SlideShare ist ein Scribd-Unternehmen logo
1 von 34
Downloaden Sie, um offline zu lesen
Submitted By:
Rohan Raj Mudvari
BIM 5th
Semester
Exam Roll No: 8568/18
TRIBHUVAN UNIVERSITY
Submitted To:
Mr. Rupesh Thapa
Lab Report of Advanced Internetworking (IT 223) using
Cisco Packet Tracer (version 8.0.0.0212) for the partial
fulfillment of BIM 5th semester.
ACKNOWLEDGEMENT
This project has been developed in order to fulfill the partial requirement
of Tribhuvan University (TU) for the completion of Bachelor of Information
Management (BIM). Although this is the individual project assigned to me during
my academic study in BIM Fifth Semester, I should remain thankful to many
persons for the successful completion of this project.
First of all, I am thankful to my respected Faculty member Rupesh Thapa
for his persistence help and clear guidance throughout my academic study and
throughout the completion of this project. His suggestions and guidance in every
stage is one of the major reasons of the successful completion of my project.
Without his proper crystal-clear guidance, my project would not have been
accomplished in time.
At last but not least, I am very thankful to respected principle of our college Dr.
Anil Lal Amatya for helping and encouraging me in every aspect of my academic
study during in this college and many-many thanks Asian School of Management
and Technology, Kathmandu, Nepal.
With Thankful
Rohan Raj Mudvari
BIM 5th Semester
Table of Contents
Description Page No.
Configuring OSPF in a Network 1-14
Configuring OSPF in an IPV6 Network 15-18
Configuring RIP in a Network 19-25
Configuring EIGRP in a Network 26-30
Configuring BGP in a Network 31
1 | P a g e
Configuring OSPF on a Network
Network Topology:
Documentation of Network end devices:
For Router-1:
Interface Description IP Address Subnet Mask
gigabitEthernet 0/0/0 Connected to Sw-1 192.14.10.1 255.255.255.0
Serial 0/1/1 Connected to R-2 10.10.10.1 255.255.255.0
Serial 0/1/0 Connected to R-3 20.20.20.1 255.255.255.0
Serial 0/2/0 Connected to R-4 30.30.30.1 255.255.255.0
Serial 0/2/1 Connected to ISP 200.200.200.1 255.255.255.0
For Router-2:
Interface Description IP Address Subnet Mask
gigabitEthernet 0/0/0 Connected to Sw-2 192.14.20.1 255.255.255.0
Serial 0/1/0 Connected to R-1 10.10.10.1 255.255.255.0
Serial 0/1/1 Connected to R-5 50.50.50.1 255.255.255.0
Router -1
Router -2
Router -4
Router -5
Router -3
2 | P a g e
For Router-3:
Interface Description IP Address Subnet Mask
gigabitEthernet 0/0/0 Connected to Sw-3 192.14.30.1 255.255.255.0
Serial 0/1/0 Connected to R-1 20.20.20.1 255.255.255.0
Serial 0/1/1 Connected to R-5 60.60.60.1 255.255.255.0
For Router-4:
Interface Description IP Address Subnet Mask
gigabitEthernet 0/0/0 Connected to Sw-4 192.14.40.1 255.255.255.0
Serial 0/1/0 Connected to R-1 30.30.30.1 255.255.255.0
Serial 0/1/1 Connected to R-5 40.40.40.1 255.255.255.0
For Router-5:
Interface Description IP Address Subnet Mask
gigabitEthernet 0/0/0 Connected to Sw-5 192.14.50.1 255.255.255.0
Serial 0/1/0 Connected to R-4 40.40.40.1 255.255.255.0
Serial 0/1/1 Connected to R-2 50.50.50.1 255.255.255.0
Serial 0/2/0 Connected to R-3 60.60.60.1 255.255.255.0
PC’s:
PC Name Ip Address Default Gateway
PC1 192.14.10.10 192.14.10.1
PC2 192.14.20.10 192.14.20.1
PC3 192.14.30.10 192.14.30.1
PC4 192.14.40.10 192.14.40.1
PC5 192.14.50.10 192.14.50.1
3 | P a g e
Operational Figure:
4 | P a g e
Configuration of Devices
For Router 1:
Router>enable
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R-1
R-1(config)#enable secret bim
R-1(config)#line console 0
R-1(config-line)#password cisco
R-1(config-line)#login
R-1(config-line)#exit
R-1(config)#line vty 0 4
R-1(config-line)#password bim123
R-1(config-line)#login
R-1(config-line)#exit
Router(config-if)#int se 0/1/0
Router(config-if)#desc ***connected to R-3***
Router(config-if)#ip address 20.20.20.1 255.255.255.0
Router(config-if)#no shut
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to down
Router(config-if)#int se 0/1/1
Router(config-if)#desc ***connected to R-2***
Router(config-if)#ip address 10.10.10.1 255.255.255.0
Router(config-if)#no shut
%LINK-5-CHANGED: Interface Serial0/1/1, changed state to down
5 | P a g e
Router(config-if)#int se 0/2/0
Router(config-if)#desc ***connected to R-4***
Router(config-if)#ip address 30.30.30.1 255.255.255.0
Router(config-if)#no shut
%LINK-5-CHANGED: Interface Serial0/2/0, changed state to down
Router(config-if)#int se 0/2/1
Router(config-if)#desc ***connected to ISP***
Router(config-if)#ip address 200.200.200.1 255.255.255.0
Router(config-if)#no shut
%LINK-5-CHANGED: Interface Serial0/2/1, changed state to down
For Router-2:
Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R-2
R-2(config)#int gig 0/0/0
R-2(config-if)#ip address 192.14.20.1 255.255.255.0
R-2(config-if)#no shut
R-2(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0/0, changed state to
up
R-2(config-if)#int se 0/1/0
R-2(config-if)#desc ***connected to R-1***
R-2(config-if)#ip address 10.10.10.2 255.255.255.0
R-2(config-if)#no shut
R-2(config-if)#
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0, changed state to up
6 | P a g e
R-2(config-if)#int se 0/1/1
R-2(config-if)#desc **connected to R-5***
R-2(config-if)#ip address 50.50.50.2 255.255.255.0
R-2(config-if)#no shut
%LINK-5-CHANGED: Interface Serial0/1/1, changed state to down
R-2(config-if)#
R-2#
%SYS-5-CONFIG_I: Configured from console by console
For Router 3:
R-2(config)#hostname R-3
R-3(config)#int gig 0/0/0
R-3(config-if)#desc ***connected to sw-3***
R-3(config-if)#ip address 192.14.30.1 255.255.255.0
R-3(config-if)#no shut
R-3(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0/0, changed state to
up
R-3(config-if)#int se 0/1/0
R-3(config-if)#ip address 20.20.20.2 255.255.255.0
R-3(config-if)#no shut
R-3(config-if)#
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0, changed state to up
R-3(config-if)#int se 0/1/1
R-3(config-if)#desc **connected to R-5***
R-3(config-if)#ip address 60.60.60.2 255.255.255.0
R-3(config-if)#no shut
%LINK-5-CHANGED: Interface Serial0/1/1, changed state to down
7 | P a g e
For Router-4:
Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int gig 0/0/0
Router(config-if)#desc **connected to sw-4**
Router(config-if)#ip address 192.14.40.1 255.255.255.0
Router(config-if)#no shut
Router(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0/0, changed state to
up
Router(config-if)#int se 0/1/0
Router(config-if)#desc **connected to R-1**
Router(config-if)#ip address 30.30.30.1 255.255.255.0
Router(config-if)#no shut
Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0, changed state to up
Router(config-if)#int se 0/1/1
Router(config-if)#desc **connected to R-5**
Router(config-if)#ip address 40.40.40.1 255.255.255.0
Router(config-if)#no shut
%LINK-5-CHANGED: Interface Serial0/1/1, changed state to down
For Router-5:
Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int gig 0/0/0
Router(config-if)#desc **connected to sw5**
Router(config-if)#ip address 192.14.50.1 255.255.255.0
Router(config-if)#no shut
Router(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0/0, changed state to up
8 | P a g e
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0/0, changed state to
up
Router(config-if)#int se 0/2/0
Router(config-if)#desc **connected to R-3**
Router(config-if)#ip address 60.60.60.1 255.255.255.0
Router(config-if)#no shut
Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/2/0, changed state to up
Router(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/2/0, changed state to up
Router(config-if)#int se 0/1/1
Router(config-if)#desc **connected to R-2**
Router(config-if)#ip address 50.50.50.1 255.255.255.0
Router(config-if)#no shut
Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/1/1, changed state to up
Router(config-if)#int se 0/1/1
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/1, changed state to up
Router(config-if)# int se 0/1/0
Router(config-if)#desc **connected to R-4**
Router(config-if)#ip address 40.40.40.1 255.255.255.0
Router(config-if)#no shut
Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to up
Router(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0, changed state to up
For ISP:
Router(config)#hostname ISP
ISP(config)#interface serial 0/1/0
ISP(config-if)#desc **connected to R-1**
ISP(config-if)#ip address 200.200.200.2 255.255.255.0
ISP(config-if)#no shut
ISP(config)#ip route 0.0.0.0 0.0.0.0 200.200.200.1
ISP(config)#end
ISP#
9 | P a g e
( Since the same protocol in a network could not be used in order to configure the ISP, we have
implemented static default protocol in ISP and Router-1 respectively)
In Router-1:
Router(config)#ip route 0.0.0.0 0.0.0.0 200.200.200.2
Router(config)#end
Configuring OSPF:
For Router-1:
Router(config)#router ospf 1
Router(config-router)#network 192.14.10.1 0.0.0.255 area 0
Router(config-router)#network 20.20.20.1 0.0.0.255 area 0
Router(config-router)#network 10.10.10.1 0.0.0.255 area 0
Router(config-router)#network 30.30.30.1 0.0.0.255 area 0
Router(config-router)#
Router#
%SYS-5-CONFIG_I: Configured from console by console
Router#wr
Building configuration...
[OK]
For Router-2:
R-2(config)#router ospf 1
R-2(config-router)#network 192.14.20.1 0.0.0.255 area 0
R-2(config-router)#network 10.10.10.1 0.0.0.255 area 0
R-2(config-router)#
01:42:52: %OSPF-5-ADJCHG: Process 1, Nbr 200.200.200.1 on Serial0/1/0 from LOADING to
FULL, Loading Done
R-2(config-router)#network 50.50.50.1 0.0.0.255 area 0
R-2(config-router)#
10 | P a g e
For Router-3:
R-3(config)#router ospf 1
R-3(config-router)#network 192.14.30.1 0.0.0.255 area 0
R-3(config-router)#network 20.20.20.1 0.0.0.255 area 0
R-3(config-router)#
01:47:57: %OSPF-5-ADJCHG: Process 1, Nbr 200.200.200.1 on Serial0/1/0 from LOADING to
FULL, Loading Done
R-3(config-router)#network 60.60.60.1 0.0.0.255 area 0
For Router-4:
Router(config)#router ospf 1
Router(config-router)#network 192.14.10.1 0.0.0.255 area 0
Router(config-router)#network 30.30.30.1 0.0.0.255 area 0
Router(config-router)#
01:52:03: %OSPF-5-ADJCHG: Process 1, Nbr 200.200.200.1 on Serial0/1/0 from LOADING to
FULL, Loading Done
Router(config-router)#network 40.40.40.1 0.0.0.255 area 0
Router(config-router)#
For Router-5:
Router(config)#router ospf 1
Router(config-router)#network 192.14.50.1 0.0.0.255 area 0
Router(config-router)#network 60.60.60.1 0.0.0.255 area 0
Router(config-router)#
01:54:36: %OSPF-5-ADJCHG: Process 1, Nbr 192.14.30.1 on Serial0/2/0 from LOADING to
FULL, Loading Done
Router(config-router)#network 50.50.50.1 0.0.0.255 area 0
Router(config-router)#
01:54:51: %OSPF-5-ADJCHG: Process 1, Nbr 192.14.20.1 on Serial0/1/1 from LOADING to
FULL, Loading Done
Router(config-router)#network 40.40.40.1 0.0.0.255 area 0
Router(config-router)#
01:55:07: %OSPF-5-ADJCHG: Process 1, Nbr 192.14.40.1 on Serial0/1/0 from LOADING to
FULL, Loading Done
11 | P a g e
In Router-1:
Router(config)#router ospf 1
Router(config-router)#default-information originate
(default-information originate tells the router to inject any default route that has been configured
on the router into the OSPF)
Pinging PC1 from PC5:
We are receiving the packets when we ping PC1 (local network of Router 1) from PC5 (local
network of Router 5). From this we can understand that, router could communicate with each
other using the OSPF protocol. For speculation, we also pinged other PC’s with each other to
make sure that protocol is working perfectly.
12 | P a g e
Pinging PC3 from PC2:
Pinging PC5 From ISP:
13 | P a g e
Router#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
192.14.30.1 0 FULL/ - 00:00:39 20.20.20.2 Serial0/1/0
192.14.40.1 0 FULL/ - 00:00:39 30.30.30.1 Serial0/2/0
192.14.20.1 0 FULL/ - 00:00:38 10.10.10.2 Serial0/1/1
Router#show ip interface brief
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0/0 192.14.10.1 YES manual up up
GigabitEthernet0/0/1 unassigned YES unset administratively down down
GigabitEthernet0/0/2 unassigned YES unset administratively down down
Serial0/1/0 20.20.20.1 YES manual up up
Serial0/1/1 10.10.10.1 YES manual up up
Serial0/2/0 30.30.30.1 YES manual up up
Serial0/2/1 200.200.200.1 YES manual up up
Vlan1 unassigned YES unset administratively down down
Router#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is 200.200.200.2 to network 0.0.0.
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.10.10.0/24 is directly connected, Serial0/1/1
L 10.10.10.1/32 is directly connected, Serial0/1/1
20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
14 | P a g e
C 20.20.20.0/24 is directly connected, Serial0/1/0
L 20.20.20.1/32 is directly connected, Serial0/1/0
30.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 30.30.30.0/24 is directly connected, Serial0/2/0
L 30.30.30.1/32 is directly connected, Serial0/2/0
40.0.0.0/24 is subnetted, 1 subnets
O 40.40.40.0/24 [110/128] via 30.30.30.1, 00:26:49, Serial0/2/0
50.0.0.0/24 is subnetted, 1 subnets
Router#show ip route ospf
40.0.0.0/24 is subnetted, 1 subnets
O 40.40.40.0 [110/128] via 30.30.30.1, 00:31:30, Serial0/2/0
50.0.0.0/24 is subnetted, 1 subnets
O 50.50.50.0 [110/128] via 10.10.10.2, 00:40:38, Serial0/1/1
60.0.0.0/24 is subnetted, 1 subnets
O 60.60.60.0 [110/128] via 20.20.20.2, 00:35:31, Serial0/1/0
O 192.14.20.0 [110/65] via 10.10.10.2, 00:40:55, Serial0/1/1
O 192.14.30.0 [110/65] via 20.20.20.2, 00:35:50, Serial0/1/0
O 192.14.40.0 [110/65] via 30.30.30.2, 00:35:58, Serial0/2/0
O 192.14.50.0 [110/129] via 20.20.20.2, 00:28:41, Serial0/1/0
[110/129] via 10.10.10.2, 00:28:41, Serial0/1/1
[110/129] via 30.30.30.1, 00:28:41, Serial0/2/0
Conclusion:
Hence, it is proved that OSPF is an Interior Gateway Protocol. Even though we have 5 routers
and a ISP in this network, for the purpose of demonstration, I have only pinged selected network
device to show that OSPF works.
Ping operation from one PC of router to another PC of another router can be easily done in
OSPF. Not only this, it is very easy to ping the ISP from any end-pint in the network.
15 | P a g e
Configuring OSPF in an IPV6 network
IPv6 is the latest version of the Internet Protocol. The IPv6 protocol can handle packets more
efficiently, improve performance and increase security. It enables internet service providers to
reduce the size of their routing tables by making them more hierarchical.
Operational Figure:
Configuration:
Router(config)#ipv6 unicast-routing
Router(config)#int gig 0/0/0
Router(config-if)#ipv6 address 2001:db8:1:1::1/64
Router(config-if)#no shutdown
Router(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0/0, changed state to up
16 | P a g e
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0/0, changed state to
up
Router(config-if)#exit
Router(config)#int se 0/1/0
Router(config-if)#ipv6 address 2001:db8:1:a001::1/64
Router(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to down
Router(config-if)#clock rate 64000
Router(config-if)#end
Router#
%SYS-5-CONFIG_I: Configured from console by console
Router(config-rtr)#router-id 1.1.1.1
Router(config-rtr)#exit
Router(config)#int gig 0/0/0
Router(config-if)#ipv6 ospf 1 area 0
Router(config-if)#int se 0/1/0
Router(config-if)#ipv6 ospf 1 area 0
Router(config-if)#end
Router#
%SYS-5-CONFIG_I: Configured from console by console
Router#wr
Building configuration...
[OK]
Router# 00:40:01: %OSPFv3-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial0/1/0 from
LOADING to FULL, Loading Done
17 | P a g e
Pinging PC1 from PC0:
Pinging PC0 from PC2:
18 | P a g e
Router#show ipv6 interface brief
GigabitEthernet0/0/0 [up/up]
FE80::201:43FF:FE27:4301
2001:DB8:1:2::1
GigabitEthernet0/0/1 [administratively down/down]
unassigned
GigabitEthernet0/0/2 [administratively down/down]
unassigned
Serial0/1/0 [up/up]
FE80::201:43FF:FE27:4301
2001:DB8:1:A001::2
Serial0/1/1 [up/up]
FE80::201:43FF:FE27:4301
2001:DB8:1:A002::1
Serial0/2/0 [administratively down/down]
unassigned
Serial0/2/1 [administratively down/down]
unassigned
Vlan1 [administratively down/down]
unassigned
Router#
Router#show ipv6 protocol
IPv6 Routing Protocol is "connected"
IPv6 Routing Protocol is "ND"
IPv6 Routing Protocol is "ospf 1"
Interfaces (Area 0)
GigabitEthernet0/0/0
Serial0/1/1
Serial0/1/0
Redistribution:
None
Router#show ipv6 ospf neighbor
Neighbor ID Pri State Dead Time Interface ID Interface
1.1.1.1 0 FULL/ - 00:00:39 4 Serial0/1/0
3.3.3.3 0 FULL/ - 00:00:33 4 Serial0/1/1
Router#
19 | P a g e
Configuring RIP in a network
RIP uses a distance vector algorithm to decide which path to put a packet on to get to its
destination. Each RIP router maintains a routing table, which is a list of all the destinations the
router knows how to reach. Each router broadcasts its entire routing table to its closest neighbors
every 30 seconds.
Operational Figure:
IP configuration for Laptop 1:
IP configuration for Laptop 2:
20 | P a g e
For Router-1:
Router>enable
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R1
R1(config)#enable secret bim
R1(config)#line console 0
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#exit
R1(config)#line vty 0 4
R1(config-line)#password bim123
R1(config-line)#login
R1(config-line)#exit
R1(config)#interface gig 0/0/0
R1(config-if)#desc **connected to sw-1**
R1(config-if)#no shut
R1(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0/0, changed state to
up
R1(config-if)#ip address 192.14.10.1 255.255.255.0
R1(config-if)#exit
R1(config)#int se 0/1/0
R1(config-if)#desc **connected to R-2**
R1(config-if)#ip address 10.10.10.1 255.255.255.0
21 | P a g e
R1(config-if)#no shut
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to down
R1(config-if)#exit
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 192.14.10.0
R1(config-router)#network 10.10.10.0
R1(config-router)#no auto-summary
R1(config-router)#end
R1#
%SYS-5-CONFIG_I: Configured from console by console
R1#wr
Building configuration...
[OK]
R1#
For Router-2:
Router>enable
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R-2
R-2(config)#enable secret bim
R-2(config)#line console 0
R-2(config-line)#password cisco
R-2(config-line)#login
R-2(config-line)#exit
22 | P a g e
R-2(config)#line vty 0 4
R-2(config-line)#password bim123
R-2(config-line)#login
R-2(config-line)#exit
R-2(config)#int gig 0/0/0
R-2(config-if)#desc **connected to sw-2**
R-2(config-if)#ip address 192.14.20.1 255.255.255.0
R-2(config-if)#no shut
R-2(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0/0, changed state to
up
R-2(config-if)#exit
R-2(config)#int se 0/1/0
R-2(config-if)#ip address 10.10.10.2 255.255.255.0
R-2(config-if)#no shut
R-2(config-if)#
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to up
R-2(config-if)#exit
R-2(config)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0, changed state to up
R-2(config)#router rip
R-2(config-router)#version 2
23 | P a g e
R-2(config-router)#network 192.14.20.0
R-2(config-router)#network 10.10.10.0
R-2(config-router)#no auto-summary
R-2(config-router)#end
R-2#
%SYS-5-CONFIG_I: Configured from console by console
R-2#wr
Building configuration...
[OK]
Pinging Laptop-1 from Laptop-2:
R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
24 | P a g e
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.10.10.0/24 is directly connected, Serial0/1/0
L 10.10.10.1/32 is directly connected, Serial0/1/0
192.14.10.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.14.10.0/24 is directly connected, GigabitEthernet0/0/0
L 192.14.10.1/32 is directly connected, GigabitEthernet0/0/0
R 192.14.20.0/24 [120/1] via 10.10.10.2, 00:00:26, Serial0/1/0
R1#show ip protocol
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 5 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 2, receive 2
Interface Send Recv Triggered RIP Key-chain
GigabitEthernet0/0/0 2 2
Serial0/1/0 2 2
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
10.0.0.0
192.14.10.0
25 | P a g e
Passive Interface(s):
Routing Information Sources:
Gateway Distance Last Update
10.10.10.2 120 00:00:16
Distance: (default is 120)
Conclusion:
Hence, we have configured RIP (Routing Information Protocol) on this network. The main
advantage of using RIP is that it is simple to configure and implement. It is easy to understand
and is generally loop free.
It prevents routing loops by implementing a limit on a number of hops allowed in path from the
source to destination.
26 | P a g e
Configuring EIGRP in a network
Enhanced Interior Gateway Routing Protocol (EIGRP) is an advanced distance-vector routing
protocol that is used on a computer network for automating routing decisions and configuration.
The protocol was designed by Cisco Systems as a proprietary protocol, available only on Cisco
routers.
Operational Figure:
For Router-1:
Router>enable
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R1
R1(config)#enable secret bim
R1(config)#line console 0
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#exit
R1(config)#line vty 0 4
R1(config-line)#password bim123
R1(config-line)#login
R1(config-line)#exit
R1(config)#interface gig 0/0/0
27 | P a g e
R1(config-if)#desc **connected to sw-1**
R1(config-if)#no shut
R1(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0/0, changed state to
up
R1(config-if)#ip address 192.14.10.1 255.255.255.0
R1(config-if)#exit
R1(config)#int se 0/1/0
R1(config-if)#desc **connected to R-2**
R1(config-if)#ip address 10.10.10.1 255.255.255.0
R1(config-if)#no shut
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to down
R1(config-if)#exit
R1(config)#router eigrp 10
R1(config-router)#network 192.14.10.0 255.255.255.0
R1(config-router)#network 10.10.10.0 255.255.255.0
R1(config-router)#exit
R1(config)#exit
R1#
%SYS-5-CONFIG_I: Configured from console by console
R1#wr
Building configuration...
[OK]
28 | P a g e
For Router 2:
Router>enable
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R-2
R-2(config)#enable secret bim
R-2(config)#line console 0
R-2(config-line)#password cisco
R-2(config-line)#login
R-2(config-line)#exit
R-2(config)#line vty 0 4
R-2(config-line)#password bim123
R-2(config-line)#login
R-2(config-line)#exit
R-2(config)#int gig 0/0/0
R-2(config-if)#desc **connected to sw-2**
R-2(config-if)#ip address 192.14.20.1 255.255.255.0
R-2(config-if)#no shut
R-2(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0/0, changed state to
up
R-2(config-if)#exit
R-2(config)#int se 0/1/0
R-2(config-if)#ip address 10.10.10.2 255.255.255.0
R-2(config-if)#no shut
29 | P a g e
R-2(config-if)#
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to up
R-2(config-if)#exit
R-2(config)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0, changed state to up
R-2(config)#router eigrp 10
R-2(config-router)#network 192.14.20.0 255.255.255.0
R-2(config-router)#network 10.10.10.0 255.255.255.0
R-2(config-router)#
%DUAL-5-NBRCHANGE: IP-EIGRP 10: Neighbor 10.10.10.1 (Serial0/1/0) is up: new
adjacency
R-2(config-router)#exit
R-2(config)#exit
R-2#
%SYS-5-CONFIG_I: Configured from console by console
R-2#wr
Building configuration...
[OK]
30 | P a g e
Conclusion:
As we can see, the current working protocol is EIGRP and it does ping from PC1 to PC2
suggesting that EIGRP is working.
In a well-designed network, EIGRP scales well and provides extremely quick convergence times
with minimal network traffic.
When a change occurs in EIGRP configured network, only routing table changes are propagated,
not the entire routing table; this reduces the load the routing protocol itself places on the
network.
31 | P a g e
Configuring BGP in a Network
Border Gateway Protocol (BGP) is a standardized exterior gateway protocol designed to
exchange routing and reachability information among autonomous systems (AS) on the Internet.
BGP is classified as a path-vector routing protocol and it makes routing decisions based on paths,
network policies, or rule-sets configured by a network administrator.
Since the Cisco Packet tracer version 8.0.0.0212 does not support the internal BGP configuration
of the network, it was not possible to show working mechanism of BGP. Nevertheless, here is
command to configure BGP in a network:
For Router-1:
Router>enable
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#router bgp 200
R1(config-router)#network 192.14.10.0
R1(config-router)#network 10.10.10.0
R1(config-router)#neighbor 192.14.20.1 remote-as 200 //ip address of neighbor router
R1(config-router)#neighbor 192.14.20.10 remote-as 200 //ip address of neighbor PC
For Router-2:
Router>enable
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#router bgp 200
R2(config-router)#network 192.14.20.0
R2(config-router)#network 10.10.10.0
R2(config-router)#neighbor 192.14.10.1 remote-as 200 //ip address of neighbor router
R2(config-router)#neighbor 192.14.10.10 remote-as 200 //ip address of neighbor PC

Weitere ähnliche Inhalte

Was ist angesagt?

E-R Diagram of College Management Systems
E-R Diagram of College Management SystemsE-R Diagram of College Management Systems
E-R Diagram of College Management SystemsOmprakash Chauhan
 
Day 1 INTRODUCTION TO IOS AND CISCO ROUTERS
Day 1 INTRODUCTION TO IOS AND CISCO ROUTERSDay 1 INTRODUCTION TO IOS AND CISCO ROUTERS
Day 1 INTRODUCTION TO IOS AND CISCO ROUTERSanilinvns
 
RIP Routing Information Protocol Extreme Networks
RIP Routing Information Protocol Extreme NetworksRIP Routing Information Protocol Extreme Networks
RIP Routing Information Protocol Extreme NetworksDani Royman Simanjuntak
 
Cisco Router Basic Configuration
Cisco Router Basic ConfigurationCisco Router Basic Configuration
Cisco Router Basic ConfigurationProf. Erwin Globio
 
Open shortest path first (ospf)
Open shortest path first (ospf)Open shortest path first (ospf)
Open shortest path first (ospf)Respa Peter
 
COMANDOS CISCO HUAWEI JUNIPER
COMANDOS CISCO HUAWEI JUNIPERCOMANDOS CISCO HUAWEI JUNIPER
COMANDOS CISCO HUAWEI JUNIPEROscarFF
 
Database Management System of Travel Co.
Database Management System of Travel Co.Database Management System of Travel Co.
Database Management System of Travel Co.Awais Ali
 
Basic isp network design
Basic isp network designBasic isp network design
Basic isp network designpiku das
 
Network Address Translation (NAT)
Network Address Translation (NAT)Network Address Translation (NAT)
Network Address Translation (NAT)Joud Khattab
 
Chapter 7 - Computer Networking a top-down Approach 7th
Chapter 7 - Computer Networking a top-down Approach 7thChapter 7 - Computer Networking a top-down Approach 7th
Chapter 7 - Computer Networking a top-down Approach 7thAndy Juan Sarango Veliz
 
TCP/IP Protocols With All Layer Description
TCP/IP Protocols With All Layer DescriptionTCP/IP Protocols With All Layer Description
TCP/IP Protocols With All Layer DescriptionShubham Khedekar
 

Was ist angesagt? (20)

E-R Diagram of College Management Systems
E-R Diagram of College Management SystemsE-R Diagram of College Management Systems
E-R Diagram of College Management Systems
 
Day 1 INTRODUCTION TO IOS AND CISCO ROUTERS
Day 1 INTRODUCTION TO IOS AND CISCO ROUTERSDay 1 INTRODUCTION TO IOS AND CISCO ROUTERS
Day 1 INTRODUCTION TO IOS AND CISCO ROUTERS
 
RIP Routing Information Protocol Extreme Networks
RIP Routing Information Protocol Extreme NetworksRIP Routing Information Protocol Extreme Networks
RIP Routing Information Protocol Extreme Networks
 
Routing ppt
Routing pptRouting ppt
Routing ppt
 
Cisco Router Basic Configuration
Cisco Router Basic ConfigurationCisco Router Basic Configuration
Cisco Router Basic Configuration
 
Open shortest path first (ospf)
Open shortest path first (ospf)Open shortest path first (ospf)
Open shortest path first (ospf)
 
Dynamic routing
Dynamic routingDynamic routing
Dynamic routing
 
COMANDOS CISCO HUAWEI JUNIPER
COMANDOS CISCO HUAWEI JUNIPERCOMANDOS CISCO HUAWEI JUNIPER
COMANDOS CISCO HUAWEI JUNIPER
 
IP Routing Tutorial
IP Routing TutorialIP Routing Tutorial
IP Routing Tutorial
 
Mime
MimeMime
Mime
 
Database Management System of Travel Co.
Database Management System of Travel Co.Database Management System of Travel Co.
Database Management System of Travel Co.
 
VLAN ON PACKET TRACER
VLAN ON PACKET TRACERVLAN ON PACKET TRACER
VLAN ON PACKET TRACER
 
OSPF Overview
OSPF OverviewOSPF Overview
OSPF Overview
 
Basic isp network design
Basic isp network designBasic isp network design
Basic isp network design
 
Network Address Translation (NAT)
Network Address Translation (NAT)Network Address Translation (NAT)
Network Address Translation (NAT)
 
IP Routing
IP RoutingIP Routing
IP Routing
 
Chapter 7 - Computer Networking a top-down Approach 7th
Chapter 7 - Computer Networking a top-down Approach 7thChapter 7 - Computer Networking a top-down Approach 7th
Chapter 7 - Computer Networking a top-down Approach 7th
 
TCP/IP Protocols With All Layer Description
TCP/IP Protocols With All Layer DescriptionTCP/IP Protocols With All Layer Description
TCP/IP Protocols With All Layer Description
 
What is Network Address Translation (NAT)
What is Network Address Translation (NAT)What is Network Address Translation (NAT)
What is Network Address Translation (NAT)
 
DHCP & DNS
DHCP & DNSDHCP & DNS
DHCP & DNS
 

Ähnlich wie Advanced Internetworking Report

2.6.6 Packet Tracer - Verify Single-Area OSPFv2 - ILM.docx
2.6.6 Packet Tracer - Verify Single-Area OSPFv2 - ILM.docx2.6.6 Packet Tracer - Verify Single-Area OSPFv2 - ILM.docx
2.6.6 Packet Tracer - Verify Single-Area OSPFv2 - ILM.docxJosimar Caitano
 
Labpractice1 configuringbasicroutingandswitchingwithanswer-121214084802-phpapp02
Labpractice1 configuringbasicroutingandswitchingwithanswer-121214084802-phpapp02Labpractice1 configuringbasicroutingandswitchingwithanswer-121214084802-phpapp02
Labpractice1 configuringbasicroutingandswitchingwithanswer-121214084802-phpapp02Abhilash Kuniyil
 
Detailed explanation of Basic router configuration
Detailed explanation of Basic router configurationDetailed explanation of Basic router configuration
Detailed explanation of Basic router configurationsamreenghauri786
 
2.7.1 Packet Tracer - Single-Area OSPFv2 Configuration - ILM.docx
2.7.1 Packet Tracer - Single-Area OSPFv2 Configuration - ILM.docx2.7.1 Packet Tracer - Single-Area OSPFv2 Configuration - ILM.docx
2.7.1 Packet Tracer - Single-Area OSPFv2 Configuration - ILM.docxJosimar Caitano
 
En erouting ilm_v4050 - para correção
En erouting ilm_v4050 - para correçãoEn erouting ilm_v4050 - para correção
En erouting ilm_v4050 - para correçãoi10network
 
Modul Tournamentof Cisco.doc
Modul Tournamentof Cisco.docModul Tournamentof Cisco.doc
Modul Tournamentof Cisco.doc36Zaini
 
City School Network- Routing & Switching Final Report
City School Network- Routing & Switching Final ReportCity School Network- Routing & Switching Final Report
City School Network- Routing & Switching Final ReportShahzeb Pirzada
 
How to Configure Routing Information Protocol (RIP)
How to Configure Routing Information Protocol (RIP)How to Configure Routing Information Protocol (RIP)
How to Configure Routing Information Protocol (RIP)IT Tech
 
All contents are Copyright © 1992–2012 Cisco Systems, Inc. A.docx
All contents are Copyright © 1992–2012 Cisco Systems, Inc. A.docxAll contents are Copyright © 1992–2012 Cisco Systems, Inc. A.docx
All contents are Copyright © 1992–2012 Cisco Systems, Inc. A.docxgalerussel59292
 
ccna project on topic company infrastructure
ccna project on topic company infrastructureccna project on topic company infrastructure
ccna project on topic company infrastructurePrince Gautam
 
Cisco CCNA- PPP Multilink Configuration
Cisco CCNA- PPP Multilink ConfigurationCisco CCNA- PPP Multilink Configuration
Cisco CCNA- PPP Multilink ConfigurationHamed Moghaddam
 
Ch5 - Packet Tracer Skills Integration Instructions To.docx
Ch5 - Packet Tracer Skills Integration Instructions To.docxCh5 - Packet Tracer Skills Integration Instructions To.docx
Ch5 - Packet Tracer Skills Integration Instructions To.docxcravennichole326
 
Lab- Full IPsec Implementation.pdf
Lab- Full IPsec Implementation.pdfLab- Full IPsec Implementation.pdf
Lab- Full IPsec Implementation.pdfNesibusami
 
Lab 9 instructions
Lab 9 instructionsLab 9 instructions
Lab 9 instructionstrayyoo
 
ccna summer training ppt ( Cisco certified network analysis) ppt. by Traun k...
ccna summer training ppt ( Cisco certified network analysis) ppt.  by Traun k...ccna summer training ppt ( Cisco certified network analysis) ppt.  by Traun k...
ccna summer training ppt ( Cisco certified network analysis) ppt. by Traun k...Tarun Khaneja
 
119163798 icnd1-practice-questions-9tut
119163798 icnd1-practice-questions-9tut119163798 icnd1-practice-questions-9tut
119163798 icnd1-practice-questions-9tutnicolelemmimg
 
Acn Experiment No 5
Acn Experiment No 5Acn Experiment No 5
Acn Experiment No 5Garima Singh
 
Networking Tutorial Goes to Basic PPP Configuration
Networking Tutorial Goes to Basic PPP ConfigurationNetworking Tutorial Goes to Basic PPP Configuration
Networking Tutorial Goes to Basic PPP Configuration3Anetwork com
 
Lab practice 1 configuring basic routing and switching (with answer)
Lab practice 1   configuring basic routing and switching (with answer) Lab practice 1   configuring basic routing and switching (with answer)
Lab practice 1 configuring basic routing and switching (with answer) Arz Sy
 

Ähnlich wie Advanced Internetworking Report (20)

2.6.6 Packet Tracer - Verify Single-Area OSPFv2 - ILM.docx
2.6.6 Packet Tracer - Verify Single-Area OSPFv2 - ILM.docx2.6.6 Packet Tracer - Verify Single-Area OSPFv2 - ILM.docx
2.6.6 Packet Tracer - Verify Single-Area OSPFv2 - ILM.docx
 
Labpractice1 configuringbasicroutingandswitchingwithanswer-121214084802-phpapp02
Labpractice1 configuringbasicroutingandswitchingwithanswer-121214084802-phpapp02Labpractice1 configuringbasicroutingandswitchingwithanswer-121214084802-phpapp02
Labpractice1 configuringbasicroutingandswitchingwithanswer-121214084802-phpapp02
 
Detailed explanation of Basic router configuration
Detailed explanation of Basic router configurationDetailed explanation of Basic router configuration
Detailed explanation of Basic router configuration
 
1
11
1
 
2.7.1 Packet Tracer - Single-Area OSPFv2 Configuration - ILM.docx
2.7.1 Packet Tracer - Single-Area OSPFv2 Configuration - ILM.docx2.7.1 Packet Tracer - Single-Area OSPFv2 Configuration - ILM.docx
2.7.1 Packet Tracer - Single-Area OSPFv2 Configuration - ILM.docx
 
En erouting ilm_v4050 - para correção
En erouting ilm_v4050 - para correçãoEn erouting ilm_v4050 - para correção
En erouting ilm_v4050 - para correção
 
Modul Tournamentof Cisco.doc
Modul Tournamentof Cisco.docModul Tournamentof Cisco.doc
Modul Tournamentof Cisco.doc
 
City School Network- Routing & Switching Final Report
City School Network- Routing & Switching Final ReportCity School Network- Routing & Switching Final Report
City School Network- Routing & Switching Final Report
 
How to Configure Routing Information Protocol (RIP)
How to Configure Routing Information Protocol (RIP)How to Configure Routing Information Protocol (RIP)
How to Configure Routing Information Protocol (RIP)
 
All contents are Copyright © 1992–2012 Cisco Systems, Inc. A.docx
All contents are Copyright © 1992–2012 Cisco Systems, Inc. A.docxAll contents are Copyright © 1992–2012 Cisco Systems, Inc. A.docx
All contents are Copyright © 1992–2012 Cisco Systems, Inc. A.docx
 
ccna project on topic company infrastructure
ccna project on topic company infrastructureccna project on topic company infrastructure
ccna project on topic company infrastructure
 
Cisco CCNA- PPP Multilink Configuration
Cisco CCNA- PPP Multilink ConfigurationCisco CCNA- PPP Multilink Configuration
Cisco CCNA- PPP Multilink Configuration
 
Ch5 - Packet Tracer Skills Integration Instructions To.docx
Ch5 - Packet Tracer Skills Integration Instructions To.docxCh5 - Packet Tracer Skills Integration Instructions To.docx
Ch5 - Packet Tracer Skills Integration Instructions To.docx
 
Lab- Full IPsec Implementation.pdf
Lab- Full IPsec Implementation.pdfLab- Full IPsec Implementation.pdf
Lab- Full IPsec Implementation.pdf
 
Lab 9 instructions
Lab 9 instructionsLab 9 instructions
Lab 9 instructions
 
ccna summer training ppt ( Cisco certified network analysis) ppt. by Traun k...
ccna summer training ppt ( Cisco certified network analysis) ppt.  by Traun k...ccna summer training ppt ( Cisco certified network analysis) ppt.  by Traun k...
ccna summer training ppt ( Cisco certified network analysis) ppt. by Traun k...
 
119163798 icnd1-practice-questions-9tut
119163798 icnd1-practice-questions-9tut119163798 icnd1-practice-questions-9tut
119163798 icnd1-practice-questions-9tut
 
Acn Experiment No 5
Acn Experiment No 5Acn Experiment No 5
Acn Experiment No 5
 
Networking Tutorial Goes to Basic PPP Configuration
Networking Tutorial Goes to Basic PPP ConfigurationNetworking Tutorial Goes to Basic PPP Configuration
Networking Tutorial Goes to Basic PPP Configuration
 
Lab practice 1 configuring basic routing and switching (with answer)
Lab practice 1   configuring basic routing and switching (with answer) Lab practice 1   configuring basic routing and switching (with answer)
Lab practice 1 configuring basic routing and switching (with answer)
 

Mehr von RohanRajMudvari

Role of AI In Cross Functional Drivers Performance
Role of AI In Cross Functional Drivers PerformanceRole of AI In Cross Functional Drivers Performance
Role of AI In Cross Functional Drivers PerformanceRohanRajMudvari
 
Amazon.com-An E-business Summary
Amazon.com-An E-business SummaryAmazon.com-An E-business Summary
Amazon.com-An E-business SummaryRohanRajMudvari
 
Enterprise Resource Planning
Enterprise Resource PlanningEnterprise Resource Planning
Enterprise Resource PlanningRohanRajMudvari
 
School Enquiry and Admission Management System Presentation
School Enquiry and Admission Management System PresentationSchool Enquiry and Admission Management System Presentation
School Enquiry and Admission Management System PresentationRohanRajMudvari
 
Online Order System Presentation
Online Order System PresentationOnline Order System Presentation
Online Order System PresentationRohanRajMudvari
 
Presentation on Loan Management System
Presentation on Loan Management SystemPresentation on Loan Management System
Presentation on Loan Management SystemRohanRajMudvari
 
Presentation on Hostel Management System
Presentation on Hostel Management SystemPresentation on Hostel Management System
Presentation on Hostel Management SystemRohanRajMudvari
 
Presentation on Library Management System
Presentation on Library Management SystemPresentation on Library Management System
Presentation on Library Management SystemRohanRajMudvari
 
Presentation on Tourism Management
Presentation on Tourism ManagementPresentation on Tourism Management
Presentation on Tourism ManagementRohanRajMudvari
 
Leo Club of Kathmandu Miracle Web based System
Leo Club of Kathmandu Miracle Web based SystemLeo Club of Kathmandu Miracle Web based System
Leo Club of Kathmandu Miracle Web based SystemRohanRajMudvari
 
Stuent Fee Management System Presentation
Stuent Fee Management System PresentationStuent Fee Management System Presentation
Stuent Fee Management System PresentationRohanRajMudvari
 
E-Commerce Site Presentation
E-Commerce Site PresentationE-Commerce Site Presentation
E-Commerce Site PresentationRohanRajMudvari
 
Online Food Ordering System Presentation
Online Food Ordering System PresentationOnline Food Ordering System Presentation
Online Food Ordering System PresentationRohanRajMudvari
 
House Rental Management System Presentation
House Rental Management System PresentationHouse Rental Management System Presentation
House Rental Management System PresentationRohanRajMudvari
 
Hotel Reservation System Presentation
Hotel Reservation System PresentationHotel Reservation System Presentation
Hotel Reservation System PresentationRohanRajMudvari
 
Online Book Store Presentation
Online Book Store PresentationOnline Book Store Presentation
Online Book Store PresentationRohanRajMudvari
 
ETOP Profile of F1Soft International Nepal
ETOP Profile of F1Soft International NepalETOP Profile of F1Soft International Nepal
ETOP Profile of F1Soft International NepalRohanRajMudvari
 
Gym Management System.pptx
Gym Management System.pptxGym Management System.pptx
Gym Management System.pptxRohanRajMudvari
 
Online Clothing Store.pptx
Online Clothing Store.pptxOnline Clothing Store.pptx
Online Clothing Store.pptxRohanRajMudvari
 

Mehr von RohanRajMudvari (19)

Role of AI In Cross Functional Drivers Performance
Role of AI In Cross Functional Drivers PerformanceRole of AI In Cross Functional Drivers Performance
Role of AI In Cross Functional Drivers Performance
 
Amazon.com-An E-business Summary
Amazon.com-An E-business SummaryAmazon.com-An E-business Summary
Amazon.com-An E-business Summary
 
Enterprise Resource Planning
Enterprise Resource PlanningEnterprise Resource Planning
Enterprise Resource Planning
 
School Enquiry and Admission Management System Presentation
School Enquiry and Admission Management System PresentationSchool Enquiry and Admission Management System Presentation
School Enquiry and Admission Management System Presentation
 
Online Order System Presentation
Online Order System PresentationOnline Order System Presentation
Online Order System Presentation
 
Presentation on Loan Management System
Presentation on Loan Management SystemPresentation on Loan Management System
Presentation on Loan Management System
 
Presentation on Hostel Management System
Presentation on Hostel Management SystemPresentation on Hostel Management System
Presentation on Hostel Management System
 
Presentation on Library Management System
Presentation on Library Management SystemPresentation on Library Management System
Presentation on Library Management System
 
Presentation on Tourism Management
Presentation on Tourism ManagementPresentation on Tourism Management
Presentation on Tourism Management
 
Leo Club of Kathmandu Miracle Web based System
Leo Club of Kathmandu Miracle Web based SystemLeo Club of Kathmandu Miracle Web based System
Leo Club of Kathmandu Miracle Web based System
 
Stuent Fee Management System Presentation
Stuent Fee Management System PresentationStuent Fee Management System Presentation
Stuent Fee Management System Presentation
 
E-Commerce Site Presentation
E-Commerce Site PresentationE-Commerce Site Presentation
E-Commerce Site Presentation
 
Online Food Ordering System Presentation
Online Food Ordering System PresentationOnline Food Ordering System Presentation
Online Food Ordering System Presentation
 
House Rental Management System Presentation
House Rental Management System PresentationHouse Rental Management System Presentation
House Rental Management System Presentation
 
Hotel Reservation System Presentation
Hotel Reservation System PresentationHotel Reservation System Presentation
Hotel Reservation System Presentation
 
Online Book Store Presentation
Online Book Store PresentationOnline Book Store Presentation
Online Book Store Presentation
 
ETOP Profile of F1Soft International Nepal
ETOP Profile of F1Soft International NepalETOP Profile of F1Soft International Nepal
ETOP Profile of F1Soft International Nepal
 
Gym Management System.pptx
Gym Management System.pptxGym Management System.pptx
Gym Management System.pptx
 
Online Clothing Store.pptx
Online Clothing Store.pptxOnline Clothing Store.pptx
Online Clothing Store.pptx
 

Kürzlich hochgeladen

ICT role in 21st century education and its challenges
ICT role in 21st century education and its challengesICT role in 21st century education and its challenges
ICT role in 21st century education and its challengesrafiqahmad00786416
 
presentation ICT roal in 21st century education
presentation ICT roal in 21st century educationpresentation ICT roal in 21st century education
presentation ICT roal in 21st century educationjfdjdjcjdnsjd
 
"I see eyes in my soup": How Delivery Hero implemented the safety system for ...
"I see eyes in my soup": How Delivery Hero implemented the safety system for ..."I see eyes in my soup": How Delivery Hero implemented the safety system for ...
"I see eyes in my soup": How Delivery Hero implemented the safety system for ...Zilliz
 
[BuildWithAI] Introduction to Gemini.pdf
[BuildWithAI] Introduction to Gemini.pdf[BuildWithAI] Introduction to Gemini.pdf
[BuildWithAI] Introduction to Gemini.pdfSandro Moreira
 
Biography Of Angeliki Cooney | Senior Vice President Life Sciences | Albany, ...
Biography Of Angeliki Cooney | Senior Vice President Life Sciences | Albany, ...Biography Of Angeliki Cooney | Senior Vice President Life Sciences | Albany, ...
Biography Of Angeliki Cooney | Senior Vice President Life Sciences | Albany, ...Angeliki Cooney
 
Why Teams call analytics are critical to your entire business
Why Teams call analytics are critical to your entire businessWhy Teams call analytics are critical to your entire business
Why Teams call analytics are critical to your entire businesspanagenda
 
TrustArc Webinar - Unlock the Power of AI-Driven Data Discovery
TrustArc Webinar - Unlock the Power of AI-Driven Data DiscoveryTrustArc Webinar - Unlock the Power of AI-Driven Data Discovery
TrustArc Webinar - Unlock the Power of AI-Driven Data DiscoveryTrustArc
 
Web Form Automation for Bonterra Impact Management (fka Social Solutions Apri...
Web Form Automation for Bonterra Impact Management (fka Social Solutions Apri...Web Form Automation for Bonterra Impact Management (fka Social Solutions Apri...
Web Form Automation for Bonterra Impact Management (fka Social Solutions Apri...Jeffrey Haguewood
 
Apidays New York 2024 - Accelerating FinTech Innovation by Vasa Krishnan, Fin...
Apidays New York 2024 - Accelerating FinTech Innovation by Vasa Krishnan, Fin...Apidays New York 2024 - Accelerating FinTech Innovation by Vasa Krishnan, Fin...
Apidays New York 2024 - Accelerating FinTech Innovation by Vasa Krishnan, Fin...apidays
 
Apidays New York 2024 - Scaling API-first by Ian Reasor and Radu Cotescu, Adobe
Apidays New York 2024 - Scaling API-first by Ian Reasor and Radu Cotescu, AdobeApidays New York 2024 - Scaling API-first by Ian Reasor and Radu Cotescu, Adobe
Apidays New York 2024 - Scaling API-first by Ian Reasor and Radu Cotescu, Adobeapidays
 
FWD Group - Insurer Innovation Award 2024
FWD Group - Insurer Innovation Award 2024FWD Group - Insurer Innovation Award 2024
FWD Group - Insurer Innovation Award 2024The Digital Insurer
 
WSO2's API Vision: Unifying Control, Empowering Developers
WSO2's API Vision: Unifying Control, Empowering DevelopersWSO2's API Vision: Unifying Control, Empowering Developers
WSO2's API Vision: Unifying Control, Empowering DevelopersWSO2
 
Modular Monolith - a Practical Alternative to Microservices @ Devoxx UK 2024
Modular Monolith - a Practical Alternative to Microservices @ Devoxx UK 2024Modular Monolith - a Practical Alternative to Microservices @ Devoxx UK 2024
Modular Monolith - a Practical Alternative to Microservices @ Devoxx UK 2024Victor Rentea
 
Six Myths about Ontologies: The Basics of Formal Ontology
Six Myths about Ontologies: The Basics of Formal OntologySix Myths about Ontologies: The Basics of Formal Ontology
Six Myths about Ontologies: The Basics of Formal Ontologyjohnbeverley2021
 
Strategies for Landing an Oracle DBA Job as a Fresher
Strategies for Landing an Oracle DBA Job as a FresherStrategies for Landing an Oracle DBA Job as a Fresher
Strategies for Landing an Oracle DBA Job as a FresherRemote DBA Services
 
Navigating the Deluge_ Dubai Floods and the Resilience of Dubai International...
Navigating the Deluge_ Dubai Floods and the Resilience of Dubai International...Navigating the Deluge_ Dubai Floods and the Resilience of Dubai International...
Navigating the Deluge_ Dubai Floods and the Resilience of Dubai International...Orbitshub
 
Elevate Developer Efficiency & build GenAI Application with Amazon Q​
Elevate Developer Efficiency & build GenAI Application with Amazon Q​Elevate Developer Efficiency & build GenAI Application with Amazon Q​
Elevate Developer Efficiency & build GenAI Application with Amazon Q​Bhuvaneswari Subramani
 
Cloud Frontiers: A Deep Dive into Serverless Spatial Data and FME
Cloud Frontiers:  A Deep Dive into Serverless Spatial Data and FMECloud Frontiers:  A Deep Dive into Serverless Spatial Data and FME
Cloud Frontiers: A Deep Dive into Serverless Spatial Data and FMESafe Software
 
Architecting Cloud Native Applications
Architecting Cloud Native ApplicationsArchitecting Cloud Native Applications
Architecting Cloud Native ApplicationsWSO2
 
Apidays New York 2024 - APIs in 2030: The Risk of Technological Sleepwalk by ...
Apidays New York 2024 - APIs in 2030: The Risk of Technological Sleepwalk by ...Apidays New York 2024 - APIs in 2030: The Risk of Technological Sleepwalk by ...
Apidays New York 2024 - APIs in 2030: The Risk of Technological Sleepwalk by ...apidays
 

Kürzlich hochgeladen (20)

ICT role in 21st century education and its challenges
ICT role in 21st century education and its challengesICT role in 21st century education and its challenges
ICT role in 21st century education and its challenges
 
presentation ICT roal in 21st century education
presentation ICT roal in 21st century educationpresentation ICT roal in 21st century education
presentation ICT roal in 21st century education
 
"I see eyes in my soup": How Delivery Hero implemented the safety system for ...
"I see eyes in my soup": How Delivery Hero implemented the safety system for ..."I see eyes in my soup": How Delivery Hero implemented the safety system for ...
"I see eyes in my soup": How Delivery Hero implemented the safety system for ...
 
[BuildWithAI] Introduction to Gemini.pdf
[BuildWithAI] Introduction to Gemini.pdf[BuildWithAI] Introduction to Gemini.pdf
[BuildWithAI] Introduction to Gemini.pdf
 
Biography Of Angeliki Cooney | Senior Vice President Life Sciences | Albany, ...
Biography Of Angeliki Cooney | Senior Vice President Life Sciences | Albany, ...Biography Of Angeliki Cooney | Senior Vice President Life Sciences | Albany, ...
Biography Of Angeliki Cooney | Senior Vice President Life Sciences | Albany, ...
 
Why Teams call analytics are critical to your entire business
Why Teams call analytics are critical to your entire businessWhy Teams call analytics are critical to your entire business
Why Teams call analytics are critical to your entire business
 
TrustArc Webinar - Unlock the Power of AI-Driven Data Discovery
TrustArc Webinar - Unlock the Power of AI-Driven Data DiscoveryTrustArc Webinar - Unlock the Power of AI-Driven Data Discovery
TrustArc Webinar - Unlock the Power of AI-Driven Data Discovery
 
Web Form Automation for Bonterra Impact Management (fka Social Solutions Apri...
Web Form Automation for Bonterra Impact Management (fka Social Solutions Apri...Web Form Automation for Bonterra Impact Management (fka Social Solutions Apri...
Web Form Automation for Bonterra Impact Management (fka Social Solutions Apri...
 
Apidays New York 2024 - Accelerating FinTech Innovation by Vasa Krishnan, Fin...
Apidays New York 2024 - Accelerating FinTech Innovation by Vasa Krishnan, Fin...Apidays New York 2024 - Accelerating FinTech Innovation by Vasa Krishnan, Fin...
Apidays New York 2024 - Accelerating FinTech Innovation by Vasa Krishnan, Fin...
 
Apidays New York 2024 - Scaling API-first by Ian Reasor and Radu Cotescu, Adobe
Apidays New York 2024 - Scaling API-first by Ian Reasor and Radu Cotescu, AdobeApidays New York 2024 - Scaling API-first by Ian Reasor and Radu Cotescu, Adobe
Apidays New York 2024 - Scaling API-first by Ian Reasor and Radu Cotescu, Adobe
 
FWD Group - Insurer Innovation Award 2024
FWD Group - Insurer Innovation Award 2024FWD Group - Insurer Innovation Award 2024
FWD Group - Insurer Innovation Award 2024
 
WSO2's API Vision: Unifying Control, Empowering Developers
WSO2's API Vision: Unifying Control, Empowering DevelopersWSO2's API Vision: Unifying Control, Empowering Developers
WSO2's API Vision: Unifying Control, Empowering Developers
 
Modular Monolith - a Practical Alternative to Microservices @ Devoxx UK 2024
Modular Monolith - a Practical Alternative to Microservices @ Devoxx UK 2024Modular Monolith - a Practical Alternative to Microservices @ Devoxx UK 2024
Modular Monolith - a Practical Alternative to Microservices @ Devoxx UK 2024
 
Six Myths about Ontologies: The Basics of Formal Ontology
Six Myths about Ontologies: The Basics of Formal OntologySix Myths about Ontologies: The Basics of Formal Ontology
Six Myths about Ontologies: The Basics of Formal Ontology
 
Strategies for Landing an Oracle DBA Job as a Fresher
Strategies for Landing an Oracle DBA Job as a FresherStrategies for Landing an Oracle DBA Job as a Fresher
Strategies for Landing an Oracle DBA Job as a Fresher
 
Navigating the Deluge_ Dubai Floods and the Resilience of Dubai International...
Navigating the Deluge_ Dubai Floods and the Resilience of Dubai International...Navigating the Deluge_ Dubai Floods and the Resilience of Dubai International...
Navigating the Deluge_ Dubai Floods and the Resilience of Dubai International...
 
Elevate Developer Efficiency & build GenAI Application with Amazon Q​
Elevate Developer Efficiency & build GenAI Application with Amazon Q​Elevate Developer Efficiency & build GenAI Application with Amazon Q​
Elevate Developer Efficiency & build GenAI Application with Amazon Q​
 
Cloud Frontiers: A Deep Dive into Serverless Spatial Data and FME
Cloud Frontiers:  A Deep Dive into Serverless Spatial Data and FMECloud Frontiers:  A Deep Dive into Serverless Spatial Data and FME
Cloud Frontiers: A Deep Dive into Serverless Spatial Data and FME
 
Architecting Cloud Native Applications
Architecting Cloud Native ApplicationsArchitecting Cloud Native Applications
Architecting Cloud Native Applications
 
Apidays New York 2024 - APIs in 2030: The Risk of Technological Sleepwalk by ...
Apidays New York 2024 - APIs in 2030: The Risk of Technological Sleepwalk by ...Apidays New York 2024 - APIs in 2030: The Risk of Technological Sleepwalk by ...
Apidays New York 2024 - APIs in 2030: The Risk of Technological Sleepwalk by ...
 

Advanced Internetworking Report

  • 1. Submitted By: Rohan Raj Mudvari BIM 5th Semester Exam Roll No: 8568/18 TRIBHUVAN UNIVERSITY Submitted To: Mr. Rupesh Thapa Lab Report of Advanced Internetworking (IT 223) using Cisco Packet Tracer (version 8.0.0.0212) for the partial fulfillment of BIM 5th semester.
  • 2. ACKNOWLEDGEMENT This project has been developed in order to fulfill the partial requirement of Tribhuvan University (TU) for the completion of Bachelor of Information Management (BIM). Although this is the individual project assigned to me during my academic study in BIM Fifth Semester, I should remain thankful to many persons for the successful completion of this project. First of all, I am thankful to my respected Faculty member Rupesh Thapa for his persistence help and clear guidance throughout my academic study and throughout the completion of this project. His suggestions and guidance in every stage is one of the major reasons of the successful completion of my project. Without his proper crystal-clear guidance, my project would not have been accomplished in time. At last but not least, I am very thankful to respected principle of our college Dr. Anil Lal Amatya for helping and encouraging me in every aspect of my academic study during in this college and many-many thanks Asian School of Management and Technology, Kathmandu, Nepal. With Thankful Rohan Raj Mudvari BIM 5th Semester
  • 3. Table of Contents Description Page No. Configuring OSPF in a Network 1-14 Configuring OSPF in an IPV6 Network 15-18 Configuring RIP in a Network 19-25 Configuring EIGRP in a Network 26-30 Configuring BGP in a Network 31
  • 4. 1 | P a g e Configuring OSPF on a Network Network Topology: Documentation of Network end devices: For Router-1: Interface Description IP Address Subnet Mask gigabitEthernet 0/0/0 Connected to Sw-1 192.14.10.1 255.255.255.0 Serial 0/1/1 Connected to R-2 10.10.10.1 255.255.255.0 Serial 0/1/0 Connected to R-3 20.20.20.1 255.255.255.0 Serial 0/2/0 Connected to R-4 30.30.30.1 255.255.255.0 Serial 0/2/1 Connected to ISP 200.200.200.1 255.255.255.0 For Router-2: Interface Description IP Address Subnet Mask gigabitEthernet 0/0/0 Connected to Sw-2 192.14.20.1 255.255.255.0 Serial 0/1/0 Connected to R-1 10.10.10.1 255.255.255.0 Serial 0/1/1 Connected to R-5 50.50.50.1 255.255.255.0 Router -1 Router -2 Router -4 Router -5 Router -3
  • 5. 2 | P a g e For Router-3: Interface Description IP Address Subnet Mask gigabitEthernet 0/0/0 Connected to Sw-3 192.14.30.1 255.255.255.0 Serial 0/1/0 Connected to R-1 20.20.20.1 255.255.255.0 Serial 0/1/1 Connected to R-5 60.60.60.1 255.255.255.0 For Router-4: Interface Description IP Address Subnet Mask gigabitEthernet 0/0/0 Connected to Sw-4 192.14.40.1 255.255.255.0 Serial 0/1/0 Connected to R-1 30.30.30.1 255.255.255.0 Serial 0/1/1 Connected to R-5 40.40.40.1 255.255.255.0 For Router-5: Interface Description IP Address Subnet Mask gigabitEthernet 0/0/0 Connected to Sw-5 192.14.50.1 255.255.255.0 Serial 0/1/0 Connected to R-4 40.40.40.1 255.255.255.0 Serial 0/1/1 Connected to R-2 50.50.50.1 255.255.255.0 Serial 0/2/0 Connected to R-3 60.60.60.1 255.255.255.0 PC’s: PC Name Ip Address Default Gateway PC1 192.14.10.10 192.14.10.1 PC2 192.14.20.10 192.14.20.1 PC3 192.14.30.10 192.14.30.1 PC4 192.14.40.10 192.14.40.1 PC5 192.14.50.10 192.14.50.1
  • 6. 3 | P a g e Operational Figure:
  • 7. 4 | P a g e Configuration of Devices For Router 1: Router>enable Router#config t Enter configuration commands, one per line. End with CNTL/Z. Router(config)#hostname R-1 R-1(config)#enable secret bim R-1(config)#line console 0 R-1(config-line)#password cisco R-1(config-line)#login R-1(config-line)#exit R-1(config)#line vty 0 4 R-1(config-line)#password bim123 R-1(config-line)#login R-1(config-line)#exit Router(config-if)#int se 0/1/0 Router(config-if)#desc ***connected to R-3*** Router(config-if)#ip address 20.20.20.1 255.255.255.0 Router(config-if)#no shut %LINK-5-CHANGED: Interface Serial0/1/0, changed state to down Router(config-if)#int se 0/1/1 Router(config-if)#desc ***connected to R-2*** Router(config-if)#ip address 10.10.10.1 255.255.255.0 Router(config-if)#no shut %LINK-5-CHANGED: Interface Serial0/1/1, changed state to down
  • 8. 5 | P a g e Router(config-if)#int se 0/2/0 Router(config-if)#desc ***connected to R-4*** Router(config-if)#ip address 30.30.30.1 255.255.255.0 Router(config-if)#no shut %LINK-5-CHANGED: Interface Serial0/2/0, changed state to down Router(config-if)#int se 0/2/1 Router(config-if)#desc ***connected to ISP*** Router(config-if)#ip address 200.200.200.1 255.255.255.0 Router(config-if)#no shut %LINK-5-CHANGED: Interface Serial0/2/1, changed state to down For Router-2: Router>en Router#config t Enter configuration commands, one per line. End with CNTL/Z. Router(config)#hostname R-2 R-2(config)#int gig 0/0/0 R-2(config-if)#ip address 192.14.20.1 255.255.255.0 R-2(config-if)#no shut R-2(config-if)# %LINK-5-CHANGED: Interface GigabitEthernet0/0/0, changed state to up %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0/0, changed state to up R-2(config-if)#int se 0/1/0 R-2(config-if)#desc ***connected to R-1*** R-2(config-if)#ip address 10.10.10.2 255.255.255.0 R-2(config-if)#no shut R-2(config-if)# %LINK-5-CHANGED: Interface Serial0/1/0, changed state to up %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0, changed state to up
  • 9. 6 | P a g e R-2(config-if)#int se 0/1/1 R-2(config-if)#desc **connected to R-5*** R-2(config-if)#ip address 50.50.50.2 255.255.255.0 R-2(config-if)#no shut %LINK-5-CHANGED: Interface Serial0/1/1, changed state to down R-2(config-if)# R-2# %SYS-5-CONFIG_I: Configured from console by console For Router 3: R-2(config)#hostname R-3 R-3(config)#int gig 0/0/0 R-3(config-if)#desc ***connected to sw-3*** R-3(config-if)#ip address 192.14.30.1 255.255.255.0 R-3(config-if)#no shut R-3(config-if)# %LINK-5-CHANGED: Interface GigabitEthernet0/0/0, changed state to up %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0/0, changed state to up R-3(config-if)#int se 0/1/0 R-3(config-if)#ip address 20.20.20.2 255.255.255.0 R-3(config-if)#no shut R-3(config-if)# %LINK-5-CHANGED: Interface Serial0/1/0, changed state to up %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0, changed state to up R-3(config-if)#int se 0/1/1 R-3(config-if)#desc **connected to R-5*** R-3(config-if)#ip address 60.60.60.2 255.255.255.0 R-3(config-if)#no shut %LINK-5-CHANGED: Interface Serial0/1/1, changed state to down
  • 10. 7 | P a g e For Router-4: Router>en Router#config t Enter configuration commands, one per line. End with CNTL/Z. Router(config)#int gig 0/0/0 Router(config-if)#desc **connected to sw-4** Router(config-if)#ip address 192.14.40.1 255.255.255.0 Router(config-if)#no shut Router(config-if)# %LINK-5-CHANGED: Interface GigabitEthernet0/0/0, changed state to up %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0/0, changed state to up Router(config-if)#int se 0/1/0 Router(config-if)#desc **connected to R-1** Router(config-if)#ip address 30.30.30.1 255.255.255.0 Router(config-if)#no shut Router(config-if)# %LINK-5-CHANGED: Interface Serial0/1/0, changed state to up %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0, changed state to up Router(config-if)#int se 0/1/1 Router(config-if)#desc **connected to R-5** Router(config-if)#ip address 40.40.40.1 255.255.255.0 Router(config-if)#no shut %LINK-5-CHANGED: Interface Serial0/1/1, changed state to down For Router-5: Router>en Router#config t Enter configuration commands, one per line. End with CNTL/Z. Router(config)#int gig 0/0/0 Router(config-if)#desc **connected to sw5** Router(config-if)#ip address 192.14.50.1 255.255.255.0 Router(config-if)#no shut Router(config-if)# %LINK-5-CHANGED: Interface GigabitEthernet0/0/0, changed state to up
  • 11. 8 | P a g e %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0/0, changed state to up Router(config-if)#int se 0/2/0 Router(config-if)#desc **connected to R-3** Router(config-if)#ip address 60.60.60.1 255.255.255.0 Router(config-if)#no shut Router(config-if)# %LINK-5-CHANGED: Interface Serial0/2/0, changed state to up Router(config-if)# %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/2/0, changed state to up Router(config-if)#int se 0/1/1 Router(config-if)#desc **connected to R-2** Router(config-if)#ip address 50.50.50.1 255.255.255.0 Router(config-if)#no shut Router(config-if)# %LINK-5-CHANGED: Interface Serial0/1/1, changed state to up Router(config-if)#int se 0/1/1 %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/1, changed state to up Router(config-if)# int se 0/1/0 Router(config-if)#desc **connected to R-4** Router(config-if)#ip address 40.40.40.1 255.255.255.0 Router(config-if)#no shut Router(config-if)# %LINK-5-CHANGED: Interface Serial0/1/0, changed state to up Router(config-if)# %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0, changed state to up For ISP: Router(config)#hostname ISP ISP(config)#interface serial 0/1/0 ISP(config-if)#desc **connected to R-1** ISP(config-if)#ip address 200.200.200.2 255.255.255.0 ISP(config-if)#no shut ISP(config)#ip route 0.0.0.0 0.0.0.0 200.200.200.1 ISP(config)#end ISP#
  • 12. 9 | P a g e ( Since the same protocol in a network could not be used in order to configure the ISP, we have implemented static default protocol in ISP and Router-1 respectively) In Router-1: Router(config)#ip route 0.0.0.0 0.0.0.0 200.200.200.2 Router(config)#end Configuring OSPF: For Router-1: Router(config)#router ospf 1 Router(config-router)#network 192.14.10.1 0.0.0.255 area 0 Router(config-router)#network 20.20.20.1 0.0.0.255 area 0 Router(config-router)#network 10.10.10.1 0.0.0.255 area 0 Router(config-router)#network 30.30.30.1 0.0.0.255 area 0 Router(config-router)# Router# %SYS-5-CONFIG_I: Configured from console by console Router#wr Building configuration... [OK] For Router-2: R-2(config)#router ospf 1 R-2(config-router)#network 192.14.20.1 0.0.0.255 area 0 R-2(config-router)#network 10.10.10.1 0.0.0.255 area 0 R-2(config-router)# 01:42:52: %OSPF-5-ADJCHG: Process 1, Nbr 200.200.200.1 on Serial0/1/0 from LOADING to FULL, Loading Done R-2(config-router)#network 50.50.50.1 0.0.0.255 area 0 R-2(config-router)#
  • 13. 10 | P a g e For Router-3: R-3(config)#router ospf 1 R-3(config-router)#network 192.14.30.1 0.0.0.255 area 0 R-3(config-router)#network 20.20.20.1 0.0.0.255 area 0 R-3(config-router)# 01:47:57: %OSPF-5-ADJCHG: Process 1, Nbr 200.200.200.1 on Serial0/1/0 from LOADING to FULL, Loading Done R-3(config-router)#network 60.60.60.1 0.0.0.255 area 0 For Router-4: Router(config)#router ospf 1 Router(config-router)#network 192.14.10.1 0.0.0.255 area 0 Router(config-router)#network 30.30.30.1 0.0.0.255 area 0 Router(config-router)# 01:52:03: %OSPF-5-ADJCHG: Process 1, Nbr 200.200.200.1 on Serial0/1/0 from LOADING to FULL, Loading Done Router(config-router)#network 40.40.40.1 0.0.0.255 area 0 Router(config-router)# For Router-5: Router(config)#router ospf 1 Router(config-router)#network 192.14.50.1 0.0.0.255 area 0 Router(config-router)#network 60.60.60.1 0.0.0.255 area 0 Router(config-router)# 01:54:36: %OSPF-5-ADJCHG: Process 1, Nbr 192.14.30.1 on Serial0/2/0 from LOADING to FULL, Loading Done Router(config-router)#network 50.50.50.1 0.0.0.255 area 0 Router(config-router)# 01:54:51: %OSPF-5-ADJCHG: Process 1, Nbr 192.14.20.1 on Serial0/1/1 from LOADING to FULL, Loading Done Router(config-router)#network 40.40.40.1 0.0.0.255 area 0 Router(config-router)# 01:55:07: %OSPF-5-ADJCHG: Process 1, Nbr 192.14.40.1 on Serial0/1/0 from LOADING to FULL, Loading Done
  • 14. 11 | P a g e In Router-1: Router(config)#router ospf 1 Router(config-router)#default-information originate (default-information originate tells the router to inject any default route that has been configured on the router into the OSPF) Pinging PC1 from PC5: We are receiving the packets when we ping PC1 (local network of Router 1) from PC5 (local network of Router 5). From this we can understand that, router could communicate with each other using the OSPF protocol. For speculation, we also pinged other PC’s with each other to make sure that protocol is working perfectly.
  • 15. 12 | P a g e Pinging PC3 from PC2: Pinging PC5 From ISP:
  • 16. 13 | P a g e Router#show ip ospf neighbor Neighbor ID Pri State Dead Time Address Interface 192.14.30.1 0 FULL/ - 00:00:39 20.20.20.2 Serial0/1/0 192.14.40.1 0 FULL/ - 00:00:39 30.30.30.1 Serial0/2/0 192.14.20.1 0 FULL/ - 00:00:38 10.10.10.2 Serial0/1/1 Router#show ip interface brief Interface IP-Address OK? Method Status Protocol GigabitEthernet0/0/0 192.14.10.1 YES manual up up GigabitEthernet0/0/1 unassigned YES unset administratively down down GigabitEthernet0/0/2 unassigned YES unset administratively down down Serial0/1/0 20.20.20.1 YES manual up up Serial0/1/1 10.10.10.1 YES manual up up Serial0/2/0 30.30.30.1 YES manual up up Serial0/2/1 200.200.200.1 YES manual up up Vlan1 unassigned YES unset administratively down down Router#show ip route Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area * - candidate default, U - per-user static route, o - ODR P - periodic downloaded static route Gateway of last resort is 200.200.200.2 to network 0.0.0. 10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks C 10.10.10.0/24 is directly connected, Serial0/1/1 L 10.10.10.1/32 is directly connected, Serial0/1/1 20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
  • 17. 14 | P a g e C 20.20.20.0/24 is directly connected, Serial0/1/0 L 20.20.20.1/32 is directly connected, Serial0/1/0 30.0.0.0/8 is variably subnetted, 2 subnets, 2 masks C 30.30.30.0/24 is directly connected, Serial0/2/0 L 30.30.30.1/32 is directly connected, Serial0/2/0 40.0.0.0/24 is subnetted, 1 subnets O 40.40.40.0/24 [110/128] via 30.30.30.1, 00:26:49, Serial0/2/0 50.0.0.0/24 is subnetted, 1 subnets Router#show ip route ospf 40.0.0.0/24 is subnetted, 1 subnets O 40.40.40.0 [110/128] via 30.30.30.1, 00:31:30, Serial0/2/0 50.0.0.0/24 is subnetted, 1 subnets O 50.50.50.0 [110/128] via 10.10.10.2, 00:40:38, Serial0/1/1 60.0.0.0/24 is subnetted, 1 subnets O 60.60.60.0 [110/128] via 20.20.20.2, 00:35:31, Serial0/1/0 O 192.14.20.0 [110/65] via 10.10.10.2, 00:40:55, Serial0/1/1 O 192.14.30.0 [110/65] via 20.20.20.2, 00:35:50, Serial0/1/0 O 192.14.40.0 [110/65] via 30.30.30.2, 00:35:58, Serial0/2/0 O 192.14.50.0 [110/129] via 20.20.20.2, 00:28:41, Serial0/1/0 [110/129] via 10.10.10.2, 00:28:41, Serial0/1/1 [110/129] via 30.30.30.1, 00:28:41, Serial0/2/0 Conclusion: Hence, it is proved that OSPF is an Interior Gateway Protocol. Even though we have 5 routers and a ISP in this network, for the purpose of demonstration, I have only pinged selected network device to show that OSPF works. Ping operation from one PC of router to another PC of another router can be easily done in OSPF. Not only this, it is very easy to ping the ISP from any end-pint in the network.
  • 18. 15 | P a g e Configuring OSPF in an IPV6 network IPv6 is the latest version of the Internet Protocol. The IPv6 protocol can handle packets more efficiently, improve performance and increase security. It enables internet service providers to reduce the size of their routing tables by making them more hierarchical. Operational Figure: Configuration: Router(config)#ipv6 unicast-routing Router(config)#int gig 0/0/0 Router(config-if)#ipv6 address 2001:db8:1:1::1/64 Router(config-if)#no shutdown Router(config-if)# %LINK-5-CHANGED: Interface GigabitEthernet0/0/0, changed state to up
  • 19. 16 | P a g e %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0/0, changed state to up Router(config-if)#exit Router(config)#int se 0/1/0 Router(config-if)#ipv6 address 2001:db8:1:a001::1/64 Router(config-if)#no shutdown %LINK-5-CHANGED: Interface Serial0/1/0, changed state to down Router(config-if)#clock rate 64000 Router(config-if)#end Router# %SYS-5-CONFIG_I: Configured from console by console Router(config-rtr)#router-id 1.1.1.1 Router(config-rtr)#exit Router(config)#int gig 0/0/0 Router(config-if)#ipv6 ospf 1 area 0 Router(config-if)#int se 0/1/0 Router(config-if)#ipv6 ospf 1 area 0 Router(config-if)#end Router# %SYS-5-CONFIG_I: Configured from console by console Router#wr Building configuration... [OK] Router# 00:40:01: %OSPFv3-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial0/1/0 from LOADING to FULL, Loading Done
  • 20. 17 | P a g e Pinging PC1 from PC0: Pinging PC0 from PC2:
  • 21. 18 | P a g e Router#show ipv6 interface brief GigabitEthernet0/0/0 [up/up] FE80::201:43FF:FE27:4301 2001:DB8:1:2::1 GigabitEthernet0/0/1 [administratively down/down] unassigned GigabitEthernet0/0/2 [administratively down/down] unassigned Serial0/1/0 [up/up] FE80::201:43FF:FE27:4301 2001:DB8:1:A001::2 Serial0/1/1 [up/up] FE80::201:43FF:FE27:4301 2001:DB8:1:A002::1 Serial0/2/0 [administratively down/down] unassigned Serial0/2/1 [administratively down/down] unassigned Vlan1 [administratively down/down] unassigned Router# Router#show ipv6 protocol IPv6 Routing Protocol is "connected" IPv6 Routing Protocol is "ND" IPv6 Routing Protocol is "ospf 1" Interfaces (Area 0) GigabitEthernet0/0/0 Serial0/1/1 Serial0/1/0 Redistribution: None Router#show ipv6 ospf neighbor Neighbor ID Pri State Dead Time Interface ID Interface 1.1.1.1 0 FULL/ - 00:00:39 4 Serial0/1/0 3.3.3.3 0 FULL/ - 00:00:33 4 Serial0/1/1 Router#
  • 22. 19 | P a g e Configuring RIP in a network RIP uses a distance vector algorithm to decide which path to put a packet on to get to its destination. Each RIP router maintains a routing table, which is a list of all the destinations the router knows how to reach. Each router broadcasts its entire routing table to its closest neighbors every 30 seconds. Operational Figure: IP configuration for Laptop 1: IP configuration for Laptop 2:
  • 23. 20 | P a g e For Router-1: Router>enable Router#config t Enter configuration commands, one per line. End with CNTL/Z. Router(config)#hostname R1 R1(config)#enable secret bim R1(config)#line console 0 R1(config-line)#password cisco R1(config-line)#login R1(config-line)#exit R1(config)#line vty 0 4 R1(config-line)#password bim123 R1(config-line)#login R1(config-line)#exit R1(config)#interface gig 0/0/0 R1(config-if)#desc **connected to sw-1** R1(config-if)#no shut R1(config-if)# %LINK-5-CHANGED: Interface GigabitEthernet0/0/0, changed state to up %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0/0, changed state to up R1(config-if)#ip address 192.14.10.1 255.255.255.0 R1(config-if)#exit R1(config)#int se 0/1/0 R1(config-if)#desc **connected to R-2** R1(config-if)#ip address 10.10.10.1 255.255.255.0
  • 24. 21 | P a g e R1(config-if)#no shut %LINK-5-CHANGED: Interface Serial0/1/0, changed state to down R1(config-if)#exit R1(config)#router rip R1(config-router)#version 2 R1(config-router)#network 192.14.10.0 R1(config-router)#network 10.10.10.0 R1(config-router)#no auto-summary R1(config-router)#end R1# %SYS-5-CONFIG_I: Configured from console by console R1#wr Building configuration... [OK] R1# For Router-2: Router>enable Router#config t Enter configuration commands, one per line. End with CNTL/Z. Router(config)#hostname R-2 R-2(config)#enable secret bim R-2(config)#line console 0 R-2(config-line)#password cisco R-2(config-line)#login R-2(config-line)#exit
  • 25. 22 | P a g e R-2(config)#line vty 0 4 R-2(config-line)#password bim123 R-2(config-line)#login R-2(config-line)#exit R-2(config)#int gig 0/0/0 R-2(config-if)#desc **connected to sw-2** R-2(config-if)#ip address 192.14.20.1 255.255.255.0 R-2(config-if)#no shut R-2(config-if)# %LINK-5-CHANGED: Interface GigabitEthernet0/0/0, changed state to up %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0/0, changed state to up R-2(config-if)#exit R-2(config)#int se 0/1/0 R-2(config-if)#ip address 10.10.10.2 255.255.255.0 R-2(config-if)#no shut R-2(config-if)# %LINK-5-CHANGED: Interface Serial0/1/0, changed state to up R-2(config-if)#exit R-2(config)# %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0, changed state to up R-2(config)#router rip R-2(config-router)#version 2
  • 26. 23 | P a g e R-2(config-router)#network 192.14.20.0 R-2(config-router)#network 10.10.10.0 R-2(config-router)#no auto-summary R-2(config-router)#end R-2# %SYS-5-CONFIG_I: Configured from console by console R-2#wr Building configuration... [OK] Pinging Laptop-1 from Laptop-2: R1#show ip route Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
  • 27. 24 | P a g e * - candidate default, U - per-user static route, o - ODR P - periodic downloaded static route Gateway of last resort is not set 10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks C 10.10.10.0/24 is directly connected, Serial0/1/0 L 10.10.10.1/32 is directly connected, Serial0/1/0 192.14.10.0/24 is variably subnetted, 2 subnets, 2 masks C 192.14.10.0/24 is directly connected, GigabitEthernet0/0/0 L 192.14.10.1/32 is directly connected, GigabitEthernet0/0/0 R 192.14.20.0/24 [120/1] via 10.10.10.2, 00:00:26, Serial0/1/0 R1#show ip protocol Routing Protocol is "rip" Sending updates every 30 seconds, next due in 5 seconds Invalid after 180 seconds, hold down 180, flushed after 240 Outgoing update filter list for all interfaces is not set Incoming update filter list for all interfaces is not set Redistributing: rip Default version control: send version 2, receive 2 Interface Send Recv Triggered RIP Key-chain GigabitEthernet0/0/0 2 2 Serial0/1/0 2 2 Automatic network summarization is not in effect Maximum path: 4 Routing for Networks: 10.0.0.0 192.14.10.0
  • 28. 25 | P a g e Passive Interface(s): Routing Information Sources: Gateway Distance Last Update 10.10.10.2 120 00:00:16 Distance: (default is 120) Conclusion: Hence, we have configured RIP (Routing Information Protocol) on this network. The main advantage of using RIP is that it is simple to configure and implement. It is easy to understand and is generally loop free. It prevents routing loops by implementing a limit on a number of hops allowed in path from the source to destination.
  • 29. 26 | P a g e Configuring EIGRP in a network Enhanced Interior Gateway Routing Protocol (EIGRP) is an advanced distance-vector routing protocol that is used on a computer network for automating routing decisions and configuration. The protocol was designed by Cisco Systems as a proprietary protocol, available only on Cisco routers. Operational Figure: For Router-1: Router>enable Router#config t Enter configuration commands, one per line. End with CNTL/Z. Router(config)#hostname R1 R1(config)#enable secret bim R1(config)#line console 0 R1(config-line)#password cisco R1(config-line)#login R1(config-line)#exit R1(config)#line vty 0 4 R1(config-line)#password bim123 R1(config-line)#login R1(config-line)#exit R1(config)#interface gig 0/0/0
  • 30. 27 | P a g e R1(config-if)#desc **connected to sw-1** R1(config-if)#no shut R1(config-if)# %LINK-5-CHANGED: Interface GigabitEthernet0/0/0, changed state to up %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0/0, changed state to up R1(config-if)#ip address 192.14.10.1 255.255.255.0 R1(config-if)#exit R1(config)#int se 0/1/0 R1(config-if)#desc **connected to R-2** R1(config-if)#ip address 10.10.10.1 255.255.255.0 R1(config-if)#no shut %LINK-5-CHANGED: Interface Serial0/1/0, changed state to down R1(config-if)#exit R1(config)#router eigrp 10 R1(config-router)#network 192.14.10.0 255.255.255.0 R1(config-router)#network 10.10.10.0 255.255.255.0 R1(config-router)#exit R1(config)#exit R1# %SYS-5-CONFIG_I: Configured from console by console R1#wr Building configuration... [OK]
  • 31. 28 | P a g e For Router 2: Router>enable Router#config t Enter configuration commands, one per line. End with CNTL/Z. Router(config)#hostname R-2 R-2(config)#enable secret bim R-2(config)#line console 0 R-2(config-line)#password cisco R-2(config-line)#login R-2(config-line)#exit R-2(config)#line vty 0 4 R-2(config-line)#password bim123 R-2(config-line)#login R-2(config-line)#exit R-2(config)#int gig 0/0/0 R-2(config-if)#desc **connected to sw-2** R-2(config-if)#ip address 192.14.20.1 255.255.255.0 R-2(config-if)#no shut R-2(config-if)# %LINK-5-CHANGED: Interface GigabitEthernet0/0/0, changed state to up %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0/0, changed state to up R-2(config-if)#exit R-2(config)#int se 0/1/0 R-2(config-if)#ip address 10.10.10.2 255.255.255.0 R-2(config-if)#no shut
  • 32. 29 | P a g e R-2(config-if)# %LINK-5-CHANGED: Interface Serial0/1/0, changed state to up R-2(config-if)#exit R-2(config)# %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0, changed state to up R-2(config)#router eigrp 10 R-2(config-router)#network 192.14.20.0 255.255.255.0 R-2(config-router)#network 10.10.10.0 255.255.255.0 R-2(config-router)# %DUAL-5-NBRCHANGE: IP-EIGRP 10: Neighbor 10.10.10.1 (Serial0/1/0) is up: new adjacency R-2(config-router)#exit R-2(config)#exit R-2# %SYS-5-CONFIG_I: Configured from console by console R-2#wr Building configuration... [OK]
  • 33. 30 | P a g e Conclusion: As we can see, the current working protocol is EIGRP and it does ping from PC1 to PC2 suggesting that EIGRP is working. In a well-designed network, EIGRP scales well and provides extremely quick convergence times with minimal network traffic. When a change occurs in EIGRP configured network, only routing table changes are propagated, not the entire routing table; this reduces the load the routing protocol itself places on the network.
  • 34. 31 | P a g e Configuring BGP in a Network Border Gateway Protocol (BGP) is a standardized exterior gateway protocol designed to exchange routing and reachability information among autonomous systems (AS) on the Internet. BGP is classified as a path-vector routing protocol and it makes routing decisions based on paths, network policies, or rule-sets configured by a network administrator. Since the Cisco Packet tracer version 8.0.0.0212 does not support the internal BGP configuration of the network, it was not possible to show working mechanism of BGP. Nevertheless, here is command to configure BGP in a network: For Router-1: Router>enable Router#config t Enter configuration commands, one per line. End with CNTL/Z. R1(config)#router bgp 200 R1(config-router)#network 192.14.10.0 R1(config-router)#network 10.10.10.0 R1(config-router)#neighbor 192.14.20.1 remote-as 200 //ip address of neighbor router R1(config-router)#neighbor 192.14.20.10 remote-as 200 //ip address of neighbor PC For Router-2: Router>enable Router#config t Enter configuration commands, one per line. End with CNTL/Z. R2(config)#router bgp 200 R2(config-router)#network 192.14.20.0 R2(config-router)#network 10.10.10.0 R2(config-router)#neighbor 192.14.10.1 remote-as 200 //ip address of neighbor router R2(config-router)#neighbor 192.14.10.10 remote-as 200 //ip address of neighbor PC