SlideShare ist ein Scribd-Unternehmen logo
1 von 8
Downloaden Sie, um offline zu lesen
Basic Cisco 800 Router Configuration for
Internet Access
The Cisco 800 series routers are part of the “Branch Office” category, used mainly
for SOHO purposes or for connecting remote branch offices to a central location.
They are “fixed hardware configuration” devices, meaning that they don’t have
any plug-in hardware slots for inserting additional interfaces to the device (all the
interfaces are fixed).
All the 800 series models come with a 4-port 10/100 managed switch used for
connecting the internal LAN computers, and with an IOS software that supports
security features including the Firewall set. The main difference of each model is
the WAN interface. All models that end with “1” in the model number (i.e 851,
861, 871, 881, 891) have a 10/100 Fast Ethernet interface as a WAN port. The
other models have an xDSL type WAN port (i.e ADSL, G.SHDL, VDSL2). Also,
all models have the option of a WiFi Radio interface (the model number ends with
a “W”, e.g 851W, 857W, 861W etc).
In this post I will describe a basic configuration scenario for connecting a Cisco
800 router for Internet access. I will use a model with an Ethernet WAN interface
(such as 851, 861, 871, etc) since those models are the most popular.
Something to have in mind for all 800 series routers, the four LAN interfaces (FE0
up to FE3) are Layer2 switch interfaces that are assigned by default to Vlan1. This
means that you can not assign an IP address directly to the LAN interfaces. The IP
address for the LAN-facing side of the router is assigned under “interface Vlan1”.
On the other hand, the WAN interface (FE4) is a normal Layer3 router port, which
means you can assign an IP address directly on the interface (“interface
FastEthernet4”).
I will describe three basic scenarios which are frequently encountered in real
networks.
1. Scenario 1: WAN IP address of router is assigned dynamically by the ISP.
LAN IP addresses assigned dynamically from the router to the internal PCs.
2. Scenario 2: WAN IP address of router is static. LAN IP addresses assigned
dynamically from the router.
3. Scenario 3: WAN IP address of router is static. An internal LAN Web
Server exists. The router performs a static Port NAT (port redirection) to
forward traffic from Internet towards the internal Web Server.
Scenario 1:
Configuration:
The following is the basic configuration needed for the simple scenario above.
configure terminal
enable secret somesecretpassword
! Configure the DHCP pool to assign addresses to internal hosts
ip dhcp pool vlan1pool
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 100.100.100.36
! Do not assign addresses 1 to 30
ip dhcp excluded-address 192.168.1.1 192.168.1.30
! This is the LAN facing interface of the 800 router. Used as gateway for PCs
interface vlan 1
ip address 192.168.1.1 255.255.255.0
ip nat inside
no shut
! Interfaces FE0 to FE3 are Layer 2 interfaces
interface FastEthernet0
no shut
interface FastEthernet1
no shut
interface FastEthernet2
no shut
interface FastEthernet3
no shut
! This is the WAN interface getting address via DHCP from the ISP
interface FastEthernet 4
no shut
ip address dhcp
ip nat outside
! Configure NAT. All internal hosts will be nated on the WAN interface
ip nat inside source list 1 interface fastethernet4 overload
access-list 1 permit 192.168.1.0 0.0.0.255
ip route 0.0.0.0 0.0.0.0 fastethernet4
line vty 0 4
password somestrongpassword
Scenario 2:
Configuration:
This is the same configuration as scenario 1 except that the WAN IP address is
static and also the default gateway of our ISP is known.
The only difference from the configuration above is on the WAN interface and on
default route:
! This is the WAN interface with static IP
interface FastEthernet 4
no shut
ip address 100.100.100.1 255.255.255.0
ip nat outside
ip route 0.0.0.0 0.0.0.0 100.100.100.2
Scenario 3:
Configuration:
Here the WAN address is static and we have also an internal Web Server for which
we need to allow HTTP access from Internet. To do this we must configure a static
NAT with port redirection. Traffic that comes towards our WAN public address
100.100.100.1 on port 80 will be redirected by the router to the internal Web
Server at address 192.168.1.10 on port 80.
configure terminal
enable secret somesecretpassword
! Configure the DHCP pool to assign addresses to internal hosts
ip dhcp pool vlan1pool
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 100.100.100.36
! Do not assign addresses 1 to 30
ip dhcp excluded-address 192.168.1.1 192.168.1.30
! This is the LAN facing interface of the 800 router. Used as gateway for PCs
interface vlan 1
ip address 192.168.1.1 255.255.255.0
ip nat inside
no shut
! Interfaces FE0 to FE3 are Layer 2 interfaces
interface FastEthernet0
no shut
interface FastEthernet1
no shut
interface FastEthernet2
no shut
interface FastEthernet3
no shut
! This is the WAN interface with static IP
interface FastEthernet 4
no shut
ip address 100.100.100.1 255.255.255.0
ip nat outside
! Configure NAT. All internal hosts will be nated on the WAN interface
ip nat inside source list 1 interface fastethernet4 overload
access-list 1 permit 192.168.1.0 0.0.0.255
! Configure static NAT for port redirection
ip nat inside source static tcp 192.168.1.10 80 100.100.100.1 80 extendable
ip route 0.0.0.0 0.0.0.0 100.100.100.2
line vty 0 4
password somestrongpassword
About the Author
Harris Andrea is a Cisco Certified Professional with more than 18 years of experience
working with Cisco network technologies. He is the author of two Cisco Books
(“Cisco ASA Firewall Fundamentals” and “Cisco VPN Configuration Guide”) which
have been embraced by thousands of Cisco professionals all over the world. You can
find more Cisco configuration guides and tutorials on his blog here
http://www.networkstraining.com

Weitere ähnliche Inhalte

Was ist angesagt?

6.5.1.2 packet tracer layer 2 security instructor
6.5.1.2 packet tracer   layer 2 security instructor6.5.1.2 packet tracer   layer 2 security instructor
6.5.1.2 packet tracer layer 2 security instructorSalem Trabelsi
 
Resumen comandos router
Resumen comandos routerResumen comandos router
Resumen comandos routerjlvive
 
Cisco ASA Firewall Lab WorkBook
Cisco ASA Firewall Lab WorkBookCisco ASA Firewall Lab WorkBook
Cisco ASA Firewall Lab WorkBookRHC Technologies
 
Subnetting Principles Worksheet
Subnetting Principles WorksheetSubnetting Principles Worksheet
Subnetting Principles Worksheetswascher
 
How to configure vlan, stp, dtp step by step guide
How to configure vlan, stp, dtp step by step guideHow to configure vlan, stp, dtp step by step guide
How to configure vlan, stp, dtp step by step guideIT Tech
 
NSX for vSphere Logical Routing Deep Dive
NSX for vSphere Logical Routing Deep DiveNSX for vSphere Logical Routing Deep Dive
NSX for vSphere Logical Routing Deep DivePooja Patel
 
Free CCNP switching workbook by networkershome pdf
Free CCNP switching workbook by networkershome pdfFree CCNP switching workbook by networkershome pdf
Free CCNP switching workbook by networkershome pdfNetworkershome
 
CCNA
CCNACCNA
CCNAniict
 
Troubleshooting Firewalls (2012 San Diego)
Troubleshooting Firewalls (2012 San Diego)Troubleshooting Firewalls (2012 San Diego)
Troubleshooting Firewalls (2012 San Diego)Cisco Security
 
Solusi UTS Genap Praktikum Sistem Keamanan Jaringan - STMIK Bumigora
Solusi UTS Genap Praktikum Sistem Keamanan Jaringan - STMIK BumigoraSolusi UTS Genap Praktikum Sistem Keamanan Jaringan - STMIK Bumigora
Solusi UTS Genap Praktikum Sistem Keamanan Jaringan - STMIK BumigoraI Putu Hariyadi
 
Aboutsip - intro to transactions and dialogs
Aboutsip - intro to transactions and dialogsAboutsip - intro to transactions and dialogs
Aboutsip - intro to transactions and dialogsJonas Borjesson
 
Mail server on using cisco packet tracer
Mail server   on using cisco packet tracerMail server   on using cisco packet tracer
Mail server on using cisco packet tracerSabrinaUporna
 
CCNA 1 Routing and Switching v5.0 Chapter 9
CCNA 1 Routing and Switching v5.0 Chapter 9CCNA 1 Routing and Switching v5.0 Chapter 9
CCNA 1 Routing and Switching v5.0 Chapter 9Nil Menon
 
Huawei SAN Storage How To - Assigning Management IP Address
Huawei SAN Storage How To - Assigning Management IP AddressHuawei SAN Storage How To - Assigning Management IP Address
Huawei SAN Storage How To - Assigning Management IP AddressIPMAX s.r.l.
 

Was ist angesagt? (20)

6.5.1.2 packet tracer layer 2 security instructor
6.5.1.2 packet tracer   layer 2 security instructor6.5.1.2 packet tracer   layer 2 security instructor
6.5.1.2 packet tracer layer 2 security instructor
 
Resumen comandos router
Resumen comandos routerResumen comandos router
Resumen comandos router
 
Cisco ASA Firewall Lab WorkBook
Cisco ASA Firewall Lab WorkBookCisco ASA Firewall Lab WorkBook
Cisco ASA Firewall Lab WorkBook
 
Subnetting Principles Worksheet
Subnetting Principles WorksheetSubnetting Principles Worksheet
Subnetting Principles Worksheet
 
Subnetting
SubnettingSubnetting
Subnetting
 
How to configure vlan, stp, dtp step by step guide
How to configure vlan, stp, dtp step by step guideHow to configure vlan, stp, dtp step by step guide
How to configure vlan, stp, dtp step by step guide
 
NSX for vSphere Logical Routing Deep Dive
NSX for vSphere Logical Routing Deep DiveNSX for vSphere Logical Routing Deep Dive
NSX for vSphere Logical Routing Deep Dive
 
Free CCNP switching workbook by networkershome pdf
Free CCNP switching workbook by networkershome pdfFree CCNP switching workbook by networkershome pdf
Free CCNP switching workbook by networkershome pdf
 
EMEA Airheads- ArubaOS - Rogue AP troubleshooting
EMEA Airheads- ArubaOS - Rogue AP troubleshootingEMEA Airheads- ArubaOS - Rogue AP troubleshooting
EMEA Airheads- ArubaOS - Rogue AP troubleshooting
 
CCNA
CCNACCNA
CCNA
 
Troubleshooting Firewalls (2012 San Diego)
Troubleshooting Firewalls (2012 San Diego)Troubleshooting Firewalls (2012 San Diego)
Troubleshooting Firewalls (2012 San Diego)
 
Solusi UTS Genap Praktikum Sistem Keamanan Jaringan - STMIK Bumigora
Solusi UTS Genap Praktikum Sistem Keamanan Jaringan - STMIK BumigoraSolusi UTS Genap Praktikum Sistem Keamanan Jaringan - STMIK Bumigora
Solusi UTS Genap Praktikum Sistem Keamanan Jaringan - STMIK Bumigora
 
Aboutsip - intro to transactions and dialogs
Aboutsip - intro to transactions and dialogsAboutsip - intro to transactions and dialogs
Aboutsip - intro to transactions and dialogs
 
CCNA CheatSheet
CCNA CheatSheetCCNA CheatSheet
CCNA CheatSheet
 
EtherChannel Configuration
EtherChannel ConfigurationEtherChannel Configuration
EtherChannel Configuration
 
Ejemplo VLSM
Ejemplo VLSMEjemplo VLSM
Ejemplo VLSM
 
Mail server on using cisco packet tracer
Mail server   on using cisco packet tracerMail server   on using cisco packet tracer
Mail server on using cisco packet tracer
 
CCNA 1 Routing and Switching v5.0 Chapter 9
CCNA 1 Routing and Switching v5.0 Chapter 9CCNA 1 Routing and Switching v5.0 Chapter 9
CCNA 1 Routing and Switching v5.0 Chapter 9
 
Asa packet-flow-00
Asa packet-flow-00Asa packet-flow-00
Asa packet-flow-00
 
Huawei SAN Storage How To - Assigning Management IP Address
Huawei SAN Storage How To - Assigning Management IP AddressHuawei SAN Storage How To - Assigning Management IP Address
Huawei SAN Storage How To - Assigning Management IP Address
 

Andere mochten auch

Route Redistribution
Route RedistributionRoute Redistribution
Route RedistributionNetwax Lab
 
Overview on china's philanthropy for ACCP
Overview on china's philanthropy for ACCPOverview on china's philanthropy for ACCP
Overview on china's philanthropy for ACCPgive2asia
 
Editioning use in ebs
Editioning use in  ebsEditioning use in  ebs
Editioning use in ebspasalapudi123
 
Asat book0-fresh blood
Asat book0-fresh bloodAsat book0-fresh blood
Asat book0-fresh bloodAshraf Ali
 
An incentive model of partialinformation sharing in supply chain
An incentive model of partialinformation sharing in supply chainAn incentive model of partialinformation sharing in supply chain
An incentive model of partialinformation sharing in supply chainAli Elkhateb
 
Case study: #GoogleMoLang
Case study: #GoogleMoLangCase study: #GoogleMoLang
Case study: #GoogleMoLangnoreensayoc
 
Q3 2013 ASSA ABLOY investors presentation 28 october
Q3 2013 ASSA ABLOY investors presentation 28 octoberQ3 2013 ASSA ABLOY investors presentation 28 october
Q3 2013 ASSA ABLOY investors presentation 28 octoberASSA ABLOY
 
Kedaulatan Rakyat 2 Maret 2014
Kedaulatan Rakyat 2 Maret 2014Kedaulatan Rakyat 2 Maret 2014
Kedaulatan Rakyat 2 Maret 2014hastapurnama
 
فرانز كافكا - الآثار الكاملة - الجزء الأول
فرانز كافكا - الآثار الكاملة - الجزء الأولفرانز كافكا - الآثار الكاملة - الجزء الأول
فرانز كافكا - الآثار الكاملة - الجزء الأولA-Ile Self-hallucination
 
Email & Social Media Training
Email & Social Media TrainingEmail & Social Media Training
Email & Social Media TrainingWilliam Mann
 

Andere mochten auch (17)

Route Redistribution
Route RedistributionRoute Redistribution
Route Redistribution
 
Kewirausahaan
KewirausahaanKewirausahaan
Kewirausahaan
 
Overview on china's philanthropy for ACCP
Overview on china's philanthropy for ACCPOverview on china's philanthropy for ACCP
Overview on china's philanthropy for ACCP
 
Editioning use in ebs
Editioning use in  ebsEditioning use in  ebs
Editioning use in ebs
 
Img056
Img056Img056
Img056
 
How To Promote Your Business On Pinterest
How To Promote Your Business On PinterestHow To Promote Your Business On Pinterest
How To Promote Your Business On Pinterest
 
Asat book0-fresh blood
Asat book0-fresh bloodAsat book0-fresh blood
Asat book0-fresh blood
 
Tao tai khoan google play
Tao tai khoan google playTao tai khoan google play
Tao tai khoan google play
 
An incentive model of partialinformation sharing in supply chain
An incentive model of partialinformation sharing in supply chainAn incentive model of partialinformation sharing in supply chain
An incentive model of partialinformation sharing in supply chain
 
JCLIC
JCLICJCLIC
JCLIC
 
Case study: #GoogleMoLang
Case study: #GoogleMoLangCase study: #GoogleMoLang
Case study: #GoogleMoLang
 
Jdj Foss Java Tools
Jdj Foss Java ToolsJdj Foss Java Tools
Jdj Foss Java Tools
 
Q3 2013 ASSA ABLOY investors presentation 28 october
Q3 2013 ASSA ABLOY investors presentation 28 octoberQ3 2013 ASSA ABLOY investors presentation 28 october
Q3 2013 ASSA ABLOY investors presentation 28 october
 
Kedaulatan Rakyat 2 Maret 2014
Kedaulatan Rakyat 2 Maret 2014Kedaulatan Rakyat 2 Maret 2014
Kedaulatan Rakyat 2 Maret 2014
 
Cob 20081113 1
Cob 20081113 1Cob 20081113 1
Cob 20081113 1
 
فرانز كافكا - الآثار الكاملة - الجزء الأول
فرانز كافكا - الآثار الكاملة - الجزء الأولفرانز كافكا - الآثار الكاملة - الجزء الأول
فرانز كافكا - الآثار الكاملة - الجزء الأول
 
Email & Social Media Training
Email & Social Media TrainingEmail & Social Media Training
Email & Social Media Training
 

Ähnlich wie Basic Cisco 800 Router Configuration for Internet Access

Configuring a Cisco Router as a PPPoE Client for DSL Connectivity
 Configuring a Cisco Router as a PPPoE Client for DSL Connectivity Configuring a Cisco Router as a PPPoE Client for DSL Connectivity
Configuring a Cisco Router as a PPPoE Client for DSL Connectivity3Anetwork com
 
CMIT 350 FINAL EXAM CCNA CERTIFICATION PRACTICE EXAM
CMIT 350 FINAL EXAM CCNA CERTIFICATION PRACTICE EXAMCMIT 350 FINAL EXAM CCNA CERTIFICATION PRACTICE EXAM
CMIT 350 FINAL EXAM CCNA CERTIFICATION PRACTICE EXAMHamesKellor
 
Chapter11ccna
Chapter11ccnaChapter11ccna
Chapter11ccnarobertoxe
 
Lab practice 1 configuring basic routing and switching (with answer)
Lab practice 1   configuring basic routing and switching (with answer) Lab practice 1   configuring basic routing and switching (with answer)
Lab practice 1 configuring basic routing and switching (with answer) Arz Sy
 
NAT (network address translation) & PAT (port address translation)
NAT (network address translation) & PAT (port address translation)NAT (network address translation) & PAT (port address translation)
NAT (network address translation) & PAT (port address translation)Netwax Lab
 
Configure basic firewall and vpn
Configure basic firewall and vpnConfigure basic firewall and vpn
Configure basic firewall and vpnKumar
 
ACIT Mumbai - CCNA Training - Router Introduction
ACIT Mumbai - CCNA Training -  Router Introduction ACIT Mumbai - CCNA Training -  Router Introduction
ACIT Mumbai - CCNA Training - Router Introduction Sleek International
 
cisco-ewan-nat-acl-pt-practice-sba-with-solution-110516171316-phpapp02.pdf
cisco-ewan-nat-acl-pt-practice-sba-with-solution-110516171316-phpapp02.pdfcisco-ewan-nat-acl-pt-practice-sba-with-solution-110516171316-phpapp02.pdf
cisco-ewan-nat-acl-pt-practice-sba-with-solution-110516171316-phpapp02.pdfAsgarAlam6
 
Labpractice1 configuringbasicroutingandswitchingwithanswer-121214084802-phpapp02
Labpractice1 configuringbasicroutingandswitchingwithanswer-121214084802-phpapp02Labpractice1 configuringbasicroutingandswitchingwithanswer-121214084802-phpapp02
Labpractice1 configuringbasicroutingandswitchingwithanswer-121214084802-phpapp02Abhilash Kuniyil
 
69632 configuring-cat-ip-phone
69632 configuring-cat-ip-phone69632 configuring-cat-ip-phone
69632 configuring-cat-ip-phoneRayan Darine
 
Nat failover with dual isp on cisco router configuration explained with example
Nat failover with dual isp on cisco router configuration explained with exampleNat failover with dual isp on cisco router configuration explained with example
Nat failover with dual isp on cisco router configuration explained with exampleunixhowto
 
119163798 icnd1-practice-questions-9tut
119163798 icnd1-practice-questions-9tut119163798 icnd1-practice-questions-9tut
119163798 icnd1-practice-questions-9tutnicolelemmimg
 
Detailed explanation of Basic router configuration
Detailed explanation of Basic router configurationDetailed explanation of Basic router configuration
Detailed explanation of Basic router configurationsamreenghauri786
 

Ähnlich wie Basic Cisco 800 Router Configuration for Internet Access (20)

Nat 03
Nat 03Nat 03
Nat 03
 
Configuring a Cisco Router as a PPPoE Client for DSL Connectivity
 Configuring a Cisco Router as a PPPoE Client for DSL Connectivity Configuring a Cisco Router as a PPPoE Client for DSL Connectivity
Configuring a Cisco Router as a PPPoE Client for DSL Connectivity
 
CMIT 350 FINAL EXAM CCNA CERTIFICATION PRACTICE EXAM
CMIT 350 FINAL EXAM CCNA CERTIFICATION PRACTICE EXAMCMIT 350 FINAL EXAM CCNA CERTIFICATION PRACTICE EXAM
CMIT 350 FINAL EXAM CCNA CERTIFICATION PRACTICE EXAM
 
Nat 07
Nat 07Nat 07
Nat 07
 
Chapter11ccna
Chapter11ccnaChapter11ccna
Chapter11ccna
 
Chapter11ccna
Chapter11ccnaChapter11ccna
Chapter11ccna
 
Lab practice 1 configuring basic routing and switching (with answer)
Lab practice 1   configuring basic routing and switching (with answer) Lab practice 1   configuring basic routing and switching (with answer)
Lab practice 1 configuring basic routing and switching (with answer)
 
NAT (network address translation) & PAT (port address translation)
NAT (network address translation) & PAT (port address translation)NAT (network address translation) & PAT (port address translation)
NAT (network address translation) & PAT (port address translation)
 
Configure basic firewall and vpn
Configure basic firewall and vpnConfigure basic firewall and vpn
Configure basic firewall and vpn
 
ACIT Mumbai - CCNA Training - Router Introduction
ACIT Mumbai - CCNA Training -  Router Introduction ACIT Mumbai - CCNA Training -  Router Introduction
ACIT Mumbai - CCNA Training - Router Introduction
 
cisco-ewan-nat-acl-pt-practice-sba-with-solution-110516171316-phpapp02.pdf
cisco-ewan-nat-acl-pt-practice-sba-with-solution-110516171316-phpapp02.pdfcisco-ewan-nat-acl-pt-practice-sba-with-solution-110516171316-phpapp02.pdf
cisco-ewan-nat-acl-pt-practice-sba-with-solution-110516171316-phpapp02.pdf
 
Labpractice1 configuringbasicroutingandswitchingwithanswer-121214084802-phpapp02
Labpractice1 configuringbasicroutingandswitchingwithanswer-121214084802-phpapp02Labpractice1 configuringbasicroutingandswitchingwithanswer-121214084802-phpapp02
Labpractice1 configuringbasicroutingandswitchingwithanswer-121214084802-phpapp02
 
69632 configuring-cat-ip-phone
69632 configuring-cat-ip-phone69632 configuring-cat-ip-phone
69632 configuring-cat-ip-phone
 
portfolio2
portfolio2portfolio2
portfolio2
 
Nat failover with dual isp on cisco router configuration explained with example
Nat failover with dual isp on cisco router configuration explained with exampleNat failover with dual isp on cisco router configuration explained with example
Nat failover with dual isp on cisco router configuration explained with example
 
3 2
3 23 2
3 2
 
119163798 icnd1-practice-questions-9tut
119163798 icnd1-practice-questions-9tut119163798 icnd1-practice-questions-9tut
119163798 icnd1-practice-questions-9tut
 
Ccna 2 chapter 11 2014 v5
Ccna 2 chapter 11 2014 v5Ccna 2 chapter 11 2014 v5
Ccna 2 chapter 11 2014 v5
 
CCNA 1 Final v5.0 2014
CCNA 1 Final  v5.0 2014CCNA 1 Final  v5.0 2014
CCNA 1 Final v5.0 2014
 
Detailed explanation of Basic router configuration
Detailed explanation of Basic router configurationDetailed explanation of Basic router configuration
Detailed explanation of Basic router configuration
 

Kürzlich hochgeladen

Connector Corner: Accelerate revenue generation using UiPath API-centric busi...
Connector Corner: Accelerate revenue generation using UiPath API-centric busi...Connector Corner: Accelerate revenue generation using UiPath API-centric busi...
Connector Corner: Accelerate revenue generation using UiPath API-centric busi...DianaGray10
 
Artificial Intelligence Chap.5 : Uncertainty
Artificial Intelligence Chap.5 : UncertaintyArtificial Intelligence Chap.5 : Uncertainty
Artificial Intelligence Chap.5 : UncertaintyKhushali Kathiriya
 
Apidays Singapore 2024 - Building Digital Trust in a Digital Economy by Veron...
Apidays Singapore 2024 - Building Digital Trust in a Digital Economy by Veron...Apidays Singapore 2024 - Building Digital Trust in a Digital Economy by Veron...
Apidays Singapore 2024 - Building Digital Trust in a Digital Economy by Veron...apidays
 
2024: Domino Containers - The Next Step. News from the Domino Container commu...
2024: Domino Containers - The Next Step. News from the Domino Container commu...2024: Domino Containers - The Next Step. News from the Domino Container commu...
2024: Domino Containers - The Next Step. News from the Domino Container commu...Martijn de Jong
 
ICT role in 21st century education and its challenges
ICT role in 21st century education and its challengesICT role in 21st century education and its challenges
ICT role in 21st century education and its challengesrafiqahmad00786416
 
A Year of the Servo Reboot: Where Are We Now?
A Year of the Servo Reboot: Where Are We Now?A Year of the Servo Reboot: Where Are We Now?
A Year of the Servo Reboot: Where Are We Now?Igalia
 
DBX First Quarter 2024 Investor Presentation
DBX First Quarter 2024 Investor PresentationDBX First Quarter 2024 Investor Presentation
DBX First Quarter 2024 Investor PresentationDropbox
 
Why Teams call analytics are critical to your entire business
Why Teams call analytics are critical to your entire businessWhy Teams call analytics are critical to your entire business
Why Teams call analytics are critical to your entire businesspanagenda
 
MS Copilot expands with MS Graph connectors
MS Copilot expands with MS Graph connectorsMS Copilot expands with MS Graph connectors
MS Copilot expands with MS Graph connectorsNanddeep Nachan
 
Strategies for Unlocking Knowledge Management in Microsoft 365 in the Copilot...
Strategies for Unlocking Knowledge Management in Microsoft 365 in the Copilot...Strategies for Unlocking Knowledge Management in Microsoft 365 in the Copilot...
Strategies for Unlocking Knowledge Management in Microsoft 365 in the Copilot...Drew Madelung
 
presentation ICT roal in 21st century education
presentation ICT roal in 21st century educationpresentation ICT roal in 21st century education
presentation ICT roal in 21st century educationjfdjdjcjdnsjd
 
A Beginners Guide to Building a RAG App Using Open Source Milvus
A Beginners Guide to Building a RAG App Using Open Source MilvusA Beginners Guide to Building a RAG App Using Open Source Milvus
A Beginners Guide to Building a RAG App Using Open Source MilvusZilliz
 
Mastering MySQL Database Architecture: Deep Dive into MySQL Shell and MySQL R...
Mastering MySQL Database Architecture: Deep Dive into MySQL Shell and MySQL R...Mastering MySQL Database Architecture: Deep Dive into MySQL Shell and MySQL R...
Mastering MySQL Database Architecture: Deep Dive into MySQL Shell and MySQL R...Miguel Araújo
 
Web Form Automation for Bonterra Impact Management (fka Social Solutions Apri...
Web Form Automation for Bonterra Impact Management (fka Social Solutions Apri...Web Form Automation for Bonterra Impact Management (fka Social Solutions Apri...
Web Form Automation for Bonterra Impact Management (fka Social Solutions Apri...Jeffrey Haguewood
 
Real Time Object Detection Using Open CV
Real Time Object Detection Using Open CVReal Time Object Detection Using Open CV
Real Time Object Detection Using Open CVKhem
 
EMPOWERMENT TECHNOLOGY GRADE 11 QUARTER 2 REVIEWER
EMPOWERMENT TECHNOLOGY GRADE 11 QUARTER 2 REVIEWEREMPOWERMENT TECHNOLOGY GRADE 11 QUARTER 2 REVIEWER
EMPOWERMENT TECHNOLOGY GRADE 11 QUARTER 2 REVIEWERMadyBayot
 
How to Troubleshoot Apps for the Modern Connected Worker
How to Troubleshoot Apps for the Modern Connected WorkerHow to Troubleshoot Apps for the Modern Connected Worker
How to Troubleshoot Apps for the Modern Connected WorkerThousandEyes
 
TrustArc Webinar - Unlock the Power of AI-Driven Data Discovery
TrustArc Webinar - Unlock the Power of AI-Driven Data DiscoveryTrustArc Webinar - Unlock the Power of AI-Driven Data Discovery
TrustArc Webinar - Unlock the Power of AI-Driven Data DiscoveryTrustArc
 
Apidays New York 2024 - Scaling API-first by Ian Reasor and Radu Cotescu, Adobe
Apidays New York 2024 - Scaling API-first by Ian Reasor and Radu Cotescu, AdobeApidays New York 2024 - Scaling API-first by Ian Reasor and Radu Cotescu, Adobe
Apidays New York 2024 - Scaling API-first by Ian Reasor and Radu Cotescu, Adobeapidays
 
Boost Fertility New Invention Ups Success Rates.pdf
Boost Fertility New Invention Ups Success Rates.pdfBoost Fertility New Invention Ups Success Rates.pdf
Boost Fertility New Invention Ups Success Rates.pdfsudhanshuwaghmare1
 

Kürzlich hochgeladen (20)

Connector Corner: Accelerate revenue generation using UiPath API-centric busi...
Connector Corner: Accelerate revenue generation using UiPath API-centric busi...Connector Corner: Accelerate revenue generation using UiPath API-centric busi...
Connector Corner: Accelerate revenue generation using UiPath API-centric busi...
 
Artificial Intelligence Chap.5 : Uncertainty
Artificial Intelligence Chap.5 : UncertaintyArtificial Intelligence Chap.5 : Uncertainty
Artificial Intelligence Chap.5 : Uncertainty
 
Apidays Singapore 2024 - Building Digital Trust in a Digital Economy by Veron...
Apidays Singapore 2024 - Building Digital Trust in a Digital Economy by Veron...Apidays Singapore 2024 - Building Digital Trust in a Digital Economy by Veron...
Apidays Singapore 2024 - Building Digital Trust in a Digital Economy by Veron...
 
2024: Domino Containers - The Next Step. News from the Domino Container commu...
2024: Domino Containers - The Next Step. News from the Domino Container commu...2024: Domino Containers - The Next Step. News from the Domino Container commu...
2024: Domino Containers - The Next Step. News from the Domino Container commu...
 
ICT role in 21st century education and its challenges
ICT role in 21st century education and its challengesICT role in 21st century education and its challenges
ICT role in 21st century education and its challenges
 
A Year of the Servo Reboot: Where Are We Now?
A Year of the Servo Reboot: Where Are We Now?A Year of the Servo Reboot: Where Are We Now?
A Year of the Servo Reboot: Where Are We Now?
 
DBX First Quarter 2024 Investor Presentation
DBX First Quarter 2024 Investor PresentationDBX First Quarter 2024 Investor Presentation
DBX First Quarter 2024 Investor Presentation
 
Why Teams call analytics are critical to your entire business
Why Teams call analytics are critical to your entire businessWhy Teams call analytics are critical to your entire business
Why Teams call analytics are critical to your entire business
 
MS Copilot expands with MS Graph connectors
MS Copilot expands with MS Graph connectorsMS Copilot expands with MS Graph connectors
MS Copilot expands with MS Graph connectors
 
Strategies for Unlocking Knowledge Management in Microsoft 365 in the Copilot...
Strategies for Unlocking Knowledge Management in Microsoft 365 in the Copilot...Strategies for Unlocking Knowledge Management in Microsoft 365 in the Copilot...
Strategies for Unlocking Knowledge Management in Microsoft 365 in the Copilot...
 
presentation ICT roal in 21st century education
presentation ICT roal in 21st century educationpresentation ICT roal in 21st century education
presentation ICT roal in 21st century education
 
A Beginners Guide to Building a RAG App Using Open Source Milvus
A Beginners Guide to Building a RAG App Using Open Source MilvusA Beginners Guide to Building a RAG App Using Open Source Milvus
A Beginners Guide to Building a RAG App Using Open Source Milvus
 
Mastering MySQL Database Architecture: Deep Dive into MySQL Shell and MySQL R...
Mastering MySQL Database Architecture: Deep Dive into MySQL Shell and MySQL R...Mastering MySQL Database Architecture: Deep Dive into MySQL Shell and MySQL R...
Mastering MySQL Database Architecture: Deep Dive into MySQL Shell and MySQL R...
 
Web Form Automation for Bonterra Impact Management (fka Social Solutions Apri...
Web Form Automation for Bonterra Impact Management (fka Social Solutions Apri...Web Form Automation for Bonterra Impact Management (fka Social Solutions Apri...
Web Form Automation for Bonterra Impact Management (fka Social Solutions Apri...
 
Real Time Object Detection Using Open CV
Real Time Object Detection Using Open CVReal Time Object Detection Using Open CV
Real Time Object Detection Using Open CV
 
EMPOWERMENT TECHNOLOGY GRADE 11 QUARTER 2 REVIEWER
EMPOWERMENT TECHNOLOGY GRADE 11 QUARTER 2 REVIEWEREMPOWERMENT TECHNOLOGY GRADE 11 QUARTER 2 REVIEWER
EMPOWERMENT TECHNOLOGY GRADE 11 QUARTER 2 REVIEWER
 
How to Troubleshoot Apps for the Modern Connected Worker
How to Troubleshoot Apps for the Modern Connected WorkerHow to Troubleshoot Apps for the Modern Connected Worker
How to Troubleshoot Apps for the Modern Connected Worker
 
TrustArc Webinar - Unlock the Power of AI-Driven Data Discovery
TrustArc Webinar - Unlock the Power of AI-Driven Data DiscoveryTrustArc Webinar - Unlock the Power of AI-Driven Data Discovery
TrustArc Webinar - Unlock the Power of AI-Driven Data Discovery
 
Apidays New York 2024 - Scaling API-first by Ian Reasor and Radu Cotescu, Adobe
Apidays New York 2024 - Scaling API-first by Ian Reasor and Radu Cotescu, AdobeApidays New York 2024 - Scaling API-first by Ian Reasor and Radu Cotescu, Adobe
Apidays New York 2024 - Scaling API-first by Ian Reasor and Radu Cotescu, Adobe
 
Boost Fertility New Invention Ups Success Rates.pdf
Boost Fertility New Invention Ups Success Rates.pdfBoost Fertility New Invention Ups Success Rates.pdf
Boost Fertility New Invention Ups Success Rates.pdf
 

Basic Cisco 800 Router Configuration for Internet Access

  • 1. Basic Cisco 800 Router Configuration for Internet Access The Cisco 800 series routers are part of the “Branch Office” category, used mainly for SOHO purposes or for connecting remote branch offices to a central location. They are “fixed hardware configuration” devices, meaning that they don’t have any plug-in hardware slots for inserting additional interfaces to the device (all the interfaces are fixed). All the 800 series models come with a 4-port 10/100 managed switch used for connecting the internal LAN computers, and with an IOS software that supports security features including the Firewall set. The main difference of each model is the WAN interface. All models that end with “1” in the model number (i.e 851, 861, 871, 881, 891) have a 10/100 Fast Ethernet interface as a WAN port. The other models have an xDSL type WAN port (i.e ADSL, G.SHDL, VDSL2). Also, all models have the option of a WiFi Radio interface (the model number ends with a “W”, e.g 851W, 857W, 861W etc).
  • 2. In this post I will describe a basic configuration scenario for connecting a Cisco 800 router for Internet access. I will use a model with an Ethernet WAN interface (such as 851, 861, 871, etc) since those models are the most popular. Something to have in mind for all 800 series routers, the four LAN interfaces (FE0 up to FE3) are Layer2 switch interfaces that are assigned by default to Vlan1. This means that you can not assign an IP address directly to the LAN interfaces. The IP address for the LAN-facing side of the router is assigned under “interface Vlan1”. On the other hand, the WAN interface (FE4) is a normal Layer3 router port, which means you can assign an IP address directly on the interface (“interface FastEthernet4”). I will describe three basic scenarios which are frequently encountered in real networks. 1. Scenario 1: WAN IP address of router is assigned dynamically by the ISP. LAN IP addresses assigned dynamically from the router to the internal PCs. 2. Scenario 2: WAN IP address of router is static. LAN IP addresses assigned dynamically from the router. 3. Scenario 3: WAN IP address of router is static. An internal LAN Web Server exists. The router performs a static Port NAT (port redirection) to forward traffic from Internet towards the internal Web Server.
  • 3. Scenario 1: Configuration: The following is the basic configuration needed for the simple scenario above. configure terminal enable secret somesecretpassword ! Configure the DHCP pool to assign addresses to internal hosts ip dhcp pool vlan1pool network 192.168.1.0 255.255.255.0 default-router 192.168.1.1 dns-server 100.100.100.36 ! Do not assign addresses 1 to 30 ip dhcp excluded-address 192.168.1.1 192.168.1.30
  • 4. ! This is the LAN facing interface of the 800 router. Used as gateway for PCs interface vlan 1 ip address 192.168.1.1 255.255.255.0 ip nat inside no shut ! Interfaces FE0 to FE3 are Layer 2 interfaces interface FastEthernet0 no shut interface FastEthernet1 no shut interface FastEthernet2 no shut interface FastEthernet3 no shut ! This is the WAN interface getting address via DHCP from the ISP interface FastEthernet 4 no shut ip address dhcp ip nat outside ! Configure NAT. All internal hosts will be nated on the WAN interface ip nat inside source list 1 interface fastethernet4 overload access-list 1 permit 192.168.1.0 0.0.0.255 ip route 0.0.0.0 0.0.0.0 fastethernet4 line vty 0 4 password somestrongpassword
  • 5. Scenario 2: Configuration: This is the same configuration as scenario 1 except that the WAN IP address is static and also the default gateway of our ISP is known. The only difference from the configuration above is on the WAN interface and on default route: ! This is the WAN interface with static IP interface FastEthernet 4 no shut ip address 100.100.100.1 255.255.255.0 ip nat outside ip route 0.0.0.0 0.0.0.0 100.100.100.2
  • 6. Scenario 3: Configuration: Here the WAN address is static and we have also an internal Web Server for which we need to allow HTTP access from Internet. To do this we must configure a static NAT with port redirection. Traffic that comes towards our WAN public address 100.100.100.1 on port 80 will be redirected by the router to the internal Web Server at address 192.168.1.10 on port 80. configure terminal enable secret somesecretpassword
  • 7. ! Configure the DHCP pool to assign addresses to internal hosts ip dhcp pool vlan1pool network 192.168.1.0 255.255.255.0 default-router 192.168.1.1 dns-server 100.100.100.36 ! Do not assign addresses 1 to 30 ip dhcp excluded-address 192.168.1.1 192.168.1.30 ! This is the LAN facing interface of the 800 router. Used as gateway for PCs interface vlan 1 ip address 192.168.1.1 255.255.255.0 ip nat inside no shut ! Interfaces FE0 to FE3 are Layer 2 interfaces interface FastEthernet0 no shut interface FastEthernet1 no shut interface FastEthernet2 no shut interface FastEthernet3 no shut ! This is the WAN interface with static IP interface FastEthernet 4 no shut ip address 100.100.100.1 255.255.255.0 ip nat outside ! Configure NAT. All internal hosts will be nated on the WAN interface ip nat inside source list 1 interface fastethernet4 overload access-list 1 permit 192.168.1.0 0.0.0.255
  • 8. ! Configure static NAT for port redirection ip nat inside source static tcp 192.168.1.10 80 100.100.100.1 80 extendable ip route 0.0.0.0 0.0.0.0 100.100.100.2 line vty 0 4 password somestrongpassword About the Author Harris Andrea is a Cisco Certified Professional with more than 18 years of experience working with Cisco network technologies. He is the author of two Cisco Books (“Cisco ASA Firewall Fundamentals” and “Cisco VPN Configuration Guide”) which have been embraced by thousands of Cisco professionals all over the world. You can find more Cisco configuration guides and tutorials on his blog here http://www.networkstraining.com