SlideShare a Scribd company logo
1 of 6
Download to read offline
Anuj Kumar
                                            ciscobulls@gmail.com

             CCNP SWITCH
        PORTABLE STUDY GUIDE
                     &
         PRACTICE WORK BOOK


ANUJ KUMAR




             email:- ciscobulls@gmail.com
                anuj_dev007@yahoo.com
                  networkbulls.com
Anuj Kumar
                                                                                               ciscobulls@gmail.com

                                           REDUNDANCY PROTOCOLS

Cisco IOS offers feature to provide a redundant default gateway to end devices. The following are the default
gateway features supported by Cisco IOS and switches.

Hot Standby Routing Protocol (HSRP)
Virtual Router Redundancy Protocol (VRRP)
Gateway Load Balancing Protocol (GLBP)


                                       HSRP (Hot Standby Routing Protocol)

Feature:-
It is Cisco proprietary protocol.
It uses UDP Port no 1985
It sends hello message on multicast address 224.0.0.2
It sends out hello message every 3 sec (hold timer 10 sec)
Priority by default 100
It supports two types of authentication.
It supports tracking.

HSRP States: -
Active State: - in this active state, the router is send packets that are sent to virtual MAC and IP address of the
HSRP group. The active router also sends periodic hello message.

Standby: - in this state, the HSRP router is the next active router and it send periodic hello message. There must
be at least one standby router in the HSRP group.

Note: - A router does not hear any higher priority that router assume itself, so promote itself standby router.
A router does not hear an active router, so promote itself active router.
When the preempt option is not configure, the first router to initialize HSRP becomes the active router.

                           Configuration of HSRP on Switch
Switch1(config)#interface vlan 10
Switch1(config-if)#ip address 192.168.101.2 255.255.255.0
Switch1(config-if)#standby 1 ip 192.168.101.1
Switch1(config-if)#standby priority 150
Switch1(config-if)#standby 1 preempt

Switch2(config)#interface vlan 10
Switch2(config-if)#ip address 192.168.101.3 255.255.255.0
Switch2(config-if)#standby 1 ip 192.168.101.1
Switch2(config-if)#standby priority 200
Switch2(config-if)#standby 1 preempt
Anuj Kumar
                                                                                               ciscobulls@gmail.com


                                              Load Balancing of HSRP

While a router is actively forwarding traffic for one HSRP group, it can be in the standby or listen state for another
group.

Router A & Router B should be members of group 1 & Group 2.
Like as: -
     Router A:
            Active forwarding router for group 1
            Standby router for group 2.
     Router B:
            Active forwarding router for group 2
            Standby router for group 1.
Example:
Switch1(config)#interface vlan 10
Switch1(config-if)#ip address 192.168.101.2 255.255.255.0
Switch1(config-if)#standby 1 ip 192.168.101.1
Switch1(config-if)#standby priority 150
Switch1(config-if)#standby 1 preempt
Switch1(config)#interface vlan 20
Switch1(config-if)#ip address 192.168.102.2 255.255.255.0
Switch1(config-if)#standby 1 ip 192.168.102.1
Switch1(config-if)#standby priority 200
Switch1(config-if)#standby 1 preempt


Switch2(config)#interface vlan 10
Switch2(config-if)#ip address 192.168.101.3 255.255.255.0
Switch2(config-if)#standby 1 ip 192.168.101.1
Switch2(config-if)#standby priority 200
Switch2(config-if)#standby 1 preempt
Switch2(config)#interface vlan 20
Switch2(config-if)#ip address 192.168.102.3 255.255.255.0
Switch2(config-if)#standby 1 ip 192.168.102.1
Switch2(config-if)#standby priority 150
Switch2(config-if)#standby 1 preempt

Timers:-
    Both the hellotime and the holdtime parameters are configurable.
        Switch(config-if)#standby group-number timers hellotime holdtime
    Hellotime
            Default = 3 seconds
            Value varies from 1 to 255.
    Holdtime
            Default = 10 seconds
            Value varies from 1 to 255.
Anuj Kumar
                                                                                              ciscobulls@gmail.com

     To reinstate the default standby timer values, enter the following command:
      Switch(config-if)#no standby group-number timers

                                       Configuring HSRP Interface Tracking

The f0/0 interfaces on router A tracks the S0/0 interface. If the link between the S0/0 interface and Core fails, the
router automatically decrements its priority (10) on that interface and stops transmitting hello messages out
interface f0/0. Router B assumes the active router role when no hello messages are detected for the specific
holdtime period.

Switch1(config)#interface vlan 10
Switch1(config-if)#ip address 192.168.101.2 255.255.255.0
Switch1(config-if)#standby 1 ip 192.168.101.1
Switch1(config-if)#standby priority 150
Switch1(config-if)#standby 1 preempt
Switch1(config-if)#standby 1 track serial0/0(self interface name)

Switch2(config)#interface vlan 10
Switch2(config-if)#ip address 192.168.101.3 255.255.255.0
Switch2(config-if)#standby 1 ip 192.168.101.1
Switch2(config-if)#standby priority 200
Switch2(config-if)#standby 1 preempt
Switch2(config-if)#standby 1 track serial0/0 (self interface name)




                                                      Practical
Anuj Kumar
                                                             ciscobulls@gmail.com

Router(config)#host CORE
CORE(config)#int f0/0
CORE(config-if)#ip address 192.168.102.1 255.255.255.0
CORE(config-if)#no shutdown
CORE(config-if)int s0/0
CORE(config-if)#ip address 10.1.1.1 255.255.255.0
CORE(config-if)#no shutdown
CORE(config-if)#int s0/1
CORE(config-if)#ip address 11.1.1.1 255.255.255.0
CORE(config-if)#no shutdown
CORE(config-if)#router ei 100
CORE(config-router)#network 192.168.102.0
CORE(config-router)#network 10.1.1.0 0.0.0.255
CORE(config-router)#network 11.1.1.0 0.0.0.255
CORE(config-router)#no auto-summary

SW1(config)#ho SW1
SW1(config)#int s0/0
SW1(config-if)#ip address 10.1.1.2 255.255.255.0
SW1(config-if)#no shutdown
SW1(config-if)# int f0/0
SW1(config-if)# ip address 192.168.101.2 255.255.255.0
SW1(config-if)# no shutdown
SW1(config-if)# router eigrp 100
SW1(config-router)# network 192.168.101.0
SW1(config-router)# network 10.1.1.0 0.0.0.255
SW1(config-router)# no auto-summary
SW1(config-router)# exi
SW1(config)# int f0/0
SW1(config-if)# standby 1 ip 192.168.101.1
*Mar 1 00:23:07.895: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 1 state
Standby -> Active
SW1(config-if)#standby 1 priority 150
SW1(config-if)#standby 1 preempt
SW1(config-if)#standby 1 track serial 0/0




SW2(config)#ho SW2
SW2(config)#int f0/0
SW2(config-if)#ip address 192.168.101.3 255.255.255.0
SW2(config-if)#no shutdown
SW2(config-if)#int s0/0
SW2(config-if)#ip address 11.1.1.2 255.255.255.0
SW2(config-if)#no shutdown
SW2(config-if)#router ei 100
SW2(config-router)#network 192.168.101.0
SW2(config-router)#network 11.1.1.0 0.0.0.255
SW2(config-router)#no auto-summary
Anuj Kumar
                                                              ciscobulls@gmail.com

SW2(config-router)#int f0/0
SW2(config-if)#standby 1 ip 192.168.101.1
SW2(config-if)#standby 1 priority 200
SW2(config-if)#standby 1 preempt
*Mar 1 00:34:31.431: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 1 state
Standby -> Active
SW2(config-if)#standby 1 track serial 0/0


Verifying
SW1#sh standby
FastEthernet0/0 - Group 1
  State is Standby
    4 state changes, last state change 00:43:18
  Virtual IP address is 192.168.101.1
  Active virtual MAC address is 0000.0c07.ac01
    Local virtual MAC address is 0000.0c07.ac01 (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 0.000 secs
  Preemption enabled
  Active router is 192.168.101.3, priority 190 (expires in 6.912 sec)
  Standby router is local
  Priority 150 (configured 150)
    Track interface Serial0/0 state Up decrement 10
  Group name is "hsrp-Fa0/0-1" (default)
SW2#sh standby
FastEthernet0/0 - Group 1
  State is Active
    2 state changes, last state change 00:44:28
  Virtual IP address is 192.168.101.1
  Active virtual MAC address is 0000.0c07.ac01
    Local virtual MAC address is 0000.0c07.ac01 (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 1.296 secs
  Preemption enabled
  Active router is local
  Standby router is 192.168.101.2, priority 150 (expires in 8.436 sec)
  Priority 190 (configured 200)
    Track interface Serial0/0 state Down decrement 10
  Group name is "hsrp-Fa0/0-1" (default)
Thank you for giving me your precious time.
Anuj Kumar

More Related Content

What's hot

Class notes fhrp,hsrp,vrrp
Class notes fhrp,hsrp,vrrpClass notes fhrp,hsrp,vrrp
Class notes fhrp,hsrp,vrrpSagarR24
 
Class notes fhrp,hsrp
Class notes  fhrp,hsrpClass notes  fhrp,hsrp
Class notes fhrp,hsrpSagarR24
 
Packet Tracer: Load Balancing with GLBP and FHRP
Packet Tracer: Load Balancing with GLBP and FHRPPacket Tracer: Load Balancing with GLBP and FHRP
Packet Tracer: Load Balancing with GLBP and FHRPRafat Khandaker
 
Chapter7ccna
Chapter7ccnaChapter7ccna
Chapter7ccnarobertoxe
 
EIGRP (enhanced interior gateway routing protocol)
EIGRP (enhanced interior gateway routing protocol)EIGRP (enhanced interior gateway routing protocol)
EIGRP (enhanced interior gateway routing protocol)Netwax Lab
 
Open Shortest Path First
Open Shortest Path FirstOpen Shortest Path First
Open Shortest Path FirstKashif Latif
 
Cisco discovery drs ent module 6 - v.4 in english.
Cisco discovery   drs ent module 6 - v.4 in english.Cisco discovery   drs ent module 6 - v.4 in english.
Cisco discovery drs ent module 6 - v.4 in english.igede tirtanata
 
IP Infusion Application Note for 4G LTE Fixed Wireless Access
IP Infusion Application Note for 4G LTE Fixed Wireless AccessIP Infusion Application Note for 4G LTE Fixed Wireless Access
IP Infusion Application Note for 4G LTE Fixed Wireless AccessDhiman Chowdhury
 
RIP (routing information protocol)
RIP (routing information protocol)RIP (routing information protocol)
RIP (routing information protocol)Netwax Lab
 
Routing Protocol EIGRP
Routing Protocol EIGRPRouting Protocol EIGRP
Routing Protocol EIGRPDmitry Figol
 
QoS marking on cisco IOS Router
QoS marking on cisco IOS RouterQoS marking on cisco IOS Router
QoS marking on cisco IOS RouterNetProtocol Xpert
 

What's hot (20)

Vrrp Alp
Vrrp AlpVrrp Alp
Vrrp Alp
 
Class notes fhrp,hsrp,vrrp
Class notes fhrp,hsrp,vrrpClass notes fhrp,hsrp,vrrp
Class notes fhrp,hsrp,vrrp
 
Class notes fhrp,hsrp
Class notes  fhrp,hsrpClass notes  fhrp,hsrp
Class notes fhrp,hsrp
 
Packet Tracer: Load Balancing with GLBP and FHRP
Packet Tracer: Load Balancing with GLBP and FHRPPacket Tracer: Load Balancing with GLBP and FHRP
Packet Tracer: Load Balancing with GLBP and FHRP
 
Fhrp notes
Fhrp notesFhrp notes
Fhrp notes
 
Chapter7ccna
Chapter7ccnaChapter7ccna
Chapter7ccna
 
Ospf
OspfOspf
Ospf
 
Ospf
OspfOspf
Ospf
 
EIGRP (enhanced interior gateway routing protocol)
EIGRP (enhanced interior gateway routing protocol)EIGRP (enhanced interior gateway routing protocol)
EIGRP (enhanced interior gateway routing protocol)
 
OSPF Fundamental
OSPF FundamentalOSPF Fundamental
OSPF Fundamental
 
CCIE Lab - IGP Routing
CCIE Lab -  IGP Routing  CCIE Lab -  IGP Routing
CCIE Lab - IGP Routing
 
Open Shortest Path First
Open Shortest Path FirstOpen Shortest Path First
Open Shortest Path First
 
Cisco discovery drs ent module 6 - v.4 in english.
Cisco discovery   drs ent module 6 - v.4 in english.Cisco discovery   drs ent module 6 - v.4 in english.
Cisco discovery drs ent module 6 - v.4 in english.
 
IP Infusion Application Note for 4G LTE Fixed Wireless Access
IP Infusion Application Note for 4G LTE Fixed Wireless AccessIP Infusion Application Note for 4G LTE Fixed Wireless Access
IP Infusion Application Note for 4G LTE Fixed Wireless Access
 
RIP (routing information protocol)
RIP (routing information protocol)RIP (routing information protocol)
RIP (routing information protocol)
 
Ccnpswitch
CcnpswitchCcnpswitch
Ccnpswitch
 
Igrp
IgrpIgrp
Igrp
 
Routing Protocol EIGRP
Routing Protocol EIGRPRouting Protocol EIGRP
Routing Protocol EIGRP
 
MPLS Layer 3 VPN
MPLS Layer 3 VPN MPLS Layer 3 VPN
MPLS Layer 3 VPN
 
QoS marking on cisco IOS Router
QoS marking on cisco IOS RouterQoS marking on cisco IOS Router
QoS marking on cisco IOS Router
 

Similar to Hsrp

Similar to Hsrp (20)

Layer 3 redundancy hsrp
Layer 3 redundancy   hsrpLayer 3 redundancy   hsrp
Layer 3 redundancy hsrp
 
Vrrp
VrrpVrrp
Vrrp
 
ccna cheat_sheet
ccna cheat_sheetccna cheat_sheet
ccna cheat_sheet
 
cisco ccna cheat_sheet
cisco ccna cheat_sheetcisco ccna cheat_sheet
cisco ccna cheat_sheet
 
Ncat ccna cheat sheet
Ncat ccna cheat sheetNcat ccna cheat sheet
Ncat ccna cheat sheet
 
Cisco Commands
Cisco CommandsCisco Commands
Cisco Commands
 
Ciso commands
Ciso commandsCiso commands
Ciso commands
 
Ciso commands
Ciso commandsCiso commands
Ciso commands
 
Basic cisco commands_by_marcus_nielson_2
Basic cisco commands_by_marcus_nielson_2Basic cisco commands_by_marcus_nielson_2
Basic cisco commands_by_marcus_nielson_2
 
Ccnacommand 140205001152-phpapp01
Ccnacommand 140205001152-phpapp01Ccnacommand 140205001152-phpapp01
Ccnacommand 140205001152-phpapp01
 
Labmannual
LabmannualLabmannual
Labmannual
 
Hot standby router protocol (hsrp) using
Hot standby router protocol (hsrp) usingHot standby router protocol (hsrp) using
Hot standby router protocol (hsrp) using
 
Ccna command
Ccna commandCcna command
Ccna command
 
CCNA - Routing & Switching Commands
CCNA - Routing & Switching CommandsCCNA - Routing & Switching Commands
CCNA - Routing & Switching Commands
 
Dynamic Routing IGRP
Dynamic Routing IGRPDynamic Routing IGRP
Dynamic Routing IGRP
 
Ccna Commands In 10 Minutes
Ccna Commands In 10 MinutesCcna Commands In 10 Minutes
Ccna Commands In 10 Minutes
 
Ccna commands
Ccna commandsCcna commands
Ccna commands
 
Ccna commands
Ccna commandsCcna commands
Ccna commands
 
Cisco CCNA CCNP VACL Configuration
Cisco CCNA CCNP VACL ConfigurationCisco CCNA CCNP VACL Configuration
Cisco CCNA CCNP VACL Configuration
 
Cisco CCNA IP SLA with tracking configuration
Cisco CCNA IP SLA  with tracking  configurationCisco CCNA IP SLA  with tracking  configuration
Cisco CCNA IP SLA with tracking configuration
 

More from Anuj Kumar

More from Anuj Kumar (6)

Osi model
Osi modelOsi model
Osi model
 
VLAN
VLANVLAN
VLAN
 
Private vlan
Private vlanPrivate vlan
Private vlan
 
Port aggregation
Port aggregationPort aggregation
Port aggregation
 
Hsrp
HsrpHsrp
Hsrp
 
Port aggregation
Port aggregationPort aggregation
Port aggregation
 

Recently uploaded

2024: Domino Containers - The Next Step. News from the Domino Container commu...
2024: Domino Containers - The Next Step. News from the Domino Container commu...2024: Domino Containers - The Next Step. News from the Domino Container commu...
2024: Domino Containers - The Next Step. News from the Domino Container commu...Martijn de Jong
 
08448380779 Call Girls In Friends Colony Women Seeking Men
08448380779 Call Girls In Friends Colony Women Seeking Men08448380779 Call Girls In Friends Colony Women Seeking Men
08448380779 Call Girls In Friends Colony Women Seeking MenDelhi Call girls
 
TrustArc Webinar - Stay Ahead of US State Data Privacy Law Developments
TrustArc Webinar - Stay Ahead of US State Data Privacy Law DevelopmentsTrustArc Webinar - Stay Ahead of US State Data Privacy Law Developments
TrustArc Webinar - Stay Ahead of US State Data Privacy Law DevelopmentsTrustArc
 
A Call to Action for Generative AI in 2024
A Call to Action for Generative AI in 2024A Call to Action for Generative AI in 2024
A Call to Action for Generative AI in 2024Results
 
IAC 2024 - IA Fast Track to Search Focused AI Solutions
IAC 2024 - IA Fast Track to Search Focused AI SolutionsIAC 2024 - IA Fast Track to Search Focused AI Solutions
IAC 2024 - IA Fast Track to Search Focused AI SolutionsEnterprise Knowledge
 
From Event to Action: Accelerate Your Decision Making with Real-Time Automation
From Event to Action: Accelerate Your Decision Making with Real-Time AutomationFrom Event to Action: Accelerate Your Decision Making with Real-Time Automation
From Event to Action: Accelerate Your Decision Making with Real-Time AutomationSafe Software
 
04-2024-HHUG-Sales-and-Marketing-Alignment.pptx
04-2024-HHUG-Sales-and-Marketing-Alignment.pptx04-2024-HHUG-Sales-and-Marketing-Alignment.pptx
04-2024-HHUG-Sales-and-Marketing-Alignment.pptxHampshireHUG
 
Handwritten Text Recognition for manuscripts and early printed texts
Handwritten Text Recognition for manuscripts and early printed textsHandwritten Text Recognition for manuscripts and early printed texts
Handwritten Text Recognition for manuscripts and early printed textsMaria Levchenko
 
A Domino Admins Adventures (Engage 2024)
A Domino Admins Adventures (Engage 2024)A Domino Admins Adventures (Engage 2024)
A Domino Admins Adventures (Engage 2024)Gabriella Davis
 
Understanding Discord NSFW Servers A Guide for Responsible Users.pdf
Understanding Discord NSFW Servers A Guide for Responsible Users.pdfUnderstanding Discord NSFW Servers A Guide for Responsible Users.pdf
Understanding Discord NSFW Servers A Guide for Responsible Users.pdfUK Journal
 
Axa Assurance Maroc - Insurer Innovation Award 2024
Axa Assurance Maroc - Insurer Innovation Award 2024Axa Assurance Maroc - Insurer Innovation Award 2024
Axa Assurance Maroc - Insurer Innovation Award 2024The Digital Insurer
 
Automating Google Workspace (GWS) & more with Apps Script
Automating Google Workspace (GWS) & more with Apps ScriptAutomating Google Workspace (GWS) & more with Apps Script
Automating Google Workspace (GWS) & more with Apps Scriptwesley chun
 
08448380779 Call Girls In Greater Kailash - I Women Seeking Men
08448380779 Call Girls In Greater Kailash - I Women Seeking Men08448380779 Call Girls In Greater Kailash - I Women Seeking Men
08448380779 Call Girls In Greater Kailash - I Women Seeking MenDelhi Call girls
 
Boost PC performance: How more available memory can improve productivity
Boost PC performance: How more available memory can improve productivityBoost PC performance: How more available memory can improve productivity
Boost PC performance: How more available memory can improve productivityPrincipled Technologies
 
Strategies for Unlocking Knowledge Management in Microsoft 365 in the Copilot...
Strategies for Unlocking Knowledge Management in Microsoft 365 in the Copilot...Strategies for Unlocking Knowledge Management in Microsoft 365 in the Copilot...
Strategies for Unlocking Knowledge Management in Microsoft 365 in the Copilot...Drew Madelung
 
Histor y of HAM Radio presentation slide
Histor y of HAM Radio presentation slideHistor y of HAM Radio presentation slide
Histor y of HAM Radio presentation slidevu2urc
 
What Are The Drone Anti-jamming Systems Technology?
What Are The Drone Anti-jamming Systems Technology?What Are The Drone Anti-jamming Systems Technology?
What Are The Drone Anti-jamming Systems Technology?Antenna Manufacturer Coco
 
Scaling API-first – The story of a global engineering organization
Scaling API-first – The story of a global engineering organizationScaling API-first – The story of a global engineering organization
Scaling API-first – The story of a global engineering organizationRadu Cotescu
 
The Role of Taxonomy and Ontology in Semantic Layers - Heather Hedden.pdf
The Role of Taxonomy and Ontology in Semantic Layers - Heather Hedden.pdfThe Role of Taxonomy and Ontology in Semantic Layers - Heather Hedden.pdf
The Role of Taxonomy and Ontology in Semantic Layers - Heather Hedden.pdfEnterprise Knowledge
 
How to Troubleshoot Apps for the Modern Connected Worker
How to Troubleshoot Apps for the Modern Connected WorkerHow to Troubleshoot Apps for the Modern Connected Worker
How to Troubleshoot Apps for the Modern Connected WorkerThousandEyes
 

Recently uploaded (20)

2024: Domino Containers - The Next Step. News from the Domino Container commu...
2024: Domino Containers - The Next Step. News from the Domino Container commu...2024: Domino Containers - The Next Step. News from the Domino Container commu...
2024: Domino Containers - The Next Step. News from the Domino Container commu...
 
08448380779 Call Girls In Friends Colony Women Seeking Men
08448380779 Call Girls In Friends Colony Women Seeking Men08448380779 Call Girls In Friends Colony Women Seeking Men
08448380779 Call Girls In Friends Colony Women Seeking Men
 
TrustArc Webinar - Stay Ahead of US State Data Privacy Law Developments
TrustArc Webinar - Stay Ahead of US State Data Privacy Law DevelopmentsTrustArc Webinar - Stay Ahead of US State Data Privacy Law Developments
TrustArc Webinar - Stay Ahead of US State Data Privacy Law Developments
 
A Call to Action for Generative AI in 2024
A Call to Action for Generative AI in 2024A Call to Action for Generative AI in 2024
A Call to Action for Generative AI in 2024
 
IAC 2024 - IA Fast Track to Search Focused AI Solutions
IAC 2024 - IA Fast Track to Search Focused AI SolutionsIAC 2024 - IA Fast Track to Search Focused AI Solutions
IAC 2024 - IA Fast Track to Search Focused AI Solutions
 
From Event to Action: Accelerate Your Decision Making with Real-Time Automation
From Event to Action: Accelerate Your Decision Making with Real-Time AutomationFrom Event to Action: Accelerate Your Decision Making with Real-Time Automation
From Event to Action: Accelerate Your Decision Making with Real-Time Automation
 
04-2024-HHUG-Sales-and-Marketing-Alignment.pptx
04-2024-HHUG-Sales-and-Marketing-Alignment.pptx04-2024-HHUG-Sales-and-Marketing-Alignment.pptx
04-2024-HHUG-Sales-and-Marketing-Alignment.pptx
 
Handwritten Text Recognition for manuscripts and early printed texts
Handwritten Text Recognition for manuscripts and early printed textsHandwritten Text Recognition for manuscripts and early printed texts
Handwritten Text Recognition for manuscripts and early printed texts
 
A Domino Admins Adventures (Engage 2024)
A Domino Admins Adventures (Engage 2024)A Domino Admins Adventures (Engage 2024)
A Domino Admins Adventures (Engage 2024)
 
Understanding Discord NSFW Servers A Guide for Responsible Users.pdf
Understanding Discord NSFW Servers A Guide for Responsible Users.pdfUnderstanding Discord NSFW Servers A Guide for Responsible Users.pdf
Understanding Discord NSFW Servers A Guide for Responsible Users.pdf
 
Axa Assurance Maroc - Insurer Innovation Award 2024
Axa Assurance Maroc - Insurer Innovation Award 2024Axa Assurance Maroc - Insurer Innovation Award 2024
Axa Assurance Maroc - Insurer Innovation Award 2024
 
Automating Google Workspace (GWS) & more with Apps Script
Automating Google Workspace (GWS) & more with Apps ScriptAutomating Google Workspace (GWS) & more with Apps Script
Automating Google Workspace (GWS) & more with Apps Script
 
08448380779 Call Girls In Greater Kailash - I Women Seeking Men
08448380779 Call Girls In Greater Kailash - I Women Seeking Men08448380779 Call Girls In Greater Kailash - I Women Seeking Men
08448380779 Call Girls In Greater Kailash - I Women Seeking Men
 
Boost PC performance: How more available memory can improve productivity
Boost PC performance: How more available memory can improve productivityBoost PC performance: How more available memory can improve productivity
Boost PC performance: How more available memory can improve productivity
 
Strategies for Unlocking Knowledge Management in Microsoft 365 in the Copilot...
Strategies for Unlocking Knowledge Management in Microsoft 365 in the Copilot...Strategies for Unlocking Knowledge Management in Microsoft 365 in the Copilot...
Strategies for Unlocking Knowledge Management in Microsoft 365 in the Copilot...
 
Histor y of HAM Radio presentation slide
Histor y of HAM Radio presentation slideHistor y of HAM Radio presentation slide
Histor y of HAM Radio presentation slide
 
What Are The Drone Anti-jamming Systems Technology?
What Are The Drone Anti-jamming Systems Technology?What Are The Drone Anti-jamming Systems Technology?
What Are The Drone Anti-jamming Systems Technology?
 
Scaling API-first – The story of a global engineering organization
Scaling API-first – The story of a global engineering organizationScaling API-first – The story of a global engineering organization
Scaling API-first – The story of a global engineering organization
 
The Role of Taxonomy and Ontology in Semantic Layers - Heather Hedden.pdf
The Role of Taxonomy and Ontology in Semantic Layers - Heather Hedden.pdfThe Role of Taxonomy and Ontology in Semantic Layers - Heather Hedden.pdf
The Role of Taxonomy and Ontology in Semantic Layers - Heather Hedden.pdf
 
How to Troubleshoot Apps for the Modern Connected Worker
How to Troubleshoot Apps for the Modern Connected WorkerHow to Troubleshoot Apps for the Modern Connected Worker
How to Troubleshoot Apps for the Modern Connected Worker
 

Hsrp

  • 1. Anuj Kumar ciscobulls@gmail.com CCNP SWITCH PORTABLE STUDY GUIDE & PRACTICE WORK BOOK ANUJ KUMAR email:- ciscobulls@gmail.com anuj_dev007@yahoo.com networkbulls.com
  • 2. Anuj Kumar ciscobulls@gmail.com REDUNDANCY PROTOCOLS Cisco IOS offers feature to provide a redundant default gateway to end devices. The following are the default gateway features supported by Cisco IOS and switches. Hot Standby Routing Protocol (HSRP) Virtual Router Redundancy Protocol (VRRP) Gateway Load Balancing Protocol (GLBP) HSRP (Hot Standby Routing Protocol) Feature:- It is Cisco proprietary protocol. It uses UDP Port no 1985 It sends hello message on multicast address 224.0.0.2 It sends out hello message every 3 sec (hold timer 10 sec) Priority by default 100 It supports two types of authentication. It supports tracking. HSRP States: - Active State: - in this active state, the router is send packets that are sent to virtual MAC and IP address of the HSRP group. The active router also sends periodic hello message. Standby: - in this state, the HSRP router is the next active router and it send periodic hello message. There must be at least one standby router in the HSRP group. Note: - A router does not hear any higher priority that router assume itself, so promote itself standby router. A router does not hear an active router, so promote itself active router. When the preempt option is not configure, the first router to initialize HSRP becomes the active router. Configuration of HSRP on Switch Switch1(config)#interface vlan 10 Switch1(config-if)#ip address 192.168.101.2 255.255.255.0 Switch1(config-if)#standby 1 ip 192.168.101.1 Switch1(config-if)#standby priority 150 Switch1(config-if)#standby 1 preempt Switch2(config)#interface vlan 10 Switch2(config-if)#ip address 192.168.101.3 255.255.255.0 Switch2(config-if)#standby 1 ip 192.168.101.1 Switch2(config-if)#standby priority 200 Switch2(config-if)#standby 1 preempt
  • 3. Anuj Kumar ciscobulls@gmail.com Load Balancing of HSRP While a router is actively forwarding traffic for one HSRP group, it can be in the standby or listen state for another group. Router A & Router B should be members of group 1 & Group 2. Like as: -  Router A:  Active forwarding router for group 1  Standby router for group 2.  Router B:  Active forwarding router for group 2  Standby router for group 1. Example: Switch1(config)#interface vlan 10 Switch1(config-if)#ip address 192.168.101.2 255.255.255.0 Switch1(config-if)#standby 1 ip 192.168.101.1 Switch1(config-if)#standby priority 150 Switch1(config-if)#standby 1 preempt Switch1(config)#interface vlan 20 Switch1(config-if)#ip address 192.168.102.2 255.255.255.0 Switch1(config-if)#standby 1 ip 192.168.102.1 Switch1(config-if)#standby priority 200 Switch1(config-if)#standby 1 preempt Switch2(config)#interface vlan 10 Switch2(config-if)#ip address 192.168.101.3 255.255.255.0 Switch2(config-if)#standby 1 ip 192.168.101.1 Switch2(config-if)#standby priority 200 Switch2(config-if)#standby 1 preempt Switch2(config)#interface vlan 20 Switch2(config-if)#ip address 192.168.102.3 255.255.255.0 Switch2(config-if)#standby 1 ip 192.168.102.1 Switch2(config-if)#standby priority 150 Switch2(config-if)#standby 1 preempt Timers:-  Both the hellotime and the holdtime parameters are configurable. Switch(config-if)#standby group-number timers hellotime holdtime  Hellotime  Default = 3 seconds  Value varies from 1 to 255.  Holdtime  Default = 10 seconds  Value varies from 1 to 255.
  • 4. Anuj Kumar ciscobulls@gmail.com  To reinstate the default standby timer values, enter the following command: Switch(config-if)#no standby group-number timers Configuring HSRP Interface Tracking The f0/0 interfaces on router A tracks the S0/0 interface. If the link between the S0/0 interface and Core fails, the router automatically decrements its priority (10) on that interface and stops transmitting hello messages out interface f0/0. Router B assumes the active router role when no hello messages are detected for the specific holdtime period. Switch1(config)#interface vlan 10 Switch1(config-if)#ip address 192.168.101.2 255.255.255.0 Switch1(config-if)#standby 1 ip 192.168.101.1 Switch1(config-if)#standby priority 150 Switch1(config-if)#standby 1 preempt Switch1(config-if)#standby 1 track serial0/0(self interface name) Switch2(config)#interface vlan 10 Switch2(config-if)#ip address 192.168.101.3 255.255.255.0 Switch2(config-if)#standby 1 ip 192.168.101.1 Switch2(config-if)#standby priority 200 Switch2(config-if)#standby 1 preempt Switch2(config-if)#standby 1 track serial0/0 (self interface name) Practical
  • 5. Anuj Kumar ciscobulls@gmail.com Router(config)#host CORE CORE(config)#int f0/0 CORE(config-if)#ip address 192.168.102.1 255.255.255.0 CORE(config-if)#no shutdown CORE(config-if)int s0/0 CORE(config-if)#ip address 10.1.1.1 255.255.255.0 CORE(config-if)#no shutdown CORE(config-if)#int s0/1 CORE(config-if)#ip address 11.1.1.1 255.255.255.0 CORE(config-if)#no shutdown CORE(config-if)#router ei 100 CORE(config-router)#network 192.168.102.0 CORE(config-router)#network 10.1.1.0 0.0.0.255 CORE(config-router)#network 11.1.1.0 0.0.0.255 CORE(config-router)#no auto-summary SW1(config)#ho SW1 SW1(config)#int s0/0 SW1(config-if)#ip address 10.1.1.2 255.255.255.0 SW1(config-if)#no shutdown SW1(config-if)# int f0/0 SW1(config-if)# ip address 192.168.101.2 255.255.255.0 SW1(config-if)# no shutdown SW1(config-if)# router eigrp 100 SW1(config-router)# network 192.168.101.0 SW1(config-router)# network 10.1.1.0 0.0.0.255 SW1(config-router)# no auto-summary SW1(config-router)# exi SW1(config)# int f0/0 SW1(config-if)# standby 1 ip 192.168.101.1 *Mar 1 00:23:07.895: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 1 state Standby -> Active SW1(config-if)#standby 1 priority 150 SW1(config-if)#standby 1 preempt SW1(config-if)#standby 1 track serial 0/0 SW2(config)#ho SW2 SW2(config)#int f0/0 SW2(config-if)#ip address 192.168.101.3 255.255.255.0 SW2(config-if)#no shutdown SW2(config-if)#int s0/0 SW2(config-if)#ip address 11.1.1.2 255.255.255.0 SW2(config-if)#no shutdown SW2(config-if)#router ei 100 SW2(config-router)#network 192.168.101.0 SW2(config-router)#network 11.1.1.0 0.0.0.255 SW2(config-router)#no auto-summary
  • 6. Anuj Kumar ciscobulls@gmail.com SW2(config-router)#int f0/0 SW2(config-if)#standby 1 ip 192.168.101.1 SW2(config-if)#standby 1 priority 200 SW2(config-if)#standby 1 preempt *Mar 1 00:34:31.431: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 1 state Standby -> Active SW2(config-if)#standby 1 track serial 0/0 Verifying SW1#sh standby FastEthernet0/0 - Group 1 State is Standby 4 state changes, last state change 00:43:18 Virtual IP address is 192.168.101.1 Active virtual MAC address is 0000.0c07.ac01 Local virtual MAC address is 0000.0c07.ac01 (v1 default) Hello time 3 sec, hold time 10 sec Next hello sent in 0.000 secs Preemption enabled Active router is 192.168.101.3, priority 190 (expires in 6.912 sec) Standby router is local Priority 150 (configured 150) Track interface Serial0/0 state Up decrement 10 Group name is "hsrp-Fa0/0-1" (default) SW2#sh standby FastEthernet0/0 - Group 1 State is Active 2 state changes, last state change 00:44:28 Virtual IP address is 192.168.101.1 Active virtual MAC address is 0000.0c07.ac01 Local virtual MAC address is 0000.0c07.ac01 (v1 default) Hello time 3 sec, hold time 10 sec Next hello sent in 1.296 secs Preemption enabled Active router is local Standby router is 192.168.101.2, priority 150 (expires in 8.436 sec) Priority 190 (configured 200) Track interface Serial0/0 state Down decrement 10 Group name is "hsrp-Fa0/0-1" (default) Thank you for giving me your precious time. Anuj Kumar