SlideShare ist ein Scribd-Unternehmen logo
1 von 16
Downloaden Sie, um offline zu lesen
CCNA All Commands
Page 1 of 16
CCNA Routing & Switching Commands
IP ROUTING
To view IP routing tables created on a Cisco router.
#sh ip route
Static Routing- Routers are manually configured for networks that are not directly connected,
to be able to route to all networks via the next-hop interface.
Example- Let 192.168.30.0/24 be the IP of a network not directly connected Let 192.168.20.2 be
the next hop interface
(config)#ip route 192.168.30.0 255.255.255.0 192.168.20.2
To remove static route
(config)#no ip route 192.168.30.0 255.255.255.0 192.168.20.2
Default Routing- Used on stub networks only to send packets with remote destination network
not in the routing table to the next hop router
Assume IP 192.168.40.1 is not in routing table
first remove static route
(config)#no ip route 192.168.30.0 255.255.255.0 192.168.40.1
(config)#ip route 0.0.0.0 0.0.0.0 192.168.40.1
CCNA All Commands
Page 2 of 16
RIP-A distance vector routing protocol that passes complete routing table contents to
neighbouring routers
Example- Let 192.168.10.0 & 192.168.20.0 be directly connected networks of a router interfaces
and 192.168.30.0 be non-directly connected
first delete all static routes
(config)#no ip route 192.168.30.0 255.255.255.0 192.168.20.2
(config)#router rip
(config-router)#192.168.10.0
(config-router)#192.168.20.0
(config-router)#^z
Verifying RIP
1.Sh ip route
2.debug ip
Holding Down RIP Propagation-To stop RIP update sending but allow its receipt -say for s0/0
with ip 192.168.10.0
(config)#router rip
(config-router)#network 192.168.10.0
(config-router)#passive-interface serial 0/0
CCNA All Commands
Page 3 of 16
IGRP-Also a distance routing protocol
Example- Let 192.168.10.0 & 192.168.20.0 be directly connected networks of a router interfaces
with autonomous system number of 10 and 192.168.30.0 be non-directly connected
#router igrp 10
(config-router)#network 192.168.10.0
(config-router)#network 192.168.20.0
(config-router)#^z
Verifying IGRP
sh ip route
Displays routed protocols and their interfaces
sh protocols
Displays routing protocols configured
sh ip protocols
Displays summary of IGRP routing information running on the network
debug igrp events
Displays messages request from neighbour routers
debug igrp transactions
Turning off all possible
debugging #un all
CCNA All Commands
Page 4 of 16
EIGRP-Uses classless routing which is subnet mask information sent with routing protocol
updates.
Example- Let 192.168.10.0 & 192.168.20.0 be directly connected networks of a router interfaces
with autonomous system number of 20 and 192.168.30.0 be non-directly connected
1. #router eigrp 20
2. (config-router)#network 192.168.10.0
3. (config-router)#network 192.168.20.0
4. (config-router)#^z
To stop EIGRP from working on an interface-no sending no receipt
(config)#router eigrp 20
(config-router)#passive-interface serial 0/0
To enable EIGRP on discontiguos networks(two different subnetworks of classfull network
connected by another different classful subnetwork)
Example- Let 172.16.0.0 & 10.0.0.0 be directly connected to a router to another remote
subnetwork of 192.168.10.0, then to enable EIGRP, we use
1. (config)#router eigrp 100
2. (config-router)#network 172.16.0.0
3. (config-router)#network 10.0.0.0
4. (config-router)#no auto-summary
N.B-The no auto-summary command sholuld be enabled in routers that encloses such networks.
Verifying EIGRP
sh ip route- Shows entire routing table
sh ip route eigrp- Shows only EIGRP entries in the routing table
ip eigrp neighbours- Shows all EIGRP neighbours
ip eigrp topology- Shows entries in the EIGRP topology table
CCNA All Commands
Page 5 of 16
OSPF- A link-state routing protocol
Example- Let 10.0.0.0 be the network directly connected to the router upon which OSPF is to be
enabled; with ospf ID of 1 and area o
1. (config)#router ospf 1
2. (config-router)#network 10.0.0.0 0.255.255.255 area0
Loopback Interface- They are configured to be used as the routers RID to advertise the routes
and elect DR and BDR.
Example- Let the loopback iinterface be configured on interface with ip 172.16.10.1
(config)#int loopback 0
(config-if)#ip address 172.16.10.1 255.255.255.0
(config-if)#no shut
(config-if)#^z
Verifying OSPF Configuration
Used to display all OSPF information
sho ip ospf
indicates the number of links and neighboring router ID
sho ip ospf database
Displays all OSPF interface related info
sho ip ospf interface
Summarizes OSPF info about neighbours
sho ip ospf neighbour
Overview of all present running protocols
sho ip protocols
CCNA All Commands
Page 6 of 16
Verifying Loopback and RID
To verify loopback address
sho running-config
Verifies the new RID of each router
sho ip ospf database
Verifies the new RID of each router
sho ip ospf interface
Initial configuration of a 1900 Switch with ip 172.16.10.16
>en
#config t
(config)#enable password level 1 kennifeh
(config)#enable password level 15 kennifeh 1
(config)#enable secret kennifeh 2 (when enabled no need 4 enable password)
(config)#hostname kenn 1900
(config)#ip address 172.16.10.16 255.255.255.0
(config)#ip default-gateway 172.16.10.1 (config)#int f0/1
(config-if)#description Finance_vlan (No space for 1900)
(config-if)#int f0/26
(config-if)#description Trunk_to_Biulding
(config-if)#exit
CCNA All Commands
Page 7 of 16
Initail Configuration of 2950 Switch with ip 172.16.10.17 255.255.255.0
>en
#config t(config)#hostame kenn2950
(config)#enable password kenn
(config)#enable password kenn1 (enable and enable secret password must be different)
(config)#line vty 0 15
(config-line)#login
(config-line)#password telnet
(config-line)#line con 0
(config-line)#login
(config-line)#password console
(config-line)#exit
(config)#int vlan 1
(config-if)#ip address 172.16.10.17 255.255.255.0
(config-if)#no shut
(config-if)#int f0/1
(config-if)#description sales printer(with space)
(config-if)#int f0/12
(config-if)description connection to backbone
(config-if)#exit
(config)#ip default-gateway 172.16.10.1
(config)
Erasing Switching Configuration 1900
#delete nvram yes
Erasing Switching Configuration 2950
#erase startup-config Enter
CCNA All Commands
Page 8 of 16
Configuring VLANS 1900
>en #config t
(config)#vlan 2 name Cisco
(config)#vlan 3 name Microsoft
(config)#vlan 4 name Comptia
(config)#exit
Verify with command
sh run
Configuring for 2950
>en
#vlan database
(vlan)#vlan 2 name Cisco
(vlan)#vlan 3 name Microsoft
(vlan)#vlan 4 name Comptia (vlan)#apply
(vlan)#^c
Verify with command sh vlan brief
Assigning Switch Ports To Vlan-1900
(config)#int e0/2
(config-if)#vlan-membership static 2
(config-if)#int e0/3
(config-if)#vlan-membership static 3
(config-if)#exit
Verify with
sh vlan
CCNA All Commands
Page 9 of 16
Assigning Switch Ports To Vlan-2950
(config)#int f0/2
(config-if)#switchport access vlan 2
(config-if)#int f0/3
(config-t)#switchport access vlan 3
(config-if)#int f0/4
(config-if)#switchport access vlan 4
(config-if)#verify with sh vlan brief
Configuring Trunks ports
(config)#int f0/26
(config-if)#trunk on
Configuring Trunk Ports for 2950
(config)#int f0/12
(config-if)#switchport mode trunk
(config-if)#^z
To disable Trunk use
switchport mode access
To verify Trunking use
sh running config
CCNA All Commands
Page 10 of 16
Configuring Inter-vlan Routing for 1900 connecting to 2600
(config)#int f0/0.1
(config-if)#encapsulation isl vlan (d number)
Configuring Inter-vlan Routing for 2950 connecting to 2600
(config)#int f0/0.1
(config-if)#encapsulation dot1q vlan (d number)
Configuring VTP for 1900
(config)#vtp server
(config)vtp domain kenn
(config)#vtp password kenn
Configuring VTP for 2950
(config)#vtp mode server
(config)#vtp domain routersim
(config)#^z
Verify with
sh vtp status
CCNA All Commands
Page 11 of 16
Checking the Current Configuration Register Values
Show version or show ver
Changing Configuration Register
(config)#config-register 0x101 (d default is 0x2102) (config)#^z
Recovering Passwords
Interrupt the Router Boot Sequene
ctrl+Break key (windows wont perform break key, only 95/98)
Changing the configuration register -for 2600 series router
rammon>confreg 0x2142
for 2500 - type 0 after a break and enter the command o/r 0x2142
Reloading the Router and Entering Privilged mode - for 2600 - type reset
Viewing and changing the configuration - copy run start
Resetting the configuration Register and Reloading the Router - config t
Backing up and restoring the Cisco ios
verifying flash memory - Ensuring flash memory has enough
room router#sh flash
Backing-up the ciso ios
first verify server connectivity by-
Router#ping 192.168.0.120
then; router#copy flash tftp
CCNA All Commands
Page 12 of 16
Restoring or upgrading the cisco router
ios router#copy tftp flash
[confirm][ENTER]
?[ENTER]
Backing up and Restoring the Cisco configuration
Backing up the cisco router configuration
copy runing config tftp
Verifying the current configuration
sh run
copying the current cofiguration to NVRAM
copy run start
copying the current configuration to a TFTP server
copy run TFTP
Restoring the Cisco Router Configuration
copy TFTP run
Erasing the configuration
erase startup-config
CCNA All Commands
Page 13 of 16
Getting CDP timers and Holdtime
information Router#config t
Router(config)#cdp timer 90
Router(config)#cdp holdtime 240
Router(config)#^z
To turn-off CDP Completely
no cdp run
Gathering Neighbour information
kenn2509#sh cdp nei
delivers information about directly connected devices or
kenn2509#sh cdp neighbour detail
Also sh cdp entry
Gathering Interface Traffic Information
kenn2509#sh cdp traffic
Gathering port and Interface
information kenn2509#sh cdp interface
To turn off cdp on a router,
use no cdp enable
then ^z
CCNA All Commands
Page 14 of 16
Using Telnet
kenn2509#telnet 172.16.10.2
Telnetting into multiple devices
simultaneously kenn2509#telnet 172.16.10.2
then, 2501B>{cntl+shift+6, then x}
Checking Telnet connections
kenn2509#sh sessions - connections from your router to remote
Checking Telnet users
kenn2509#sh user
Closing Telnet sessions
1900switch>exit OR
kenn2509#disconnect1 (num of active networks)
CCNA All Commands
Page 15 of 16
Resolving Hostname
kenn2509#config t
kenn2509(config)#ip host 2501B 172.16.10.2
kenn2509(config)#ip host 1900switch 192.168.0.148
kenn2509(config)#^z
To remove a hostname from a table, use
RouterA(config)#no ip host routerB
Using DNS to resolve names
#config t
(config)#ip domain-lookup (usually turned on by default)
(config)#ip name-server 192.168.0.70 (ip of an assumed DNS set)
(config)#ip domain-name kenn.com (Appends the domain name to a host)
(config)#^z
Check Network Connectivity use ping command
#ping kenn2509
Using Traceroute command
#trace 2501B
CCNA All Commands
Page 16 of 16
Access Lists
Creating a Standard Access Lists (1-99 or 1,300-1,999)
(config)#access-list 10 deny 172.16.30.2 (using the ip as a test)
Controlling vty(Telnet) sessions
(config)#access-list 50 permit 172.16.30.2
(config)#line vty 0 4
(config-line)#access-class 50 in
Creating Extended Access-lists (100 to 199) OR (2000 to 2699)
(config)#access-list 110 deny tcp any host 172.16.30.2 eq 23 log
(config)#access-list 110 permit ip any any
(config)#int f0/0
(config-if)#ip access-group 110 in
(config-if)#ipaccess-group 110 out

Weitere ähnliche Inhalte

Was ist angesagt?

IOS Cisco - Cheat sheets
IOS Cisco - Cheat sheetsIOS Cisco - Cheat sheets
IOS Cisco - Cheat sheetsAlejandro Marin
 
How to configure vlan, stp, dtp step by step guide
How to configure vlan, stp, dtp step by step guideHow to configure vlan, stp, dtp step by step guide
How to configure vlan, stp, dtp step by step guideIT Tech
 
Ccnp workbook network bulls
Ccnp workbook network bullsCcnp workbook network bulls
Ccnp workbook network bullsSwapnil Kapate
 
Ccna Commands In 10 Minutes
Ccna Commands In 10 MinutesCcna Commands In 10 Minutes
Ccna Commands In 10 MinutesCCNAResources
 
1000 Ccna Questions And Answers
1000 Ccna Questions And Answers1000 Ccna Questions And Answers
1000 Ccna Questions And AnswersCCNAResources
 
Lab 6.4.1 InterVLAN routing
Lab 6.4.1 InterVLAN routingLab 6.4.1 InterVLAN routing
Lab 6.4.1 InterVLAN routingMuhd Mu'izuddin
 
CCNA2 Verson6 Chapter6
CCNA2 Verson6 Chapter6CCNA2 Verson6 Chapter6
CCNA2 Verson6 Chapter6Chaing Ravuth
 
Cisco vs. huawei CLI Commands
Cisco vs. huawei CLI CommandsCisco vs. huawei CLI Commands
Cisco vs. huawei CLI CommandsBootcamp SCL
 
Free CCNP switching workbook by networkershome pdf
Free CCNP switching workbook by networkershome pdfFree CCNP switching workbook by networkershome pdf
Free CCNP switching workbook by networkershome pdfNetworkershome
 
Cisco router basic
Cisco router basicCisco router basic
Cisco router basicTapan Khilar
 
Dynamic Routing IGRP
Dynamic Routing IGRPDynamic Routing IGRP
Dynamic Routing IGRPKishore Kumar
 
Troubleshooting BGP
Troubleshooting BGPTroubleshooting BGP
Troubleshooting BGPAPNIC
 
Cisco Networking (Routing and Switching)
Cisco Networking (Routing and Switching)Cisco Networking (Routing and Switching)
Cisco Networking (Routing and Switching)Alan Mark
 
CCNA ppt Day 1
CCNA ppt Day 1CCNA ppt Day 1
CCNA ppt Day 1VISHNU N
 
Ncat ccna cheat sheet
Ncat ccna cheat sheetNcat ccna cheat sheet
Ncat ccna cheat sheetEZREIG OMAR
 
CCNA 2 Routing and Switching v5.0 Chapter 5
CCNA 2 Routing and Switching v5.0 Chapter 5CCNA 2 Routing and Switching v5.0 Chapter 5
CCNA 2 Routing and Switching v5.0 Chapter 5Nil Menon
 

Was ist angesagt? (20)

IOS Cisco - Cheat sheets
IOS Cisco - Cheat sheetsIOS Cisco - Cheat sheets
IOS Cisco - Cheat sheets
 
Cisco Commands
Cisco CommandsCisco Commands
Cisco Commands
 
How to configure vlan, stp, dtp step by step guide
How to configure vlan, stp, dtp step by step guideHow to configure vlan, stp, dtp step by step guide
How to configure vlan, stp, dtp step by step guide
 
Ccnp workbook network bulls
Ccnp workbook network bullsCcnp workbook network bulls
Ccnp workbook network bulls
 
ccna cheat_sheet
ccna cheat_sheetccna cheat_sheet
ccna cheat_sheet
 
Ccna Commands In 10 Minutes
Ccna Commands In 10 MinutesCcna Commands In 10 Minutes
Ccna Commands In 10 Minutes
 
1000 Ccna Questions And Answers
1000 Ccna Questions And Answers1000 Ccna Questions And Answers
1000 Ccna Questions And Answers
 
Lab 6.4.1 InterVLAN routing
Lab 6.4.1 InterVLAN routingLab 6.4.1 InterVLAN routing
Lab 6.4.1 InterVLAN routing
 
CCNA2 Verson6 Chapter6
CCNA2 Verson6 Chapter6CCNA2 Verson6 Chapter6
CCNA2 Verson6 Chapter6
 
Cisco vs. huawei CLI Commands
Cisco vs. huawei CLI CommandsCisco vs. huawei CLI Commands
Cisco vs. huawei CLI Commands
 
Free CCNP switching workbook by networkershome pdf
Free CCNP switching workbook by networkershome pdfFree CCNP switching workbook by networkershome pdf
Free CCNP switching workbook by networkershome pdf
 
Cisco router basic
Cisco router basicCisco router basic
Cisco router basic
 
Dynamic Routing IGRP
Dynamic Routing IGRPDynamic Routing IGRP
Dynamic Routing IGRP
 
Troubleshooting BGP
Troubleshooting BGPTroubleshooting BGP
Troubleshooting BGP
 
Cisco Networking (Routing and Switching)
Cisco Networking (Routing and Switching)Cisco Networking (Routing and Switching)
Cisco Networking (Routing and Switching)
 
CCNA ppt Day 1
CCNA ppt Day 1CCNA ppt Day 1
CCNA ppt Day 1
 
Nat pat
Nat patNat pat
Nat pat
 
Ncat ccna cheat sheet
Ncat ccna cheat sheetNcat ccna cheat sheet
Ncat ccna cheat sheet
 
CCNA 2 Routing and Switching v5.0 Chapter 5
CCNA 2 Routing and Switching v5.0 Chapter 5CCNA 2 Routing and Switching v5.0 Chapter 5
CCNA 2 Routing and Switching v5.0 Chapter 5
 
ccna networking ppt
ccna networking pptccna networking ppt
ccna networking ppt
 

Andere mochten auch

Switch configuration (command)
Switch configuration (command)Switch configuration (command)
Switch configuration (command)Muhammad Ibrahim
 
Lab practice 1 configuring basic routing and switching (with answer)
Lab practice 1   configuring basic routing and switching (with answer) Lab practice 1   configuring basic routing and switching (with answer)
Lab practice 1 configuring basic routing and switching (with answer) Arz Sy
 
Step by Step guide to set up a simple network in Packet Tracer
Step by Step guide to set up a simple network in Packet TracerStep by Step guide to set up a simple network in Packet Tracer
Step by Step guide to set up a simple network in Packet TracerSorath Asnani
 
Routers and Routing Configuration
Routers and Routing ConfigurationRouters and Routing Configuration
Routers and Routing Configurationyasir1122
 
Router configuration in packet tracer
Router configuration in packet  tracerRouter configuration in packet  tracer
Router configuration in packet tracerAnabia Anabia
 
Increase internet speed by 20%
Increase internet speed by 20%Increase internet speed by 20%
Increase internet speed by 20%usamaali213
 
Cisco router configuration tutorial
Cisco router configuration tutorialCisco router configuration tutorial
Cisco router configuration tutorialIT Tech
 
37 en-1-especificaciones
37 en-1-especificaciones37 en-1-especificaciones
37 en-1-especificacionesIVAN GAVILAN
 
Cisco Router Basic Configuration
Cisco Router Basic ConfigurationCisco Router Basic Configuration
Cisco Router Basic ConfigurationProf. Erwin Globio
 

Andere mochten auch (12)

Switch configuration (command)
Switch configuration (command)Switch configuration (command)
Switch configuration (command)
 
Ccna full
Ccna fullCcna full
Ccna full
 
Lab practice 1 configuring basic routing and switching (with answer)
Lab practice 1   configuring basic routing and switching (with answer) Lab practice 1   configuring basic routing and switching (with answer)
Lab practice 1 configuring basic routing and switching (with answer)
 
Step by Step guide to set up a simple network in Packet Tracer
Step by Step guide to set up a simple network in Packet TracerStep by Step guide to set up a simple network in Packet Tracer
Step by Step guide to set up a simple network in Packet Tracer
 
Routers and Routing Configuration
Routers and Routing ConfigurationRouters and Routing Configuration
Routers and Routing Configuration
 
Router configuration in packet tracer
Router configuration in packet  tracerRouter configuration in packet  tracer
Router configuration in packet tracer
 
Ccna concepts
Ccna conceptsCcna concepts
Ccna concepts
 
Increase internet speed by 20%
Increase internet speed by 20%Increase internet speed by 20%
Increase internet speed by 20%
 
Cisco router configuration tutorial
Cisco router configuration tutorialCisco router configuration tutorial
Cisco router configuration tutorial
 
37 en-1-especificaciones
37 en-1-especificaciones37 en-1-especificaciones
37 en-1-especificaciones
 
Cisco Router Basic Configuration
Cisco Router Basic ConfigurationCisco Router Basic Configuration
Cisco Router Basic Configuration
 
Ccna notes
Ccna notesCcna notes
Ccna notes
 

Ähnlich wie CCNA - Routing & Switching Commands

Routing protocol commands list
Routing protocol commands listRouting protocol commands list
Routing protocol commands listactsupport .com
 
Basic cisco commands_by_marcus_nielson_2
Basic cisco commands_by_marcus_nielson_2Basic cisco commands_by_marcus_nielson_2
Basic cisco commands_by_marcus_nielson_2MAFANTIRI SELLO
 
Routing information protocol & rip configuration
Routing information protocol & rip configurationRouting information protocol & rip configuration
Routing information protocol & rip configuration3Anetwork com
 
How to Configure Routing Information Protocol (RIP)
How to Configure Routing Information Protocol (RIP)How to Configure Routing Information Protocol (RIP)
How to Configure Routing Information Protocol (RIP)IT Tech
 
How to configure frame realy
How to configure frame realyHow to configure frame realy
How to configure frame realyNetProtocol Xpert
 
Service Provider Networks and Frame Relay
Service Provider Networks and Frame RelayService Provider Networks and Frame Relay
Service Provider Networks and Frame RelayTharindu Sankalpa
 
cisco ccna cheat_sheet
cisco ccna cheat_sheetcisco ccna cheat_sheet
cisco ccna cheat_sheetGuntaka Reddy
 
VRF Configuration
VRF ConfigurationVRF Configuration
VRF ConfigurationNetwax Lab
 
Ciso 4 ospf
Ciso 4 ospfCiso 4 ospf
Ciso 4 ospfmyciokas
 
OSPF (open shortest path first) part iii
OSPF (open shortest path first) part  iiiOSPF (open shortest path first) part  iii
OSPF (open shortest path first) part iiiNetwax Lab
 

Ähnlich wie CCNA - Routing & Switching Commands (20)

Ccnacommand 140205001152-phpapp01
Ccnacommand 140205001152-phpapp01Ccnacommand 140205001152-phpapp01
Ccnacommand 140205001152-phpapp01
 
Ccna commands
Ccna commandsCcna commands
Ccna commands
 
Ccna commands
Ccna commandsCcna commands
Ccna commands
 
Ccna commands
Ccna commands   Ccna commands
Ccna commands
 
Routing protocol commands list
Routing protocol commands listRouting protocol commands list
Routing protocol commands list
 
Networking Lab Report
Networking Lab ReportNetworking Lab Report
Networking Lab Report
 
Ciso commands
Ciso commandsCiso commands
Ciso commands
 
Ciso commands
Ciso commandsCiso commands
Ciso commands
 
Basic cisco commands_by_marcus_nielson_2
Basic cisco commands_by_marcus_nielson_2Basic cisco commands_by_marcus_nielson_2
Basic cisco commands_by_marcus_nielson_2
 
Routing information protocol & rip configuration
Routing information protocol & rip configurationRouting information protocol & rip configuration
Routing information protocol & rip configuration
 
How to Configure Routing Information Protocol (RIP)
How to Configure Routing Information Protocol (RIP)How to Configure Routing Information Protocol (RIP)
How to Configure Routing Information Protocol (RIP)
 
How to configure frame realy
How to configure frame realyHow to configure frame realy
How to configure frame realy
 
Service Provider Networks and Frame Relay
Service Provider Networks and Frame RelayService Provider Networks and Frame Relay
Service Provider Networks and Frame Relay
 
cisco ccna cheat_sheet
cisco ccna cheat_sheetcisco ccna cheat_sheet
cisco ccna cheat_sheet
 
VRF Configuration
VRF ConfigurationVRF Configuration
VRF Configuration
 
Ciso 4 ospf
Ciso 4 ospfCiso 4 ospf
Ciso 4 ospf
 
Ccna command
Ccna commandCcna command
Ccna command
 
Ciso ospf
Ciso ospfCiso ospf
Ciso ospf
 
OSWAN.pptx
OSWAN.pptxOSWAN.pptx
OSWAN.pptx
 
OSPF (open shortest path first) part iii
OSPF (open shortest path first) part  iiiOSPF (open shortest path first) part  iii
OSPF (open shortest path first) part iii
 

Mehr von Eng. Emad Al-Atoum

Mehr von Eng. Emad Al-Atoum (12)

Mind Mapping
Mind MappingMind Mapping
Mind Mapping
 
How to Build Your Own Power Supply
How to Build Your Own Power SupplyHow to Build Your Own Power Supply
How to Build Your Own Power Supply
 
CCNA 200-120 Exam Quick Notes
CCNA 200-120 Exam Quick NotesCCNA 200-120 Exam Quick Notes
CCNA 200-120 Exam Quick Notes
 
Ccna 200-120 Exam Dumps
Ccna 200-120 Exam DumpsCcna 200-120 Exam Dumps
Ccna 200-120 Exam Dumps
 
CCNA 200-120 Exam Questions
CCNA 200-120 Exam QuestionsCCNA 200-120 Exam Questions
CCNA 200-120 Exam Questions
 
NAT- Network Address Translation
NAT- Network Address TranslationNAT- Network Address Translation
NAT- Network Address Translation
 
Fast and Easy Subnetting
Fast and Easy SubnettingFast and Easy Subnetting
Fast and Easy Subnetting
 
CISCO Exact Questions By: Konard
CISCO Exact Questions By: KonardCISCO Exact Questions By: Konard
CISCO Exact Questions By: Konard
 
CCNA Quick Notes
CCNA Quick NotesCCNA Quick Notes
CCNA Quick Notes
 
CCNA Dec, 2015 Questions
CCNA Dec, 2015 QuestionsCCNA Dec, 2015 Questions
CCNA Dec, 2015 Questions
 
50 Impossible Quotes
50 Impossible Quotes50 Impossible Quotes
50 Impossible Quotes
 
CCNA Exam Question
CCNA Exam QuestionCCNA Exam Question
CCNA Exam Question
 

Kürzlich hochgeladen

4.16.24 21st Century Movements for Black Lives.pptx
4.16.24 21st Century Movements for Black Lives.pptx4.16.24 21st Century Movements for Black Lives.pptx
4.16.24 21st Century Movements for Black Lives.pptxmary850239
 
Concurrency Control in Database Management system
Concurrency Control in Database Management systemConcurrency Control in Database Management system
Concurrency Control in Database Management systemChristalin Nelson
 
Expanded definition: technical and operational
Expanded definition: technical and operationalExpanded definition: technical and operational
Expanded definition: technical and operationalssuser3e220a
 
Keynote by Prof. Wurzer at Nordex about IP-design
Keynote by Prof. Wurzer at Nordex about IP-designKeynote by Prof. Wurzer at Nordex about IP-design
Keynote by Prof. Wurzer at Nordex about IP-designMIPLM
 
Choosing the Right CBSE School A Comprehensive Guide for Parents
Choosing the Right CBSE School A Comprehensive Guide for ParentsChoosing the Right CBSE School A Comprehensive Guide for Parents
Choosing the Right CBSE School A Comprehensive Guide for Parentsnavabharathschool99
 
Grade 9 Quarter 4 Dll Grade 9 Quarter 4 DLL.pdf
Grade 9 Quarter 4 Dll Grade 9 Quarter 4 DLL.pdfGrade 9 Quarter 4 Dll Grade 9 Quarter 4 DLL.pdf
Grade 9 Quarter 4 Dll Grade 9 Quarter 4 DLL.pdfJemuel Francisco
 
The Contemporary World: The Globalization of World Politics
The Contemporary World: The Globalization of World PoliticsThe Contemporary World: The Globalization of World Politics
The Contemporary World: The Globalization of World PoliticsRommel Regala
 
Measures of Position DECILES for ungrouped data
Measures of Position DECILES for ungrouped dataMeasures of Position DECILES for ungrouped data
Measures of Position DECILES for ungrouped dataBabyAnnMotar
 
Millenials and Fillennials (Ethical Challenge and Responses).pptx
Millenials and Fillennials (Ethical Challenge and Responses).pptxMillenials and Fillennials (Ethical Challenge and Responses).pptx
Millenials and Fillennials (Ethical Challenge and Responses).pptxJanEmmanBrigoli
 
USPS® Forced Meter Migration - How to Know if Your Postage Meter Will Soon be...
USPS® Forced Meter Migration - How to Know if Your Postage Meter Will Soon be...USPS® Forced Meter Migration - How to Know if Your Postage Meter Will Soon be...
USPS® Forced Meter Migration - How to Know if Your Postage Meter Will Soon be...Postal Advocate Inc.
 
Field Attribute Index Feature in Odoo 17
Field Attribute Index Feature in Odoo 17Field Attribute Index Feature in Odoo 17
Field Attribute Index Feature in Odoo 17Celine George
 
TEACHER REFLECTION FORM (NEW SET........).docx
TEACHER REFLECTION FORM (NEW SET........).docxTEACHER REFLECTION FORM (NEW SET........).docx
TEACHER REFLECTION FORM (NEW SET........).docxruthvilladarez
 
Student Profile Sample - We help schools to connect the data they have, with ...
Student Profile Sample - We help schools to connect the data they have, with ...Student Profile Sample - We help schools to connect the data they have, with ...
Student Profile Sample - We help schools to connect the data they have, with ...Seán Kennedy
 
ENG 5 Q4 WEEk 1 DAY 1 Restate sentences heard in one’s own words. Use appropr...
ENG 5 Q4 WEEk 1 DAY 1 Restate sentences heard in one’s own words. Use appropr...ENG 5 Q4 WEEk 1 DAY 1 Restate sentences heard in one’s own words. Use appropr...
ENG 5 Q4 WEEk 1 DAY 1 Restate sentences heard in one’s own words. Use appropr...JojoEDelaCruz
 
Daily Lesson Plan in Mathematics Quarter 4
Daily Lesson Plan in Mathematics Quarter 4Daily Lesson Plan in Mathematics Quarter 4
Daily Lesson Plan in Mathematics Quarter 4JOYLYNSAMANIEGO
 
4.16.24 Poverty and Precarity--Desmond.pptx
4.16.24 Poverty and Precarity--Desmond.pptx4.16.24 Poverty and Precarity--Desmond.pptx
4.16.24 Poverty and Precarity--Desmond.pptxmary850239
 

Kürzlich hochgeladen (20)

4.16.24 21st Century Movements for Black Lives.pptx
4.16.24 21st Century Movements for Black Lives.pptx4.16.24 21st Century Movements for Black Lives.pptx
4.16.24 21st Century Movements for Black Lives.pptx
 
Concurrency Control in Database Management system
Concurrency Control in Database Management systemConcurrency Control in Database Management system
Concurrency Control in Database Management system
 
YOUVE GOT EMAIL_FINALS_EL_DORADO_2024.pptx
YOUVE GOT EMAIL_FINALS_EL_DORADO_2024.pptxYOUVE GOT EMAIL_FINALS_EL_DORADO_2024.pptx
YOUVE GOT EMAIL_FINALS_EL_DORADO_2024.pptx
 
Expanded definition: technical and operational
Expanded definition: technical and operationalExpanded definition: technical and operational
Expanded definition: technical and operational
 
Keynote by Prof. Wurzer at Nordex about IP-design
Keynote by Prof. Wurzer at Nordex about IP-designKeynote by Prof. Wurzer at Nordex about IP-design
Keynote by Prof. Wurzer at Nordex about IP-design
 
Choosing the Right CBSE School A Comprehensive Guide for Parents
Choosing the Right CBSE School A Comprehensive Guide for ParentsChoosing the Right CBSE School A Comprehensive Guide for Parents
Choosing the Right CBSE School A Comprehensive Guide for Parents
 
Grade 9 Quarter 4 Dll Grade 9 Quarter 4 DLL.pdf
Grade 9 Quarter 4 Dll Grade 9 Quarter 4 DLL.pdfGrade 9 Quarter 4 Dll Grade 9 Quarter 4 DLL.pdf
Grade 9 Quarter 4 Dll Grade 9 Quarter 4 DLL.pdf
 
The Contemporary World: The Globalization of World Politics
The Contemporary World: The Globalization of World PoliticsThe Contemporary World: The Globalization of World Politics
The Contemporary World: The Globalization of World Politics
 
Measures of Position DECILES for ungrouped data
Measures of Position DECILES for ungrouped dataMeasures of Position DECILES for ungrouped data
Measures of Position DECILES for ungrouped data
 
Millenials and Fillennials (Ethical Challenge and Responses).pptx
Millenials and Fillennials (Ethical Challenge and Responses).pptxMillenials and Fillennials (Ethical Challenge and Responses).pptx
Millenials and Fillennials (Ethical Challenge and Responses).pptx
 
YOUVE_GOT_EMAIL_PRELIMS_EL_DORADO_2024.pptx
YOUVE_GOT_EMAIL_PRELIMS_EL_DORADO_2024.pptxYOUVE_GOT_EMAIL_PRELIMS_EL_DORADO_2024.pptx
YOUVE_GOT_EMAIL_PRELIMS_EL_DORADO_2024.pptx
 
USPS® Forced Meter Migration - How to Know if Your Postage Meter Will Soon be...
USPS® Forced Meter Migration - How to Know if Your Postage Meter Will Soon be...USPS® Forced Meter Migration - How to Know if Your Postage Meter Will Soon be...
USPS® Forced Meter Migration - How to Know if Your Postage Meter Will Soon be...
 
Field Attribute Index Feature in Odoo 17
Field Attribute Index Feature in Odoo 17Field Attribute Index Feature in Odoo 17
Field Attribute Index Feature in Odoo 17
 
TEACHER REFLECTION FORM (NEW SET........).docx
TEACHER REFLECTION FORM (NEW SET........).docxTEACHER REFLECTION FORM (NEW SET........).docx
TEACHER REFLECTION FORM (NEW SET........).docx
 
Student Profile Sample - We help schools to connect the data they have, with ...
Student Profile Sample - We help schools to connect the data they have, with ...Student Profile Sample - We help schools to connect the data they have, with ...
Student Profile Sample - We help schools to connect the data they have, with ...
 
LEFT_ON_C'N_ PRELIMS_EL_DORADO_2024.pptx
LEFT_ON_C'N_ PRELIMS_EL_DORADO_2024.pptxLEFT_ON_C'N_ PRELIMS_EL_DORADO_2024.pptx
LEFT_ON_C'N_ PRELIMS_EL_DORADO_2024.pptx
 
ENG 5 Q4 WEEk 1 DAY 1 Restate sentences heard in one’s own words. Use appropr...
ENG 5 Q4 WEEk 1 DAY 1 Restate sentences heard in one’s own words. Use appropr...ENG 5 Q4 WEEk 1 DAY 1 Restate sentences heard in one’s own words. Use appropr...
ENG 5 Q4 WEEk 1 DAY 1 Restate sentences heard in one’s own words. Use appropr...
 
Daily Lesson Plan in Mathematics Quarter 4
Daily Lesson Plan in Mathematics Quarter 4Daily Lesson Plan in Mathematics Quarter 4
Daily Lesson Plan in Mathematics Quarter 4
 
INCLUSIVE EDUCATION PRACTICES FOR TEACHERS AND TRAINERS.pptx
INCLUSIVE EDUCATION PRACTICES FOR TEACHERS AND TRAINERS.pptxINCLUSIVE EDUCATION PRACTICES FOR TEACHERS AND TRAINERS.pptx
INCLUSIVE EDUCATION PRACTICES FOR TEACHERS AND TRAINERS.pptx
 
4.16.24 Poverty and Precarity--Desmond.pptx
4.16.24 Poverty and Precarity--Desmond.pptx4.16.24 Poverty and Precarity--Desmond.pptx
4.16.24 Poverty and Precarity--Desmond.pptx
 

CCNA - Routing & Switching Commands

  • 1. CCNA All Commands Page 1 of 16 CCNA Routing & Switching Commands IP ROUTING To view IP routing tables created on a Cisco router. #sh ip route Static Routing- Routers are manually configured for networks that are not directly connected, to be able to route to all networks via the next-hop interface. Example- Let 192.168.30.0/24 be the IP of a network not directly connected Let 192.168.20.2 be the next hop interface (config)#ip route 192.168.30.0 255.255.255.0 192.168.20.2 To remove static route (config)#no ip route 192.168.30.0 255.255.255.0 192.168.20.2 Default Routing- Used on stub networks only to send packets with remote destination network not in the routing table to the next hop router Assume IP 192.168.40.1 is not in routing table first remove static route (config)#no ip route 192.168.30.0 255.255.255.0 192.168.40.1 (config)#ip route 0.0.0.0 0.0.0.0 192.168.40.1
  • 2. CCNA All Commands Page 2 of 16 RIP-A distance vector routing protocol that passes complete routing table contents to neighbouring routers Example- Let 192.168.10.0 & 192.168.20.0 be directly connected networks of a router interfaces and 192.168.30.0 be non-directly connected first delete all static routes (config)#no ip route 192.168.30.0 255.255.255.0 192.168.20.2 (config)#router rip (config-router)#192.168.10.0 (config-router)#192.168.20.0 (config-router)#^z Verifying RIP 1.Sh ip route 2.debug ip Holding Down RIP Propagation-To stop RIP update sending but allow its receipt -say for s0/0 with ip 192.168.10.0 (config)#router rip (config-router)#network 192.168.10.0 (config-router)#passive-interface serial 0/0
  • 3. CCNA All Commands Page 3 of 16 IGRP-Also a distance routing protocol Example- Let 192.168.10.0 & 192.168.20.0 be directly connected networks of a router interfaces with autonomous system number of 10 and 192.168.30.0 be non-directly connected #router igrp 10 (config-router)#network 192.168.10.0 (config-router)#network 192.168.20.0 (config-router)#^z Verifying IGRP sh ip route Displays routed protocols and their interfaces sh protocols Displays routing protocols configured sh ip protocols Displays summary of IGRP routing information running on the network debug igrp events Displays messages request from neighbour routers debug igrp transactions Turning off all possible debugging #un all
  • 4. CCNA All Commands Page 4 of 16 EIGRP-Uses classless routing which is subnet mask information sent with routing protocol updates. Example- Let 192.168.10.0 & 192.168.20.0 be directly connected networks of a router interfaces with autonomous system number of 20 and 192.168.30.0 be non-directly connected 1. #router eigrp 20 2. (config-router)#network 192.168.10.0 3. (config-router)#network 192.168.20.0 4. (config-router)#^z To stop EIGRP from working on an interface-no sending no receipt (config)#router eigrp 20 (config-router)#passive-interface serial 0/0 To enable EIGRP on discontiguos networks(two different subnetworks of classfull network connected by another different classful subnetwork) Example- Let 172.16.0.0 & 10.0.0.0 be directly connected to a router to another remote subnetwork of 192.168.10.0, then to enable EIGRP, we use 1. (config)#router eigrp 100 2. (config-router)#network 172.16.0.0 3. (config-router)#network 10.0.0.0 4. (config-router)#no auto-summary N.B-The no auto-summary command sholuld be enabled in routers that encloses such networks. Verifying EIGRP sh ip route- Shows entire routing table sh ip route eigrp- Shows only EIGRP entries in the routing table ip eigrp neighbours- Shows all EIGRP neighbours ip eigrp topology- Shows entries in the EIGRP topology table
  • 5. CCNA All Commands Page 5 of 16 OSPF- A link-state routing protocol Example- Let 10.0.0.0 be the network directly connected to the router upon which OSPF is to be enabled; with ospf ID of 1 and area o 1. (config)#router ospf 1 2. (config-router)#network 10.0.0.0 0.255.255.255 area0 Loopback Interface- They are configured to be used as the routers RID to advertise the routes and elect DR and BDR. Example- Let the loopback iinterface be configured on interface with ip 172.16.10.1 (config)#int loopback 0 (config-if)#ip address 172.16.10.1 255.255.255.0 (config-if)#no shut (config-if)#^z Verifying OSPF Configuration Used to display all OSPF information sho ip ospf indicates the number of links and neighboring router ID sho ip ospf database Displays all OSPF interface related info sho ip ospf interface Summarizes OSPF info about neighbours sho ip ospf neighbour Overview of all present running protocols sho ip protocols
  • 6. CCNA All Commands Page 6 of 16 Verifying Loopback and RID To verify loopback address sho running-config Verifies the new RID of each router sho ip ospf database Verifies the new RID of each router sho ip ospf interface Initial configuration of a 1900 Switch with ip 172.16.10.16 >en #config t (config)#enable password level 1 kennifeh (config)#enable password level 15 kennifeh 1 (config)#enable secret kennifeh 2 (when enabled no need 4 enable password) (config)#hostname kenn 1900 (config)#ip address 172.16.10.16 255.255.255.0 (config)#ip default-gateway 172.16.10.1 (config)#int f0/1 (config-if)#description Finance_vlan (No space for 1900) (config-if)#int f0/26 (config-if)#description Trunk_to_Biulding (config-if)#exit
  • 7. CCNA All Commands Page 7 of 16 Initail Configuration of 2950 Switch with ip 172.16.10.17 255.255.255.0 >en #config t(config)#hostame kenn2950 (config)#enable password kenn (config)#enable password kenn1 (enable and enable secret password must be different) (config)#line vty 0 15 (config-line)#login (config-line)#password telnet (config-line)#line con 0 (config-line)#login (config-line)#password console (config-line)#exit (config)#int vlan 1 (config-if)#ip address 172.16.10.17 255.255.255.0 (config-if)#no shut (config-if)#int f0/1 (config-if)#description sales printer(with space) (config-if)#int f0/12 (config-if)description connection to backbone (config-if)#exit (config)#ip default-gateway 172.16.10.1 (config) Erasing Switching Configuration 1900 #delete nvram yes Erasing Switching Configuration 2950 #erase startup-config Enter
  • 8. CCNA All Commands Page 8 of 16 Configuring VLANS 1900 >en #config t (config)#vlan 2 name Cisco (config)#vlan 3 name Microsoft (config)#vlan 4 name Comptia (config)#exit Verify with command sh run Configuring for 2950 >en #vlan database (vlan)#vlan 2 name Cisco (vlan)#vlan 3 name Microsoft (vlan)#vlan 4 name Comptia (vlan)#apply (vlan)#^c Verify with command sh vlan brief Assigning Switch Ports To Vlan-1900 (config)#int e0/2 (config-if)#vlan-membership static 2 (config-if)#int e0/3 (config-if)#vlan-membership static 3 (config-if)#exit Verify with sh vlan
  • 9. CCNA All Commands Page 9 of 16 Assigning Switch Ports To Vlan-2950 (config)#int f0/2 (config-if)#switchport access vlan 2 (config-if)#int f0/3 (config-t)#switchport access vlan 3 (config-if)#int f0/4 (config-if)#switchport access vlan 4 (config-if)#verify with sh vlan brief Configuring Trunks ports (config)#int f0/26 (config-if)#trunk on Configuring Trunk Ports for 2950 (config)#int f0/12 (config-if)#switchport mode trunk (config-if)#^z To disable Trunk use switchport mode access To verify Trunking use sh running config
  • 10. CCNA All Commands Page 10 of 16 Configuring Inter-vlan Routing for 1900 connecting to 2600 (config)#int f0/0.1 (config-if)#encapsulation isl vlan (d number) Configuring Inter-vlan Routing for 2950 connecting to 2600 (config)#int f0/0.1 (config-if)#encapsulation dot1q vlan (d number) Configuring VTP for 1900 (config)#vtp server (config)vtp domain kenn (config)#vtp password kenn Configuring VTP for 2950 (config)#vtp mode server (config)#vtp domain routersim (config)#^z Verify with sh vtp status
  • 11. CCNA All Commands Page 11 of 16 Checking the Current Configuration Register Values Show version or show ver Changing Configuration Register (config)#config-register 0x101 (d default is 0x2102) (config)#^z Recovering Passwords Interrupt the Router Boot Sequene ctrl+Break key (windows wont perform break key, only 95/98) Changing the configuration register -for 2600 series router rammon>confreg 0x2142 for 2500 - type 0 after a break and enter the command o/r 0x2142 Reloading the Router and Entering Privilged mode - for 2600 - type reset Viewing and changing the configuration - copy run start Resetting the configuration Register and Reloading the Router - config t Backing up and restoring the Cisco ios verifying flash memory - Ensuring flash memory has enough room router#sh flash Backing-up the ciso ios first verify server connectivity by- Router#ping 192.168.0.120 then; router#copy flash tftp
  • 12. CCNA All Commands Page 12 of 16 Restoring or upgrading the cisco router ios router#copy tftp flash [confirm][ENTER] ?[ENTER] Backing up and Restoring the Cisco configuration Backing up the cisco router configuration copy runing config tftp Verifying the current configuration sh run copying the current cofiguration to NVRAM copy run start copying the current configuration to a TFTP server copy run TFTP Restoring the Cisco Router Configuration copy TFTP run Erasing the configuration erase startup-config
  • 13. CCNA All Commands Page 13 of 16 Getting CDP timers and Holdtime information Router#config t Router(config)#cdp timer 90 Router(config)#cdp holdtime 240 Router(config)#^z To turn-off CDP Completely no cdp run Gathering Neighbour information kenn2509#sh cdp nei delivers information about directly connected devices or kenn2509#sh cdp neighbour detail Also sh cdp entry Gathering Interface Traffic Information kenn2509#sh cdp traffic Gathering port and Interface information kenn2509#sh cdp interface To turn off cdp on a router, use no cdp enable then ^z
  • 14. CCNA All Commands Page 14 of 16 Using Telnet kenn2509#telnet 172.16.10.2 Telnetting into multiple devices simultaneously kenn2509#telnet 172.16.10.2 then, 2501B>{cntl+shift+6, then x} Checking Telnet connections kenn2509#sh sessions - connections from your router to remote Checking Telnet users kenn2509#sh user Closing Telnet sessions 1900switch>exit OR kenn2509#disconnect1 (num of active networks)
  • 15. CCNA All Commands Page 15 of 16 Resolving Hostname kenn2509#config t kenn2509(config)#ip host 2501B 172.16.10.2 kenn2509(config)#ip host 1900switch 192.168.0.148 kenn2509(config)#^z To remove a hostname from a table, use RouterA(config)#no ip host routerB Using DNS to resolve names #config t (config)#ip domain-lookup (usually turned on by default) (config)#ip name-server 192.168.0.70 (ip of an assumed DNS set) (config)#ip domain-name kenn.com (Appends the domain name to a host) (config)#^z Check Network Connectivity use ping command #ping kenn2509 Using Traceroute command #trace 2501B
  • 16. CCNA All Commands Page 16 of 16 Access Lists Creating a Standard Access Lists (1-99 or 1,300-1,999) (config)#access-list 10 deny 172.16.30.2 (using the ip as a test) Controlling vty(Telnet) sessions (config)#access-list 50 permit 172.16.30.2 (config)#line vty 0 4 (config-line)#access-class 50 in Creating Extended Access-lists (100 to 199) OR (2000 to 2699) (config)#access-list 110 deny tcp any host 172.16.30.2 eq 23 log (config)#access-list 110 permit ip any any (config)#int f0/0 (config-if)#ip access-group 110 in (config-if)#ipaccess-group 110 out