SlideShare ist ein Scribd-Unternehmen logo
1 von 8
Enterprise network manager: The router-on-a-stick
At present, a lot of small and medium-sized enterprises’ network are formed by
multiple L2 switches + a router(you can use any one of Cisco router), and then
connect the router into the internet. So far, this is a common way to use router-on-
a-stick to manage the enterprise network.
In order to realize the communications between all the employees and the Internet in the
enterprises, it is unrealistic for a person using a public network address. Generally, the
enterprise has one or several public addresses while has dozens or even hundreds of
employees. How to communicate all these public addresses using employees with the
Internet? NAT technology definitely!
In general, there are lots of departments in a enterprise, such as finance department,
technology department, engineering department and so on, each department doing his
coherent responsibility. How to clearly distinguish these departments to facilitate the
management? VLAN technology absolutely!
In order to the convenient work and enhancement of the working efficiency, managers
from different departments have to communicate with each other while the employees’
are forbidden. How to do ? ACL technology without any doubt!
Now, let’s learn how to use the NAT+VLAN+ACL technology to manage the
enterprises’ network.
NTE ( Network Testing Environment) is as below:
Introduction:
The only public network address: 172.16.1.1/24
Three departments of the enterprise:
1
Finance department (PC1 for manager)
Technology department (PC3 for manager)
Engineering department (PC5 for manager)
IP:
PC1:192.168.1.2/24PC2:192.168.1.3/24
PC3:192.168.2.2/24PC4:192.168.2.3/24
PC5:192.168.3.2/24PC6:192.168.3.3/24
Test for purpose:
By NAT configuration, all the computers will be connected to communicate with Internet
through the only public network address.
To divide various departments through VLAN configuration and to realize the
intercommunications among managers from different departments through ACL
configuration while not among the employees.
Ok, let’s down to work as we’ve known the intention.
Firstly, basic configuration on R1 and R2 (dot1Q is needed to encapsulate for sub-
interface configuration as we have to use routing process among VLANs.)
R1
Router>en
Router#conft
Enterconfiguration commands, one per line. End withCNTL/Z.
Router(config)#host r1
r1(config)#int s0/0
r1(config-if)#ip addr 172.16.1.1 255.255.255.0
r1(config-if)#no shut
%LINK-5-CHANGED: Interface Serial0/0, changed state to up
r1(config-if)#clock rate 64000
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changedstate to u
r1(config-if)#exit
r1(config)#int f0/0
r1(config-if)#no ip addr
r1(config-if)#no shut
r1(config-if)#exit
r1(config)#intf0/0.1 (sub-interface configuration)
r1(config-subif)#encapsulation dot1Q2 (dot1Q is needed to encapsulate for sub-interface
configuration)
r1(config-subif)#ip addr 192.168.1.1 255.255.255.0
r1(config-subif)#no shut
r1(config-subif)#exit
2
r1(config)#intf0/0.2 (sub-interface configuration)
r1(config-subif)#encapsulation dot1Q3 (dot1Q is needed to encapsulate for sub-interface
configuration)
r1(config-subif)#ip addr 192.168.2.1 255.255.255.0
r1(config-subif)#no shut
r1(config-subif)#exit
r1(config)#intf0/0.3 (sub-interface configuration)
r1(config-subif)#encapsulation dot1Q4 (dot1Q is needed to encapsulate for sub-interface
configuration)
r1(config-subif)#ip addr 192.168.3.1 255.255.255.0
We just need the IP configuration on S0/0 port of R2 cause we take R2 as public
network.
R2
Router>en
Router#conft
Enterconfiguration commands, one per line. End withCNTL/Z.
Router(config)#host r2
r2(config)#int s0/0
r2(config-if)#ip addr 172.16.1.2 255.255.255.0
r2(config-if)#no shut
Secondly, to have all the employees passed through the only public network—IP
172.16.1.1/24 for
Internetcommunications.
R1
r1(config)#ip nat pool internet 172.16.1.1 172.16.1.1 netmask255.255.255.0
r1(config)#access-list 10 permit 192.168.0.00.0.255.255
r1(config)#ip nat inside source list 10 pool internet overload
r1(config)#int s0/0
r1(config-if)#ip nat outside
r1(config-if)#exit
r1(config)#int f0/0
r1(config-if)#ip nat inside
To divide various departments through VLAN configuration and to realize the
intercommunications among managers from different departments through ACL
configuration while not among the employees.
Sw
Switch>en
3
Switch#conft
Enterconfiguration commands, one per line. End withCNTL/Z.
Switch(config)#int f0/1
Switch(config-if)#switchport modetrunk (Trunk link configuration)
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1,changed state to
down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1,changed state to up
Switch(config-if)#exit
Switch(config)#vlan2 (VLAN 2 setting up)
Switch(config-vlan)#namegongchengbu (Vlan2: Engineering department)
Switch(config-vlan)#exit
Switch(config)#vlan3 (VLAN 3 setting up)
Switch(config-vlan)#namecaiwubu (VLAN3: Finance department)
Switch(config-vlan)#exit
Switch(config-vlan)#vlan4 (VLAN 4 setting up)
Switch(config-vlan)#namejishubu (VLAN4: Technology department)
Switch(config-vlan)#exit
Switch(config)#int f0/2
Switch(config-if)#switchport access vlan2 (Member adding to VLAN 2 manually)
Switch(config-if)#exit
Switch(config)#int f0/3
Switch(config-if)#switchport access vlan 2
Switch(config-if)#exit
Switch(config)#int f0/4
Switch(config-if)#switchport access vlan3 (Member adding to VLAN 3 manually)
Switch(config-if)#exit
Switch(config)#int f0/5
Switch(config-if)#switchport access vlan 3
Switch(config-if)#exit
Switch(config)#int f0/6
Switch(config-if)#switchport access vlan4 (Member adding to VLAN 4 manually)
Switch(config-if)#exit
Switch(config)#int f0/7
Switch(config-if)#switchport access vlan 4
Switch(config-if)#exit
The definition of ACL (Access Control List):
Be careful for ACL definition and you’d better put the most peculiar ACL on the top.
Note: The interface binding is needed if the ACL can be applied.
R1
r1(config)#access-list 10 permit 192.168.2.2 0.0.0.0
r1(config)#access-list 10 deny 192.168.2.0 0.0.0.255
4
r1(config)#access-list 10 permit 192.168.3.2 0.0.0.0
r1(config)#access-list 10 deny 192.168.3.0 0.0.0.255
r1(config)#access-list 10 permit any
r1(config)#int f0/0.1
r1(config-subif)#ip access-group 10 out
r1(config-subif)#exit
r1(config)#access-list 11 permit 192.168.1.2 0.0.0.0
r1(config)#access-list 11 deny 192.168.1.0 0.0.0.255
r1(config)#access-list 11 permit 192.168.3.2 0.0.0.0
r1(config)#access-list 11 deny 192.168.3.0 0.0.0.255
r1(config)#access-list 11 permit any
r1(config)#int f0/0.2
r1(config-subif)#ip access-group 11 out
r1(config-subif)#exit
r1(config)#access-list 12 permit 192.168.1.2 0.0.0.0
r1(config)#access-list 12 deny 192.168.1.0 0.0.0.255
r1(config)#access-list 12 permit 192.168.2.2 0.0.0.0
r1(config)#access-list 12 deny 192.168.2.0 0.0.0.255
r1(config)#access-list 12 permit any
r1(config)#int f0/0.3
r1(config-subif)#ip access-group 12 out
r1(config-subif)#exit
Now, all the employees can intercommunicates after configuration.
PC>ping 172.16.1.2
Pinging172.16.1.2 with 32 bytes of data:
Replyfrom 172.16.1.2: bytes=32 time=94ms TTL=254
Reply from172.16.1.2: bytes=32 time=94ms TTL=254
Reply from172.16.1.2: bytes=32 time=94ms TTL=254
Reply from172.16.1.2: bytes=32 time=90ms TTL=254
Pingstatistics for 172.16.1.2:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximateround trip times in milli-seconds:
Minimum =90ms, Maximum = 94ms, Average = 93ms
The intercommunications among managers from different departments (PC1, PC3
and PC5) have been realized after configuration.
PC1>ping 192.168.2.2
Pinging192.168.2.2 with 32 bytes of data:
Replyfrom 192.168.2.2: bytes=32 time=125ms TTL=127
Reply from192.168.2.2: bytes=32 time=110ms TTL=127
5
Reply from192.168.2.2: bytes=32 time=110ms TTL=127
Reply from192.168.2.2: bytes=32 time=125ms TTL=127
Pingstatistics for 192.168.2.2:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximateround trip times in milli-seconds:
Minimum =110ms, Maximum = 125ms, Average = 117ms
PC1 PING PC5
PC1>ping 192.168.3.2
Pinging192.168.3.2 with 32 bytes of data:
Replyfrom 192.168.3.2: bytes=32 time=111ms TTL=127
Reply from192.168.3.2: bytes=32 time=120ms TTL=127
Reply from192.168.3.2: bytes=32 time=111ms TTL=127
Reply from192.168.3.2: bytes=32 time=105ms TTL=127
Pingstatistics for 192.168.3.2:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximateround trip times in milli-seconds:
Minimum = 105ms, Maximum = 120ms, Average = 111ms
PC3 PING PC5
PC3>ping 192.168.3.2
Pinging192.168.3.2 with 32 bytes of data:
Replyfrom 192.168.3.2: bytes=32 time=125ms TTL=127
Reply from192.168.3.2: bytes=32 time=125ms TTL=127
Reply from192.168.3.2: bytes=32 time=109ms TTL=127
Reply from192.168.3.2: bytes=32 time=94ms TTL=127
Pingstatistics for 192.168.3.2:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximateround trip times in milli-seconds:
Minimum = 94ms, Maximum = 125ms, Average = 113ms
There is no intercommunications among employees.(PC2,PC4 and PC6)
PC2 PING PC4
PC2>ping 192.168.2.3
Pinging192.168.2.3 with 32 bytes of data:
Requesttimed out.
Requesttimed out.
Requesttimed out.
Requesttimed out.
Pingstatistics for 192.168.2.3:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),
PC2 PING PC6
6
PC2>ping 192.168.3.3
Pinging192.168.3.3 with 32 bytes of data:
Requesttimed out.
Requesttimed out.
Requesttimed out.
Requesttimed out.
Pingstatistics for 192.168.3.3:
Packets:Sent = 4, Received = 0, Lost = 4 (100% loss),
PC4 PING PC 6
PC4>ping 192.168.3.3
Pinging192.168.3.3 with 32 bytes of data:
Requesttimed out.
Requesttimed out.
Requesttimed out.
Requesttimed out.
Pingstatistics for 192.168.3.3:
Packets:Sent = 4, Received = 0, Lost = 4 (100% loss),
We get to our goals by all configurations as above:
All the employees can intercommunicate with Internet through one public network
address.
Managers from different departments can communicate with each other while not among
the employees.
We recommend you to use the Layer 3 Switches for Distribution Layer and Core
Switch and then connect to the Internet by routers.
More related:
Cisco Integrated Services Router Generation 2
The available power supplies for the Cisco routers
How to recover password for the Cisco 1900 and 2900 router?
The Difference of The Cisco Catalyst 2900 and Cisco Catalyst 1900
More Cisco products and Reviews you can visit: http://www.3anetwork.com/blog
3Anetwork.com is a world leading Cisco networking products wholesaler, we wholesale
original new Cisco networking equipments, including Cisco Catalyst switches, Cisco
7
routers, Cisco firewalls, Cisco wireless products, Cisco modules and interface cards
products at competitive price and ship to worldwide.
Our website: http://www.3anetwork.com
Telephone: +852-3069-7733
Email: info@3Anetwork.com
Address: 23/F Lucky Plaza, 315-321 Lockhart Road, Wanchai, Hongkong
8

Weitere ähnliche Inhalte

Was ist angesagt?

Cisco CCNA IPV6 Static Configuration
Cisco CCNA  IPV6 Static ConfigurationCisco CCNA  IPV6 Static Configuration
Cisco CCNA IPV6 Static ConfigurationHamed Moghaddam
 
Cisco CCNA Port Security
Cisco CCNA Port SecurityCisco CCNA Port Security
Cisco CCNA Port SecurityHamed Moghaddam
 
Cisco CCNA- NAT Configuration
Cisco CCNA- NAT ConfigurationCisco CCNA- NAT Configuration
Cisco CCNA- NAT ConfigurationHamed Moghaddam
 
Cisco commands List for Beginners (CCNA, CCNP)
Cisco commands List for Beginners (CCNA, CCNP)Cisco commands List for Beginners (CCNA, CCNP)
Cisco commands List for Beginners (CCNA, CCNP)DH Da Lat
 
Cisco CCNA-CCNP IP SLA Configuration
Cisco CCNA-CCNP IP SLA ConfigurationCisco CCNA-CCNP IP SLA Configuration
Cisco CCNA-CCNP IP SLA ConfigurationHamed Moghaddam
 
Ccna Commands In 10 Minutes
Ccna Commands In 10 MinutesCcna Commands In 10 Minutes
Ccna Commands In 10 MinutesCCNAResources
 
How to create and delete vlan on cisco catalyst switch
How to create and delete vlan on cisco catalyst switchHow to create and delete vlan on cisco catalyst switch
How to create and delete vlan on cisco catalyst switchIT Tech
 
Juniper JNCIA – Juniper RIP Route Configuration
Juniper JNCIA – Juniper RIP Route ConfigurationJuniper JNCIA – Juniper RIP Route Configuration
Juniper JNCIA – Juniper RIP Route ConfigurationHamed Moghaddam
 
Service Provider Networks and Frame Relay
Service Provider Networks and Frame RelayService Provider Networks and Frame Relay
Service Provider Networks and Frame RelayTharindu Sankalpa
 
Cisco CCNA GRE Tunnel Configuration
Cisco CCNA GRE Tunnel ConfigurationCisco CCNA GRE Tunnel Configuration
Cisco CCNA GRE Tunnel ConfigurationHamed Moghaddam
 
CCNA - Routing & Switching Commands
CCNA - Routing & Switching CommandsCCNA - Routing & Switching Commands
CCNA - Routing & Switching CommandsEng. Emad Al-Atoum
 
Integrated Service Digital Network
Integrated Service Digital NetworkIntegrated Service Digital Network
Integrated Service Digital NetworkKishore Kumar
 
Cisco CCNA- How to Configure Multi-Layer Switch
Cisco CCNA- How to Configure Multi-Layer SwitchCisco CCNA- How to Configure Multi-Layer Switch
Cisco CCNA- How to Configure Multi-Layer SwitchHamed Moghaddam
 
Cisco CCNA CCNP VACL Configuration
Cisco CCNA CCNP VACL ConfigurationCisco CCNA CCNP VACL Configuration
Cisco CCNA CCNP VACL ConfigurationHamed Moghaddam
 

Was ist angesagt? (20)

Cisco CCNA IPV6 Static Configuration
Cisco CCNA  IPV6 Static ConfigurationCisco CCNA  IPV6 Static Configuration
Cisco CCNA IPV6 Static Configuration
 
Basic Configurations on Router
Basic Configurations on RouterBasic Configurations on Router
Basic Configurations on Router
 
Cisco CCNA Port Security
Cisco CCNA Port SecurityCisco CCNA Port Security
Cisco CCNA Port Security
 
Cisco CCNA- NAT Configuration
Cisco CCNA- NAT ConfigurationCisco CCNA- NAT Configuration
Cisco CCNA- NAT Configuration
 
Router commands
Router commandsRouter commands
Router commands
 
Router commands
Router commandsRouter commands
Router commands
 
Cisco commands List for Beginners (CCNA, CCNP)
Cisco commands List for Beginners (CCNA, CCNP)Cisco commands List for Beginners (CCNA, CCNP)
Cisco commands List for Beginners (CCNA, CCNP)
 
Cisco Commands
Cisco CommandsCisco Commands
Cisco Commands
 
Cisco CCNA-CCNP IP SLA Configuration
Cisco CCNA-CCNP IP SLA ConfigurationCisco CCNA-CCNP IP SLA Configuration
Cisco CCNA-CCNP IP SLA Configuration
 
Ccna command
Ccna commandCcna command
Ccna command
 
Ccna Commands In 10 Minutes
Ccna Commands In 10 MinutesCcna Commands In 10 Minutes
Ccna Commands In 10 Minutes
 
How to create and delete vlan on cisco catalyst switch
How to create and delete vlan on cisco catalyst switchHow to create and delete vlan on cisco catalyst switch
How to create and delete vlan on cisco catalyst switch
 
Juniper JNCIA – Juniper RIP Route Configuration
Juniper JNCIA – Juniper RIP Route ConfigurationJuniper JNCIA – Juniper RIP Route Configuration
Juniper JNCIA – Juniper RIP Route Configuration
 
Service Provider Networks and Frame Relay
Service Provider Networks and Frame RelayService Provider Networks and Frame Relay
Service Provider Networks and Frame Relay
 
Cisco CCNA GRE Tunnel Configuration
Cisco CCNA GRE Tunnel ConfigurationCisco CCNA GRE Tunnel Configuration
Cisco CCNA GRE Tunnel Configuration
 
CCNA - Routing & Switching Commands
CCNA - Routing & Switching CommandsCCNA - Routing & Switching Commands
CCNA - Routing & Switching Commands
 
Integrated Service Digital Network
Integrated Service Digital NetworkIntegrated Service Digital Network
Integrated Service Digital Network
 
Cisco CCNA- How to Configure Multi-Layer Switch
Cisco CCNA- How to Configure Multi-Layer SwitchCisco CCNA- How to Configure Multi-Layer Switch
Cisco CCNA- How to Configure Multi-Layer Switch
 
ccna cheat_sheet
ccna cheat_sheetccna cheat_sheet
ccna cheat_sheet
 
Cisco CCNA CCNP VACL Configuration
Cisco CCNA CCNP VACL ConfigurationCisco CCNA CCNP VACL Configuration
Cisco CCNA CCNP VACL Configuration
 

Andere mochten auch

Theory Review II (pps)
Theory Review II (pps)Theory Review II (pps)
Theory Review II (pps)mladenr
 
Theory Review I (pps)
Theory Review I (pps)Theory Review I (pps)
Theory Review I (pps)mladenr
 
BAIT2164 Tutorial 4
BAIT2164 Tutorial 4BAIT2164 Tutorial 4
BAIT2164 Tutorial 4limsh
 
BAIT2164 Topics for Revision
BAIT2164 Topics for RevisionBAIT2164 Topics for Revision
BAIT2164 Topics for Revisionlimsh
 
Chapter 05 - Inter-VLAN Routing
Chapter 05 - Inter-VLAN RoutingChapter 05 - Inter-VLAN Routing
Chapter 05 - Inter-VLAN RoutingYaser Rahmati
 
Inter-VLAN Routing
Inter-VLAN RoutingInter-VLAN Routing
Inter-VLAN Routingrmosate
 

Andere mochten auch (6)

Theory Review II (pps)
Theory Review II (pps)Theory Review II (pps)
Theory Review II (pps)
 
Theory Review I (pps)
Theory Review I (pps)Theory Review I (pps)
Theory Review I (pps)
 
BAIT2164 Tutorial 4
BAIT2164 Tutorial 4BAIT2164 Tutorial 4
BAIT2164 Tutorial 4
 
BAIT2164 Topics for Revision
BAIT2164 Topics for RevisionBAIT2164 Topics for Revision
BAIT2164 Topics for Revision
 
Chapter 05 - Inter-VLAN Routing
Chapter 05 - Inter-VLAN RoutingChapter 05 - Inter-VLAN Routing
Chapter 05 - Inter-VLAN Routing
 
Inter-VLAN Routing
Inter-VLAN RoutingInter-VLAN Routing
Inter-VLAN Routing
 

Ähnlich wie Enterprise Network Manager: the Router-On-A-stick

Packettracersimulationlabl3routing 130306235157-phpapp02
Packettracersimulationlabl3routing 130306235157-phpapp02Packettracersimulationlabl3routing 130306235157-phpapp02
Packettracersimulationlabl3routing 130306235157-phpapp02A.S.M Shmimul Islam.
 
cisco ccna cheat_sheet
cisco ccna cheat_sheetcisco ccna cheat_sheet
cisco ccna cheat_sheetGuntaka Reddy
 
Ncat ccna cheat sheet
Ncat ccna cheat sheetNcat ccna cheat sheet
Ncat ccna cheat sheetEZREIG OMAR
 
VoiceBootcamp Ccnp collaboration lab guide v1.0 sample
VoiceBootcamp Ccnp collaboration lab guide v1.0 sampleVoiceBootcamp Ccnp collaboration lab guide v1.0 sample
VoiceBootcamp Ccnp collaboration lab guide v1.0 sampleFaisal Khan
 
Network Design on cisco packet tracer 6.0
Network Design on cisco packet tracer 6.0Network Design on cisco packet tracer 6.0
Network Design on cisco packet tracer 6.0Saurav Pandey
 
ccna project on topic company infrastructure
ccna project on topic company infrastructureccna project on topic company infrastructure
ccna project on topic company infrastructurePrince Gautam
 
Detailed explanation of Basic router configuration
Detailed explanation of Basic router configurationDetailed explanation of Basic router configuration
Detailed explanation of Basic router configurationsamreenghauri786
 
All contents are Copyright © 1992–2012 Cisco Systems, Inc. A.docx
All contents are Copyright © 1992–2012 Cisco Systems, Inc. A.docxAll contents are Copyright © 1992–2012 Cisco Systems, Inc. A.docx
All contents are Copyright © 1992–2012 Cisco Systems, Inc. A.docxgalerussel59292
 
ccna summer training ppt ( Cisco certified network analysis) ppt. by Traun k...
ccna summer training ppt ( Cisco certified network analysis) ppt.  by Traun k...ccna summer training ppt ( Cisco certified network analysis) ppt.  by Traun k...
ccna summer training ppt ( Cisco certified network analysis) ppt. by Traun k...Tarun Khaneja
 
Cisco CCNA IP SLA with tracking configuration
Cisco CCNA IP SLA  with tracking  configurationCisco CCNA IP SLA  with tracking  configuration
Cisco CCNA IP SLA with tracking configurationHamed Moghaddam
 
Hướng dẫn cài đặt switch planet layer 3
Hướng dẫn cài đặt switch planet layer 3Hướng dẫn cài đặt switch planet layer 3
Hướng dẫn cài đặt switch planet layer 33c telecom
 
In depth understanding network security
In depth understanding network securityIn depth understanding network security
In depth understanding network securityThanawan Tuamyim
 
Ccna 4 final lab switchi
Ccna 4 final lab switchiCcna 4 final lab switchi
Ccna 4 final lab switchiLeandro Uglar
 
Introduction 140318015826-phpapp01
Introduction 140318015826-phpapp01Introduction 140318015826-phpapp01
Introduction 140318015826-phpapp01amit singh
 
Ccna2 mod3-configuring a-router
Ccna2 mod3-configuring a-routerCcna2 mod3-configuring a-router
Ccna2 mod3-configuring a-router97148881557
 

Ähnlich wie Enterprise Network Manager: the Router-On-A-stick (20)

Packettracersimulationlabl3routing 130306235157-phpapp02
Packettracersimulationlabl3routing 130306235157-phpapp02Packettracersimulationlabl3routing 130306235157-phpapp02
Packettracersimulationlabl3routing 130306235157-phpapp02
 
Nat report2
Nat report2Nat report2
Nat report2
 
cisco ccna cheat_sheet
cisco ccna cheat_sheetcisco ccna cheat_sheet
cisco ccna cheat_sheet
 
Ncat ccna cheat sheet
Ncat ccna cheat sheetNcat ccna cheat sheet
Ncat ccna cheat sheet
 
Labmannual
LabmannualLabmannual
Labmannual
 
PROYECTO VLANS
PROYECTO VLANSPROYECTO VLANS
PROYECTO VLANS
 
Networking Lab Report
Networking Lab ReportNetworking Lab Report
Networking Lab Report
 
VoiceBootcamp Ccnp collaboration lab guide v1.0 sample
VoiceBootcamp Ccnp collaboration lab guide v1.0 sampleVoiceBootcamp Ccnp collaboration lab guide v1.0 sample
VoiceBootcamp Ccnp collaboration lab guide v1.0 sample
 
Network Design on cisco packet tracer 6.0
Network Design on cisco packet tracer 6.0Network Design on cisco packet tracer 6.0
Network Design on cisco packet tracer 6.0
 
ccna project on topic company infrastructure
ccna project on topic company infrastructureccna project on topic company infrastructure
ccna project on topic company infrastructure
 
Detailed explanation of Basic router configuration
Detailed explanation of Basic router configurationDetailed explanation of Basic router configuration
Detailed explanation of Basic router configuration
 
All contents are Copyright © 1992–2012 Cisco Systems, Inc. A.docx
All contents are Copyright © 1992–2012 Cisco Systems, Inc. A.docxAll contents are Copyright © 1992–2012 Cisco Systems, Inc. A.docx
All contents are Copyright © 1992–2012 Cisco Systems, Inc. A.docx
 
ccna summer training ppt ( Cisco certified network analysis) ppt. by Traun k...
ccna summer training ppt ( Cisco certified network analysis) ppt.  by Traun k...ccna summer training ppt ( Cisco certified network analysis) ppt.  by Traun k...
ccna summer training ppt ( Cisco certified network analysis) ppt. by Traun k...
 
Cisco CCNA IP SLA with tracking configuration
Cisco CCNA IP SLA  with tracking  configurationCisco CCNA IP SLA  with tracking  configuration
Cisco CCNA IP SLA with tracking configuration
 
Hướng dẫn cài đặt switch planet layer 3
Hướng dẫn cài đặt switch planet layer 3Hướng dẫn cài đặt switch planet layer 3
Hướng dẫn cài đặt switch planet layer 3
 
In depth understanding network security
In depth understanding network securityIn depth understanding network security
In depth understanding network security
 
Ccna command
Ccna commandCcna command
Ccna command
 
Ccna 4 final lab switchi
Ccna 4 final lab switchiCcna 4 final lab switchi
Ccna 4 final lab switchi
 
Introduction 140318015826-phpapp01
Introduction 140318015826-phpapp01Introduction 140318015826-phpapp01
Introduction 140318015826-phpapp01
 
Ccna2 mod3-configuring a-router
Ccna2 mod3-configuring a-routerCcna2 mod3-configuring a-router
Ccna2 mod3-configuring a-router
 

Mehr von 3Anetwork com

Cisco 3900 and cisco 2900 series routers
Cisco 3900 and cisco 2900 series routersCisco 3900 and cisco 2900 series routers
Cisco 3900 and cisco 2900 series routers3Anetwork com
 
Cisco catalyst 2960 x series
Cisco catalyst 2960 x seriesCisco catalyst 2960 x series
Cisco catalyst 2960 x series3Anetwork com
 
Cisco catalyst 3750 x series switches
Cisco catalyst 3750 x series switchesCisco catalyst 3750 x series switches
Cisco catalyst 3750 x series switches3Anetwork com
 
Cisco switches for small business
Cisco switches for small businessCisco switches for small business
Cisco switches for small business3Anetwork com
 
How to recover the password for cisco 2900 integrated services router
How to recover the password for cisco 2900 integrated services routerHow to recover the password for cisco 2900 integrated services router
How to recover the password for cisco 2900 integrated services router3Anetwork com
 
Cisco 4 and 8-port gigabit ethernet ehwi cs
Cisco 4  and 8-port gigabit ethernet ehwi csCisco 4  and 8-port gigabit ethernet ehwi cs
Cisco 4 and 8-port gigabit ethernet ehwi cs3Anetwork com
 
Configuring the cisco switch with the cli based setup program
Configuring the cisco switch with the cli based setup programConfiguring the cisco switch with the cli based setup program
Configuring the cisco switch with the cli based setup program3Anetwork com
 
Cisco 2960 basic configuration – vlan configuration
Cisco 2960 basic configuration – vlan configurationCisco 2960 basic configuration – vlan configuration
Cisco 2960 basic configuration – vlan configuration3Anetwork com
 
Configuring a Cisco Router as a PPPoE Client for DSL Connectivity
 Configuring a Cisco Router as a PPPoE Client for DSL Connectivity Configuring a Cisco Router as a PPPoE Client for DSL Connectivity
Configuring a Cisco Router as a PPPoE Client for DSL Connectivity3Anetwork com
 
Cisco catalyst 3850 series switches datasheet
Cisco catalyst 3850 series switches datasheetCisco catalyst 3850 series switches datasheet
Cisco catalyst 3850 series switches datasheet3Anetwork com
 
Cisco catalyst 2960 series switches overview
Cisco catalyst 2960 series switches overviewCisco catalyst 2960 series switches overview
Cisco catalyst 2960 series switches overview3Anetwork com
 
Cisco Catalyst 2960-X Datasheet
Cisco Catalyst 2960-X DatasheetCisco Catalyst 2960-X Datasheet
Cisco Catalyst 2960-X Datasheet3Anetwork com
 
How to configure a catalyst 3750 x
How to configure a catalyst 3750 xHow to configure a catalyst 3750 x
How to configure a catalyst 3750 x3Anetwork com
 
Hubs vs switches vs routers
Hubs vs switches vs routersHubs vs switches vs routers
Hubs vs switches vs routers3Anetwork com
 
Installing and removing sfp and sfp+ transceiver modules
Installing and removing sfp and sfp+ transceiver modulesInstalling and removing sfp and sfp+ transceiver modules
Installing and removing sfp and sfp+ transceiver modules3Anetwork com
 
Dmvpn with configuration example
Dmvpn with configuration exampleDmvpn with configuration example
Dmvpn with configuration example3Anetwork com
 
Cisco unified access from vision to reality
Cisco unified access from vision to realityCisco unified access from vision to reality
Cisco unified access from vision to reality3Anetwork com
 
How to use time domain reflectometer (tdr)
How to use time domain reflectometer (tdr)How to use time domain reflectometer (tdr)
How to use time domain reflectometer (tdr)3Anetwork com
 
Cisco switch commands cheat sheet
Cisco switch commands cheat sheetCisco switch commands cheat sheet
Cisco switch commands cheat sheet3Anetwork com
 

Mehr von 3Anetwork com (20)

Cisco sfp modules
Cisco sfp modulesCisco sfp modules
Cisco sfp modules
 
Cisco 3900 and cisco 2900 series routers
Cisco 3900 and cisco 2900 series routersCisco 3900 and cisco 2900 series routers
Cisco 3900 and cisco 2900 series routers
 
Cisco catalyst 2960 x series
Cisco catalyst 2960 x seriesCisco catalyst 2960 x series
Cisco catalyst 2960 x series
 
Cisco catalyst 3750 x series switches
Cisco catalyst 3750 x series switchesCisco catalyst 3750 x series switches
Cisco catalyst 3750 x series switches
 
Cisco switches for small business
Cisco switches for small businessCisco switches for small business
Cisco switches for small business
 
How to recover the password for cisco 2900 integrated services router
How to recover the password for cisco 2900 integrated services routerHow to recover the password for cisco 2900 integrated services router
How to recover the password for cisco 2900 integrated services router
 
Cisco 4 and 8-port gigabit ethernet ehwi cs
Cisco 4  and 8-port gigabit ethernet ehwi csCisco 4  and 8-port gigabit ethernet ehwi cs
Cisco 4 and 8-port gigabit ethernet ehwi cs
 
Configuring the cisco switch with the cli based setup program
Configuring the cisco switch with the cli based setup programConfiguring the cisco switch with the cli based setup program
Configuring the cisco switch with the cli based setup program
 
Cisco 2960 basic configuration – vlan configuration
Cisco 2960 basic configuration – vlan configurationCisco 2960 basic configuration – vlan configuration
Cisco 2960 basic configuration – vlan configuration
 
Configuring a Cisco Router as a PPPoE Client for DSL Connectivity
 Configuring a Cisco Router as a PPPoE Client for DSL Connectivity Configuring a Cisco Router as a PPPoE Client for DSL Connectivity
Configuring a Cisco Router as a PPPoE Client for DSL Connectivity
 
Cisco catalyst 3850 series switches datasheet
Cisco catalyst 3850 series switches datasheetCisco catalyst 3850 series switches datasheet
Cisco catalyst 3850 series switches datasheet
 
Cisco catalyst 2960 series switches overview
Cisco catalyst 2960 series switches overviewCisco catalyst 2960 series switches overview
Cisco catalyst 2960 series switches overview
 
Cisco Catalyst 2960-X Datasheet
Cisco Catalyst 2960-X DatasheetCisco Catalyst 2960-X Datasheet
Cisco Catalyst 2960-X Datasheet
 
How to configure a catalyst 3750 x
How to configure a catalyst 3750 xHow to configure a catalyst 3750 x
How to configure a catalyst 3750 x
 
Hubs vs switches vs routers
Hubs vs switches vs routersHubs vs switches vs routers
Hubs vs switches vs routers
 
Installing and removing sfp and sfp+ transceiver modules
Installing and removing sfp and sfp+ transceiver modulesInstalling and removing sfp and sfp+ transceiver modules
Installing and removing sfp and sfp+ transceiver modules
 
Dmvpn with configuration example
Dmvpn with configuration exampleDmvpn with configuration example
Dmvpn with configuration example
 
Cisco unified access from vision to reality
Cisco unified access from vision to realityCisco unified access from vision to reality
Cisco unified access from vision to reality
 
How to use time domain reflectometer (tdr)
How to use time domain reflectometer (tdr)How to use time domain reflectometer (tdr)
How to use time domain reflectometer (tdr)
 
Cisco switch commands cheat sheet
Cisco switch commands cheat sheetCisco switch commands cheat sheet
Cisco switch commands cheat sheet
 

Kürzlich hochgeladen

The Role of FIDO in a Cyber Secure Netherlands: FIDO Paris Seminar.pptx
The Role of FIDO in a Cyber Secure Netherlands: FIDO Paris Seminar.pptxThe Role of FIDO in a Cyber Secure Netherlands: FIDO Paris Seminar.pptx
The Role of FIDO in a Cyber Secure Netherlands: FIDO Paris Seminar.pptxLoriGlavin3
 
"ML in Production",Oleksandr Bagan
"ML in Production",Oleksandr Bagan"ML in Production",Oleksandr Bagan
"ML in Production",Oleksandr BaganFwdays
 
unit 4 immunoblotting technique complete.pptx
unit 4 immunoblotting technique complete.pptxunit 4 immunoblotting technique complete.pptx
unit 4 immunoblotting technique complete.pptxBkGupta21
 
Scanning the Internet for External Cloud Exposures via SSL Certs
Scanning the Internet for External Cloud Exposures via SSL CertsScanning the Internet for External Cloud Exposures via SSL Certs
Scanning the Internet for External Cloud Exposures via SSL CertsRizwan Syed
 
"Debugging python applications inside k8s environment", Andrii Soldatenko
"Debugging python applications inside k8s environment", Andrii Soldatenko"Debugging python applications inside k8s environment", Andrii Soldatenko
"Debugging python applications inside k8s environment", Andrii SoldatenkoFwdays
 
Take control of your SAP testing with UiPath Test Suite
Take control of your SAP testing with UiPath Test SuiteTake control of your SAP testing with UiPath Test Suite
Take control of your SAP testing with UiPath Test SuiteDianaGray10
 
Transcript: New from BookNet Canada for 2024: Loan Stars - Tech Forum 2024
Transcript: New from BookNet Canada for 2024: Loan Stars - Tech Forum 2024Transcript: New from BookNet Canada for 2024: Loan Stars - Tech Forum 2024
Transcript: New from BookNet Canada for 2024: Loan Stars - Tech Forum 2024BookNet Canada
 
SALESFORCE EDUCATION CLOUD | FEXLE SERVICES
SALESFORCE EDUCATION CLOUD | FEXLE SERVICESSALESFORCE EDUCATION CLOUD | FEXLE SERVICES
SALESFORCE EDUCATION CLOUD | FEXLE SERVICESmohitsingh558521
 
Transcript: New from BookNet Canada for 2024: BNC CataList - Tech Forum 2024
Transcript: New from BookNet Canada for 2024: BNC CataList - Tech Forum 2024Transcript: New from BookNet Canada for 2024: BNC CataList - Tech Forum 2024
Transcript: New from BookNet Canada for 2024: BNC CataList - Tech Forum 2024BookNet Canada
 
Advanced Computer Architecture – An Introduction
Advanced Computer Architecture – An IntroductionAdvanced Computer Architecture – An Introduction
Advanced Computer Architecture – An IntroductionDilum Bandara
 
Use of FIDO in the Payments and Identity Landscape: FIDO Paris Seminar.pptx
Use of FIDO in the Payments and Identity Landscape: FIDO Paris Seminar.pptxUse of FIDO in the Payments and Identity Landscape: FIDO Paris Seminar.pptx
Use of FIDO in the Payments and Identity Landscape: FIDO Paris Seminar.pptxLoriGlavin3
 
WordPress Websites for Engineers: Elevate Your Brand
WordPress Websites for Engineers: Elevate Your BrandWordPress Websites for Engineers: Elevate Your Brand
WordPress Websites for Engineers: Elevate Your Brandgvaughan
 
What's New in Teams Calling, Meetings and Devices March 2024
What's New in Teams Calling, Meetings and Devices March 2024What's New in Teams Calling, Meetings and Devices March 2024
What's New in Teams Calling, Meetings and Devices March 2024Stephanie Beckett
 
Unraveling Multimodality with Large Language Models.pdf
Unraveling Multimodality with Large Language Models.pdfUnraveling Multimodality with Large Language Models.pdf
Unraveling Multimodality with Large Language Models.pdfAlex Barbosa Coqueiro
 
Are Multi-Cloud and Serverless Good or Bad?
Are Multi-Cloud and Serverless Good or Bad?Are Multi-Cloud and Serverless Good or Bad?
Are Multi-Cloud and Serverless Good or Bad?Mattias Andersson
 
The Fit for Passkeys for Employee and Consumer Sign-ins: FIDO Paris Seminar.pptx
The Fit for Passkeys for Employee and Consumer Sign-ins: FIDO Paris Seminar.pptxThe Fit for Passkeys for Employee and Consumer Sign-ins: FIDO Paris Seminar.pptx
The Fit for Passkeys for Employee and Consumer Sign-ins: FIDO Paris Seminar.pptxLoriGlavin3
 
Moving Beyond Passwords: FIDO Paris Seminar.pdf
Moving Beyond Passwords: FIDO Paris Seminar.pdfMoving Beyond Passwords: FIDO Paris Seminar.pdf
Moving Beyond Passwords: FIDO Paris Seminar.pdfLoriGlavin3
 
Merck Moving Beyond Passwords: FIDO Paris Seminar.pptx
Merck Moving Beyond Passwords: FIDO Paris Seminar.pptxMerck Moving Beyond Passwords: FIDO Paris Seminar.pptx
Merck Moving Beyond Passwords: FIDO Paris Seminar.pptxLoriGlavin3
 
Developer Data Modeling Mistakes: From Postgres to NoSQL
Developer Data Modeling Mistakes: From Postgres to NoSQLDeveloper Data Modeling Mistakes: From Postgres to NoSQL
Developer Data Modeling Mistakes: From Postgres to NoSQLScyllaDB
 
Gen AI in Business - Global Trends Report 2024.pdf
Gen AI in Business - Global Trends Report 2024.pdfGen AI in Business - Global Trends Report 2024.pdf
Gen AI in Business - Global Trends Report 2024.pdfAddepto
 

Kürzlich hochgeladen (20)

The Role of FIDO in a Cyber Secure Netherlands: FIDO Paris Seminar.pptx
The Role of FIDO in a Cyber Secure Netherlands: FIDO Paris Seminar.pptxThe Role of FIDO in a Cyber Secure Netherlands: FIDO Paris Seminar.pptx
The Role of FIDO in a Cyber Secure Netherlands: FIDO Paris Seminar.pptx
 
"ML in Production",Oleksandr Bagan
"ML in Production",Oleksandr Bagan"ML in Production",Oleksandr Bagan
"ML in Production",Oleksandr Bagan
 
unit 4 immunoblotting technique complete.pptx
unit 4 immunoblotting technique complete.pptxunit 4 immunoblotting technique complete.pptx
unit 4 immunoblotting technique complete.pptx
 
Scanning the Internet for External Cloud Exposures via SSL Certs
Scanning the Internet for External Cloud Exposures via SSL CertsScanning the Internet for External Cloud Exposures via SSL Certs
Scanning the Internet for External Cloud Exposures via SSL Certs
 
"Debugging python applications inside k8s environment", Andrii Soldatenko
"Debugging python applications inside k8s environment", Andrii Soldatenko"Debugging python applications inside k8s environment", Andrii Soldatenko
"Debugging python applications inside k8s environment", Andrii Soldatenko
 
Take control of your SAP testing with UiPath Test Suite
Take control of your SAP testing with UiPath Test SuiteTake control of your SAP testing with UiPath Test Suite
Take control of your SAP testing with UiPath Test Suite
 
Transcript: New from BookNet Canada for 2024: Loan Stars - Tech Forum 2024
Transcript: New from BookNet Canada for 2024: Loan Stars - Tech Forum 2024Transcript: New from BookNet Canada for 2024: Loan Stars - Tech Forum 2024
Transcript: New from BookNet Canada for 2024: Loan Stars - Tech Forum 2024
 
SALESFORCE EDUCATION CLOUD | FEXLE SERVICES
SALESFORCE EDUCATION CLOUD | FEXLE SERVICESSALESFORCE EDUCATION CLOUD | FEXLE SERVICES
SALESFORCE EDUCATION CLOUD | FEXLE SERVICES
 
Transcript: New from BookNet Canada for 2024: BNC CataList - Tech Forum 2024
Transcript: New from BookNet Canada for 2024: BNC CataList - Tech Forum 2024Transcript: New from BookNet Canada for 2024: BNC CataList - Tech Forum 2024
Transcript: New from BookNet Canada for 2024: BNC CataList - Tech Forum 2024
 
Advanced Computer Architecture – An Introduction
Advanced Computer Architecture – An IntroductionAdvanced Computer Architecture – An Introduction
Advanced Computer Architecture – An Introduction
 
Use of FIDO in the Payments and Identity Landscape: FIDO Paris Seminar.pptx
Use of FIDO in the Payments and Identity Landscape: FIDO Paris Seminar.pptxUse of FIDO in the Payments and Identity Landscape: FIDO Paris Seminar.pptx
Use of FIDO in the Payments and Identity Landscape: FIDO Paris Seminar.pptx
 
WordPress Websites for Engineers: Elevate Your Brand
WordPress Websites for Engineers: Elevate Your BrandWordPress Websites for Engineers: Elevate Your Brand
WordPress Websites for Engineers: Elevate Your Brand
 
What's New in Teams Calling, Meetings and Devices March 2024
What's New in Teams Calling, Meetings and Devices March 2024What's New in Teams Calling, Meetings and Devices March 2024
What's New in Teams Calling, Meetings and Devices March 2024
 
Unraveling Multimodality with Large Language Models.pdf
Unraveling Multimodality with Large Language Models.pdfUnraveling Multimodality with Large Language Models.pdf
Unraveling Multimodality with Large Language Models.pdf
 
Are Multi-Cloud and Serverless Good or Bad?
Are Multi-Cloud and Serverless Good or Bad?Are Multi-Cloud and Serverless Good or Bad?
Are Multi-Cloud and Serverless Good or Bad?
 
The Fit for Passkeys for Employee and Consumer Sign-ins: FIDO Paris Seminar.pptx
The Fit for Passkeys for Employee and Consumer Sign-ins: FIDO Paris Seminar.pptxThe Fit for Passkeys for Employee and Consumer Sign-ins: FIDO Paris Seminar.pptx
The Fit for Passkeys for Employee and Consumer Sign-ins: FIDO Paris Seminar.pptx
 
Moving Beyond Passwords: FIDO Paris Seminar.pdf
Moving Beyond Passwords: FIDO Paris Seminar.pdfMoving Beyond Passwords: FIDO Paris Seminar.pdf
Moving Beyond Passwords: FIDO Paris Seminar.pdf
 
Merck Moving Beyond Passwords: FIDO Paris Seminar.pptx
Merck Moving Beyond Passwords: FIDO Paris Seminar.pptxMerck Moving Beyond Passwords: FIDO Paris Seminar.pptx
Merck Moving Beyond Passwords: FIDO Paris Seminar.pptx
 
Developer Data Modeling Mistakes: From Postgres to NoSQL
Developer Data Modeling Mistakes: From Postgres to NoSQLDeveloper Data Modeling Mistakes: From Postgres to NoSQL
Developer Data Modeling Mistakes: From Postgres to NoSQL
 
Gen AI in Business - Global Trends Report 2024.pdf
Gen AI in Business - Global Trends Report 2024.pdfGen AI in Business - Global Trends Report 2024.pdf
Gen AI in Business - Global Trends Report 2024.pdf
 

Enterprise Network Manager: the Router-On-A-stick

  • 1. Enterprise network manager: The router-on-a-stick At present, a lot of small and medium-sized enterprises’ network are formed by multiple L2 switches + a router(you can use any one of Cisco router), and then connect the router into the internet. So far, this is a common way to use router-on- a-stick to manage the enterprise network. In order to realize the communications between all the employees and the Internet in the enterprises, it is unrealistic for a person using a public network address. Generally, the enterprise has one or several public addresses while has dozens or even hundreds of employees. How to communicate all these public addresses using employees with the Internet? NAT technology definitely! In general, there are lots of departments in a enterprise, such as finance department, technology department, engineering department and so on, each department doing his coherent responsibility. How to clearly distinguish these departments to facilitate the management? VLAN technology absolutely! In order to the convenient work and enhancement of the working efficiency, managers from different departments have to communicate with each other while the employees’ are forbidden. How to do ? ACL technology without any doubt! Now, let’s learn how to use the NAT+VLAN+ACL technology to manage the enterprises’ network. NTE ( Network Testing Environment) is as below: Introduction: The only public network address: 172.16.1.1/24 Three departments of the enterprise: 1
  • 2. Finance department (PC1 for manager) Technology department (PC3 for manager) Engineering department (PC5 for manager) IP: PC1:192.168.1.2/24PC2:192.168.1.3/24 PC3:192.168.2.2/24PC4:192.168.2.3/24 PC5:192.168.3.2/24PC6:192.168.3.3/24 Test for purpose: By NAT configuration, all the computers will be connected to communicate with Internet through the only public network address. To divide various departments through VLAN configuration and to realize the intercommunications among managers from different departments through ACL configuration while not among the employees. Ok, let’s down to work as we’ve known the intention. Firstly, basic configuration on R1 and R2 (dot1Q is needed to encapsulate for sub- interface configuration as we have to use routing process among VLANs.) R1 Router>en Router#conft Enterconfiguration commands, one per line. End withCNTL/Z. Router(config)#host r1 r1(config)#int s0/0 r1(config-if)#ip addr 172.16.1.1 255.255.255.0 r1(config-if)#no shut %LINK-5-CHANGED: Interface Serial0/0, changed state to up r1(config-if)#clock rate 64000 %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changedstate to u r1(config-if)#exit r1(config)#int f0/0 r1(config-if)#no ip addr r1(config-if)#no shut r1(config-if)#exit r1(config)#intf0/0.1 (sub-interface configuration) r1(config-subif)#encapsulation dot1Q2 (dot1Q is needed to encapsulate for sub-interface configuration) r1(config-subif)#ip addr 192.168.1.1 255.255.255.0 r1(config-subif)#no shut r1(config-subif)#exit 2
  • 3. r1(config)#intf0/0.2 (sub-interface configuration) r1(config-subif)#encapsulation dot1Q3 (dot1Q is needed to encapsulate for sub-interface configuration) r1(config-subif)#ip addr 192.168.2.1 255.255.255.0 r1(config-subif)#no shut r1(config-subif)#exit r1(config)#intf0/0.3 (sub-interface configuration) r1(config-subif)#encapsulation dot1Q4 (dot1Q is needed to encapsulate for sub-interface configuration) r1(config-subif)#ip addr 192.168.3.1 255.255.255.0 We just need the IP configuration on S0/0 port of R2 cause we take R2 as public network. R2 Router>en Router#conft Enterconfiguration commands, one per line. End withCNTL/Z. Router(config)#host r2 r2(config)#int s0/0 r2(config-if)#ip addr 172.16.1.2 255.255.255.0 r2(config-if)#no shut Secondly, to have all the employees passed through the only public network—IP 172.16.1.1/24 for Internetcommunications. R1 r1(config)#ip nat pool internet 172.16.1.1 172.16.1.1 netmask255.255.255.0 r1(config)#access-list 10 permit 192.168.0.00.0.255.255 r1(config)#ip nat inside source list 10 pool internet overload r1(config)#int s0/0 r1(config-if)#ip nat outside r1(config-if)#exit r1(config)#int f0/0 r1(config-if)#ip nat inside To divide various departments through VLAN configuration and to realize the intercommunications among managers from different departments through ACL configuration while not among the employees. Sw Switch>en 3
  • 4. Switch#conft Enterconfiguration commands, one per line. End withCNTL/Z. Switch(config)#int f0/1 Switch(config-if)#switchport modetrunk (Trunk link configuration) %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1,changed state to down %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1,changed state to up Switch(config-if)#exit Switch(config)#vlan2 (VLAN 2 setting up) Switch(config-vlan)#namegongchengbu (Vlan2: Engineering department) Switch(config-vlan)#exit Switch(config)#vlan3 (VLAN 3 setting up) Switch(config-vlan)#namecaiwubu (VLAN3: Finance department) Switch(config-vlan)#exit Switch(config-vlan)#vlan4 (VLAN 4 setting up) Switch(config-vlan)#namejishubu (VLAN4: Technology department) Switch(config-vlan)#exit Switch(config)#int f0/2 Switch(config-if)#switchport access vlan2 (Member adding to VLAN 2 manually) Switch(config-if)#exit Switch(config)#int f0/3 Switch(config-if)#switchport access vlan 2 Switch(config-if)#exit Switch(config)#int f0/4 Switch(config-if)#switchport access vlan3 (Member adding to VLAN 3 manually) Switch(config-if)#exit Switch(config)#int f0/5 Switch(config-if)#switchport access vlan 3 Switch(config-if)#exit Switch(config)#int f0/6 Switch(config-if)#switchport access vlan4 (Member adding to VLAN 4 manually) Switch(config-if)#exit Switch(config)#int f0/7 Switch(config-if)#switchport access vlan 4 Switch(config-if)#exit The definition of ACL (Access Control List): Be careful for ACL definition and you’d better put the most peculiar ACL on the top. Note: The interface binding is needed if the ACL can be applied. R1 r1(config)#access-list 10 permit 192.168.2.2 0.0.0.0 r1(config)#access-list 10 deny 192.168.2.0 0.0.0.255 4
  • 5. r1(config)#access-list 10 permit 192.168.3.2 0.0.0.0 r1(config)#access-list 10 deny 192.168.3.0 0.0.0.255 r1(config)#access-list 10 permit any r1(config)#int f0/0.1 r1(config-subif)#ip access-group 10 out r1(config-subif)#exit r1(config)#access-list 11 permit 192.168.1.2 0.0.0.0 r1(config)#access-list 11 deny 192.168.1.0 0.0.0.255 r1(config)#access-list 11 permit 192.168.3.2 0.0.0.0 r1(config)#access-list 11 deny 192.168.3.0 0.0.0.255 r1(config)#access-list 11 permit any r1(config)#int f0/0.2 r1(config-subif)#ip access-group 11 out r1(config-subif)#exit r1(config)#access-list 12 permit 192.168.1.2 0.0.0.0 r1(config)#access-list 12 deny 192.168.1.0 0.0.0.255 r1(config)#access-list 12 permit 192.168.2.2 0.0.0.0 r1(config)#access-list 12 deny 192.168.2.0 0.0.0.255 r1(config)#access-list 12 permit any r1(config)#int f0/0.3 r1(config-subif)#ip access-group 12 out r1(config-subif)#exit Now, all the employees can intercommunicates after configuration. PC>ping 172.16.1.2 Pinging172.16.1.2 with 32 bytes of data: Replyfrom 172.16.1.2: bytes=32 time=94ms TTL=254 Reply from172.16.1.2: bytes=32 time=94ms TTL=254 Reply from172.16.1.2: bytes=32 time=94ms TTL=254 Reply from172.16.1.2: bytes=32 time=90ms TTL=254 Pingstatistics for 172.16.1.2: Packets: Sent = 4, Received = 4, Lost = 0 (0% loss), Approximateround trip times in milli-seconds: Minimum =90ms, Maximum = 94ms, Average = 93ms The intercommunications among managers from different departments (PC1, PC3 and PC5) have been realized after configuration. PC1>ping 192.168.2.2 Pinging192.168.2.2 with 32 bytes of data: Replyfrom 192.168.2.2: bytes=32 time=125ms TTL=127 Reply from192.168.2.2: bytes=32 time=110ms TTL=127 5
  • 6. Reply from192.168.2.2: bytes=32 time=110ms TTL=127 Reply from192.168.2.2: bytes=32 time=125ms TTL=127 Pingstatistics for 192.168.2.2: Packets: Sent = 4, Received = 4, Lost = 0 (0% loss), Approximateround trip times in milli-seconds: Minimum =110ms, Maximum = 125ms, Average = 117ms PC1 PING PC5 PC1>ping 192.168.3.2 Pinging192.168.3.2 with 32 bytes of data: Replyfrom 192.168.3.2: bytes=32 time=111ms TTL=127 Reply from192.168.3.2: bytes=32 time=120ms TTL=127 Reply from192.168.3.2: bytes=32 time=111ms TTL=127 Reply from192.168.3.2: bytes=32 time=105ms TTL=127 Pingstatistics for 192.168.3.2: Packets: Sent = 4, Received = 4, Lost = 0 (0% loss), Approximateround trip times in milli-seconds: Minimum = 105ms, Maximum = 120ms, Average = 111ms PC3 PING PC5 PC3>ping 192.168.3.2 Pinging192.168.3.2 with 32 bytes of data: Replyfrom 192.168.3.2: bytes=32 time=125ms TTL=127 Reply from192.168.3.2: bytes=32 time=125ms TTL=127 Reply from192.168.3.2: bytes=32 time=109ms TTL=127 Reply from192.168.3.2: bytes=32 time=94ms TTL=127 Pingstatistics for 192.168.3.2: Packets: Sent = 4, Received = 4, Lost = 0 (0% loss), Approximateround trip times in milli-seconds: Minimum = 94ms, Maximum = 125ms, Average = 113ms There is no intercommunications among employees.(PC2,PC4 and PC6) PC2 PING PC4 PC2>ping 192.168.2.3 Pinging192.168.2.3 with 32 bytes of data: Requesttimed out. Requesttimed out. Requesttimed out. Requesttimed out. Pingstatistics for 192.168.2.3: Packets: Sent = 4, Received = 0, Lost = 4 (100% loss), PC2 PING PC6 6
  • 7. PC2>ping 192.168.3.3 Pinging192.168.3.3 with 32 bytes of data: Requesttimed out. Requesttimed out. Requesttimed out. Requesttimed out. Pingstatistics for 192.168.3.3: Packets:Sent = 4, Received = 0, Lost = 4 (100% loss), PC4 PING PC 6 PC4>ping 192.168.3.3 Pinging192.168.3.3 with 32 bytes of data: Requesttimed out. Requesttimed out. Requesttimed out. Requesttimed out. Pingstatistics for 192.168.3.3: Packets:Sent = 4, Received = 0, Lost = 4 (100% loss), We get to our goals by all configurations as above: All the employees can intercommunicate with Internet through one public network address. Managers from different departments can communicate with each other while not among the employees. We recommend you to use the Layer 3 Switches for Distribution Layer and Core Switch and then connect to the Internet by routers. More related: Cisco Integrated Services Router Generation 2 The available power supplies for the Cisco routers How to recover password for the Cisco 1900 and 2900 router? The Difference of The Cisco Catalyst 2900 and Cisco Catalyst 1900 More Cisco products and Reviews you can visit: http://www.3anetwork.com/blog 3Anetwork.com is a world leading Cisco networking products wholesaler, we wholesale original new Cisco networking equipments, including Cisco Catalyst switches, Cisco 7
  • 8. routers, Cisco firewalls, Cisco wireless products, Cisco modules and interface cards products at competitive price and ship to worldwide. Our website: http://www.3anetwork.com Telephone: +852-3069-7733 Email: info@3Anetwork.com Address: 23/F Lucky Plaza, 315-321 Lockhart Road, Wanchai, Hongkong 8