SlideShare ist ein Scribd-Unternehmen logo
1 von 15
SECURING PRIVATE ENVIORNMENT
         BY USING NAT

        PROJECT REPORT
ACKNOWLDGEMENT
The project is based on network addressing translation(nat).
The beauty of configuring nat on routers is that it can help
users access internet on private ip address which are
otherwise excluded by internet service provider(isp).
We have used inter VLAN technology to make work efficient
between 3 different and independent organisations. The
vlans have been divided into web servers and internet
clients.
DESCRIPTION

We have three organisations. Org1, org2 and org3.
Each organisation comprises a router, to route the data from
and to isp. There are manageable switches in each
organisation and we have created separate vlans for servers
and internet clients.
If we want the communication between the internet clients
and servers then we configure inter vlan concept on the
router. And if we want to block some internet clients cannot
access our servers then we create acl for that particular user.
These organisations are linked externally to an isp which
provides live(public) ip addresses to each organisation, and
isp also provides the internet connections to others.
CONFIGURATION

FOR ORG1




%SYS-5-CONFIG_I: Configured frROUTER ORG1
Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname ORG1
ORG1(config)#line console 0
ORG1(config-line)#password net
ORG1(config-line)#login
ORG1(config-line)#exit
ORG1(config)#line vty 0 4
ORG1(config-line)#password net
ORG1(config-line)#login
ORG1(config-line)#exit
ORG1(config)#enable password net
ORG1(config)#enable secret net1
ORG1(config)#int f0/0
ORG1(config-if)#no sh

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
ORG1(config-if)#exit
ORG1(config)#int f0/0.1

%LINK-5-CHANGED: Interface FastEthernet0/0.1, changed state to
upRouter(config-subif)#encapsulation dot1q 2
ORG1(config-subif)#ip nat inside
ORG1(config-subif)#ip address 10.0.0.1 255.0.0.0
ORG1(config-subif)#no sh
ORG1(config-subif)#exit
ORG1(config)#int f0/0.2

ORG1(config-subif)#encapsulation dot1q 3
ORG1(config-subif)#ip nat inside
ORG1(config-subif)#ip address 192.168.10.1 255.255.255.240
ORG1(config-subif)#no sh
ORG1(config-subif)#exit
ORG1(config)#int s0/0/0
ORG1(config-if)#ip nat outside
ORG1(config-if)#clock rate 64000
ORG1(config-if)#ip address 200.10.10.5 255.255.255.252
ORG1(config-if)#no sh

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down
ORG1(config-if)#exit
ORG1(config)#ip route 0.0.0.0 0.0.0.0 serial 0/0/0

We have place our web server in the private area so that the internet client cannot
directly access it. So, we have configured static nat and open port number 80(http)
only.

ORG1(config)#ip nat inside source static tcp 10.0.0.2 80 200.10.10.17 80

In our organisation our clients want to access internet so we will configure
dynamic nat with overload for clients.
ORG1(config)#access-list 20 permit any
ORG1(config)#ip nat pool netmax 200.10.10.18 200.10.10.18 netmask
255.255.255.240
ORG1(config)#ip nat inside source list 20 pool netmax overload
ORG1(config)#exit

ORG1#wr
Building configuration...
[OK]
ORG1#




SWITCH
Switch>en
Switch#vlan database
% Warning: It is recommended to configure VLAN from config mode,
 as VLAN database mode is being deprecated. Please consult user
 documentation for configuring VTP/VLAN in config mode.
Switch(vlan)#vlan 2 name server
VLAN 2 added:
  Name: server
Switch(vlan)#vlan 3 name clients
VLAN 3 added:
  Name: clients
Switch(vlan)#exit
APPLY completed.
Exiting....
Switch#config t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#int f0/1
Switch(config-if)#switchport access vlan 2
Switch(config-if)#exit
Switch(config)#int range f0/2 - 3
Switch(config-if-range)#switchport access vlan 3
Switch(config-if-range)#exit
Switch(config)#int f0/24
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit
Switch(config)#exit
Switch#wr
FOR ORG2

ROUTER
Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname ORG2
ORG2(config)#line console 0
ORG2(config-line)#password net
ORG2(config-line)#login
ORG2(config-line)#exit
ORG2(config)#line vty 0 4
ORG2(config-line)#password net
ORG2(config-line)#login
ORG2(config-line)#exit
ORG2(config)#enable password net
ORG2(config)#enable secret net1
ORG2(config)#int f0/0
ORG2(config-if)#no sh
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
ORG2(config-if)#exit
ORG2(config)#int f0/0.1

%LINK-5-CHANGED: Interface FastEthernet0/0.1, changed state to
upRouter(config-subif)#encapsulation dot1q 2
ORG2(config-subif)#ip nat inside
ORG2(config-subif)#ip address 10.0.0.1 255.0.0.0
ORG2(config-subif)#no sh
ORG2(config-subif)#exit
ORG2(config)#int f0/0.2

ORG2(config-subif)#encapsulation dot1q 3
ORG2(config-subif)#ip nat inside
ORG2(config-subif)#ip address 192.168.10.1 255.255.255.240
ORG2(config-subif)#no sh
ORG2(config-subif)#exit
ORG2(config)#int s0/0/0
ORG2(config-if)#ip nat outside
ORG2(config-if)#clock rate 64000
ORG2(config-if)#ip address 200.10.10.9 255.255.255.252
ORG2(config-if)#no sh
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down
ORG2(config-if)#exit
ORG2(config)#ip route 0.0.0.0 0.0.0.0 serial 0/0/0
ORG2(config)#ip nat inside source static 10.0.0.2 200.10.10.33
ORG2(config)#access-list 20 permit any
ORG2(config)#ip nat pool netmax 200.10.10.34 200.10.10.36 netmask
255.255.255.240
ORG2(config)#ip nat inside source list 20 pool netmax
ORG2(config)#exit
%SYS-5-CONFIG_I: Configured from console by console
ORG2#wr
Building configuration...
[OK]
ORG2#




SWITCH
Switch>en
Switch#vlan database
% Warning: It is recommended to configure VLAN from config mode,
 as VLAN database mode is being deprecated. Please consult user
 documentation for configuring VTP/VLAN in config mode.
Switch(vlan)#vlan 2 name server
VLAN 2 added:
  Name: server
Switch(vlan)#vlan 3 name clients
VLAN 3 added:
  Name: clients
Switch(vlan)#exit
APPLY completed.
Exiting....
Switch#config t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#int f0/1
Switch(config-if)#switchport access vlan 2
Switch(config-if)#exit
Switch(config)#int range f0/2 - 3
Switch(config-if-range)#switchport access vlan 3
Switch(config-if-range)#exit
Switch(config)#int f0/24
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit
Switch(config)#exit
Switch#wr
FOR ORG3

ROUTER
Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname ORG3
ORG3(config)#line console 0
ORG3(config-line)#password net
ORG3(config-line)#login
ORG3(config-line)#exit
ORG3(config)#line vty 0 4
ORG3(config-line)#password net
ORG3(config-line)#login
ORG3(config-line)#exit
ORG3(config)#enable password net
ORG3(config)#enable secret net1
ORG3(config)#int f0/0
ORG3(config-if)#no sh
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
ORG3(config-if)#exit
ORG3(config)#int f0/0.1

%LINK-5-CHANGED: Interface FastEthernet0/0.1, changed state to
upRouter(config-subif)#encapsulation dot1q 2
ORG3(config-subif)#ip nat inside
ORG3(config-subif)#ip address 10.0.0.1 255.0.0.0
ORG3(config-subif)#no sh
ORG3(config-subif)#exit
ORG3(config)#int f0/0.2
ORG3(config-subif)#encapsulation dot1q 3
ORG3(config-subif)#ip nat inside
ORG3(config-subif)#ip address 192.168.10.1 255.255.255.240
ORG3(config-subif)#no sh
ORG3(config-subif)#exit
ORG3(config)#int s0/0/0
ORG3(config-if)#ip nat outside
ORG3(config-if)#clock rate 64000
ORG3(config-if)#ip address 200.10.10.13 255.255.255.252
ORG3(config-if)#no sh

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down
ORG3(config-if)#exit
ORG3(config)#ip route 0.0.0.0 0.0.0.0 serial 0/0/0
ORG3(config)#ip nat inside source static 10.0.0.2 200.10.10.50
ORG3(config)#access-list 20 permit any
ORG3(config)#ip nat pool netmax 200.10.10.51 200.10.10.51 netmask
255.255.255.240
ORG3(config)#ip nat inside source list 20 pool netmax overload
ORG3(config)#exit
%SYS-5-CONFIG_I: Configured from console by console
ORG3#wr
Building configuration...
[OK]
ORG3#



SWITCH
Switch>en
Switch#vlan database
% Warning: It is recommended to configure VLAN from config mode,
 as VLAN database mode is being deprecated. Please consult user
 documentation for configuring VTP/VLAN in config mode.
Switch(vlan)#vlan 2 name server
VLAN 2 added:
  Name: server
Switch(vlan)#vlan 3 name clients
VLAN 3 added:
  Name: clients
Switch(vlan)#exit
APPLY completed.
Exiting....
Switch#config t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#int f0/1
Switch(config-if)#switchport access vlan 2
Switch(config-if)#exit
Switch(config)#int range f0/2 - 3
Switch(config-if-range)#switchport access vlan 3
Switch(config-if-range)#exit
Switch(config)#int f0/24
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit
Switch(config)#exit
Switch#wr
REFERENCES

 •   Wikipedia
 •   Google
 •   www.edu.ac.in
 •   NETMAX TECHNOLOGIES
 •   CISCO

Weitere ähnliche Inhalte

Was ist angesagt?

Packet Tracer Tutorial # 2
Packet Tracer Tutorial # 2Packet Tracer Tutorial # 2
Packet Tracer Tutorial # 2Abdul Basit
 
Cisco commands List for Beginners (CCNA, CCNP)
Cisco commands List for Beginners (CCNA, CCNP)Cisco commands List for Beginners (CCNA, CCNP)
Cisco commands List for Beginners (CCNA, CCNP)DH Da Lat
 
Cisco switch commands cheat sheet
Cisco switch commands cheat sheetCisco switch commands cheat sheet
Cisco switch commands cheat sheet3Anetwork com
 
How to create and delete vlan on cisco catalyst switch
How to create and delete vlan on cisco catalyst switchHow to create and delete vlan on cisco catalyst switch
How to create and delete vlan on cisco catalyst switchIT Tech
 
CCNA - Routing & Switching Commands
CCNA - Routing & Switching CommandsCCNA - Routing & Switching Commands
CCNA - Routing & Switching CommandsEng. Emad Al-Atoum
 
Ncat ccna cheat sheet
Ncat ccna cheat sheetNcat ccna cheat sheet
Ncat ccna cheat sheetEZREIG OMAR
 
Cisco router command configuration overview
Cisco router command configuration overviewCisco router command configuration overview
Cisco router command configuration overview3Anetwork com
 
First Hop Redundancy Protocols in IPv6 HSRP + GLBP
First Hop Redundancy Protocols in IPv6 HSRP + GLBPFirst Hop Redundancy Protocols in IPv6 HSRP + GLBP
First Hop Redundancy Protocols in IPv6 HSRP + GLBPIT Tech
 
Composants et fonctionnement d'un Switch Cisco
Composants et fonctionnement d'un Switch Cisco Composants et fonctionnement d'un Switch Cisco
Composants et fonctionnement d'un Switch Cisco DJENNA AMIR
 
STP (spanning tree protocol)
STP (spanning tree protocol)STP (spanning tree protocol)
STP (spanning tree protocol)Netwax Lab
 
2.3.1.5 packet tracer configuring rapid pvst+ answer
2.3.1.5 packet tracer   configuring rapid pvst+ answer2.3.1.5 packet tracer   configuring rapid pvst+ answer
2.3.1.5 packet tracer configuring rapid pvst+ answerNarayana Samy
 
Packet Tracer: WAN, point to point links.
Packet Tracer: WAN, point to point links.Packet Tracer: WAN, point to point links.
Packet Tracer: WAN, point to point links.Rafat Khandaker
 

Was ist angesagt? (20)

Packet Tracer Tutorial # 2
Packet Tracer Tutorial # 2Packet Tracer Tutorial # 2
Packet Tracer Tutorial # 2
 
Cisco commands List for Beginners (CCNA, CCNP)
Cisco commands List for Beginners (CCNA, CCNP)Cisco commands List for Beginners (CCNA, CCNP)
Cisco commands List for Beginners (CCNA, CCNP)
 
Layer 3 redundancy hsrp
Layer 3 redundancy   hsrpLayer 3 redundancy   hsrp
Layer 3 redundancy hsrp
 
Cisco switch commands cheat sheet
Cisco switch commands cheat sheetCisco switch commands cheat sheet
Cisco switch commands cheat sheet
 
How to create and delete vlan on cisco catalyst switch
How to create and delete vlan on cisco catalyst switchHow to create and delete vlan on cisco catalyst switch
How to create and delete vlan on cisco catalyst switch
 
CCNA - Routing & Switching Commands
CCNA - Routing & Switching CommandsCCNA - Routing & Switching Commands
CCNA - Routing & Switching Commands
 
Ncat ccna cheat sheet
Ncat ccna cheat sheetNcat ccna cheat sheet
Ncat ccna cheat sheet
 
Ccnp3 lab 3_4_en
Ccnp3 lab 3_4_enCcnp3 lab 3_4_en
Ccnp3 lab 3_4_en
 
Cisco router command configuration overview
Cisco router command configuration overviewCisco router command configuration overview
Cisco router command configuration overview
 
ccna cheat_sheet
ccna cheat_sheetccna cheat_sheet
ccna cheat_sheet
 
First Hop Redundancy Protocols in IPv6 HSRP + GLBP
First Hop Redundancy Protocols in IPv6 HSRP + GLBPFirst Hop Redundancy Protocols in IPv6 HSRP + GLBP
First Hop Redundancy Protocols in IPv6 HSRP + GLBP
 
Vrrp
VrrpVrrp
Vrrp
 
Ccnpswitch
CcnpswitchCcnpswitch
Ccnpswitch
 
Composants et fonctionnement d'un Switch Cisco
Composants et fonctionnement d'un Switch Cisco Composants et fonctionnement d'un Switch Cisco
Composants et fonctionnement d'un Switch Cisco
 
Basic Configurations on Router
Basic Configurations on RouterBasic Configurations on Router
Basic Configurations on Router
 
STP (spanning tree protocol)
STP (spanning tree protocol)STP (spanning tree protocol)
STP (spanning tree protocol)
 
2.3.1.5 packet tracer configuring rapid pvst+ answer
2.3.1.5 packet tracer   configuring rapid pvst+ answer2.3.1.5 packet tracer   configuring rapid pvst+ answer
2.3.1.5 packet tracer configuring rapid pvst+ answer
 
Packet Tracer: WAN, point to point links.
Packet Tracer: WAN, point to point links.Packet Tracer: WAN, point to point links.
Packet Tracer: WAN, point to point links.
 
Chapter13ccna
Chapter13ccnaChapter13ccna
Chapter13ccna
 
Ccna Imp Guide
Ccna Imp GuideCcna Imp Guide
Ccna Imp Guide
 

Andere mochten auch

презентация метод вертебропластика
презентация метод вертебропластикапрезентация метод вертебропластика
презентация метод вертебропластикаvalerasuccess
 
Tester cards evidence template
Tester cards evidence templateTester cards evidence template
Tester cards evidence templateChloeandRachel
 
Catalogo infissi in legno profinagency
Catalogo infissi in legno profinagencyCatalogo infissi in legno profinagency
Catalogo infissi in legno profinagencyProgettieFinanza
 
Course 14 days-5-march-2013
Course 14 days-5-march-2013Course 14 days-5-march-2013
Course 14 days-5-march-2013Galina Perova
 
Catalogo infissi in alluminio e pvc profinagency
Catalogo infissi in alluminio e pvc profinagencyCatalogo infissi in alluminio e pvc profinagency
Catalogo infissi in alluminio e pvc profinagencyProgettieFinanza
 
Hot Latina Stereotype
Hot Latina StereotypeHot Latina Stereotype
Hot Latina StereotypeSkylar Smith
 
Ask the XPages Experts
Ask the XPages ExpertsAsk the XPages Experts
Ask the XPages ExpertsTeamstudio
 
Working To A Brief Pro Forma
Working To A Brief Pro FormaWorking To A Brief Pro Forma
Working To A Brief Pro FormaChloeandRachel
 
Mini Evaluation (Posters)
Mini Evaluation (Posters)Mini Evaluation (Posters)
Mini Evaluation (Posters)ChloeandRachel
 
Firm level determinants to small and medium sized enterprises’ access to fina...
Firm level determinants to small and medium sized enterprises’ access to fina...Firm level determinants to small and medium sized enterprises’ access to fina...
Firm level determinants to small and medium sized enterprises’ access to fina...rrpidani
 

Andere mochten auch (15)

презентация метод вертебропластика
презентация метод вертебропластикапрезентация метод вертебропластика
презентация метод вертебропластика
 
Basic concepts in_matlab
Basic concepts in_matlabBasic concepts in_matlab
Basic concepts in_matlab
 
Tester cards evidence template
Tester cards evidence templateTester cards evidence template
Tester cards evidence template
 
Nat report1
Nat report1Nat report1
Nat report1
 
Catalogo infissi in legno profinagency
Catalogo infissi in legno profinagencyCatalogo infissi in legno profinagency
Catalogo infissi in legno profinagency
 
Course 14 days-5-march-2013
Course 14 days-5-march-2013Course 14 days-5-march-2013
Course 14 days-5-march-2013
 
Jaringan
JaringanJaringan
Jaringan
 
Catalogo infissi in alluminio e pvc profinagency
Catalogo infissi in alluminio e pvc profinagencyCatalogo infissi in alluminio e pvc profinagency
Catalogo infissi in alluminio e pvc profinagency
 
Hot Latina Stereotype
Hot Latina StereotypeHot Latina Stereotype
Hot Latina Stereotype
 
Ask the XPages Experts
Ask the XPages ExpertsAsk the XPages Experts
Ask the XPages Experts
 
Grindingmachine
GrindingmachineGrindingmachine
Grindingmachine
 
Working To A Brief Pro Forma
Working To A Brief Pro FormaWorking To A Brief Pro Forma
Working To A Brief Pro Forma
 
Healthy eating
Healthy eatingHealthy eating
Healthy eating
 
Mini Evaluation (Posters)
Mini Evaluation (Posters)Mini Evaluation (Posters)
Mini Evaluation (Posters)
 
Firm level determinants to small and medium sized enterprises’ access to fina...
Firm level determinants to small and medium sized enterprises’ access to fina...Firm level determinants to small and medium sized enterprises’ access to fina...
Firm level determinants to small and medium sized enterprises’ access to fina...
 

Ähnlich wie Nat report2

Introduction 140318015826-phpapp01
Introduction 140318015826-phpapp01Introduction 140318015826-phpapp01
Introduction 140318015826-phpapp01amit singh
 
ccna summer training ppt ( Cisco certified network analysis) ppt. by Traun k...
ccna summer training ppt ( Cisco certified network analysis) ppt.  by Traun k...ccna summer training ppt ( Cisco certified network analysis) ppt.  by Traun k...
ccna summer training ppt ( Cisco certified network analysis) ppt. by Traun k...Tarun Khaneja
 
CCNA- Router on stick, VLAN and Trunking
CCNA- Router on stick, VLAN and TrunkingCCNA- Router on stick, VLAN and Trunking
CCNA- Router on stick, VLAN and TrunkingRafat Khandaker
 
Ccna 4 final lab switchi
Ccna 4 final lab switchiCcna 4 final lab switchi
Ccna 4 final lab switchiLeandro Uglar
 
VIRTUAL LANS
VIRTUAL LANSVIRTUAL LANS
VIRTUAL LANSanilinvns
 
Day 5 VIRTUAL LANS
Day 5 VIRTUAL LANSDay 5 VIRTUAL LANS
Day 5 VIRTUAL LANSanilinvns
 
Virtual LAN and Vlan Trunking Protocol.pptx
Virtual LAN and Vlan Trunking Protocol.pptxVirtual LAN and Vlan Trunking Protocol.pptx
Virtual LAN and Vlan Trunking Protocol.pptxmarunkumareee77
 
CCN3Switching_lab_5_5_2
CCN3Switching_lab_5_5_2CCN3Switching_lab_5_5_2
CCN3Switching_lab_5_5_2alan moreno
 
ccna project on topic company infrastructure
ccna project on topic company infrastructureccna project on topic company infrastructure
ccna project on topic company infrastructurePrince Gautam
 
How to Configure QinQ?
How to Configure QinQ?How to Configure QinQ?
How to Configure QinQ?Huanetwork
 
Communication & switching networks lab manual
Communication & switching networks lab manualCommunication & switching networks lab manual
Communication & switching networks lab manualMUSAAB HASAN
 
Enterprise Network Manager: the Router-On-A-stick
Enterprise Network Manager: the Router-On-A-stickEnterprise Network Manager: the Router-On-A-stick
Enterprise Network Manager: the Router-On-A-stick3Anetwork com
 
(2) documents e books_cisco_networking_books_training_materials_cnap_-_ont_v5...
(2) documents e books_cisco_networking_books_training_materials_cnap_-_ont_v5...(2) documents e books_cisco_networking_books_training_materials_cnap_-_ont_v5...
(2) documents e books_cisco_networking_books_training_materials_cnap_-_ont_v5...Lary Onyeka
 
Network Design on cisco packet tracer 6.0
Network Design on cisco packet tracer 6.0Network Design on cisco packet tracer 6.0
Network Design on cisco packet tracer 6.0Saurav Pandey
 

Ähnlich wie Nat report2 (20)

corporate network
corporate networkcorporate network
corporate network
 
Introduction 140318015826-phpapp01
Introduction 140318015826-phpapp01Introduction 140318015826-phpapp01
Introduction 140318015826-phpapp01
 
ccna summer training ppt ( Cisco certified network analysis) ppt. by Traun k...
ccna summer training ppt ( Cisco certified network analysis) ppt.  by Traun k...ccna summer training ppt ( Cisco certified network analysis) ppt.  by Traun k...
ccna summer training ppt ( Cisco certified network analysis) ppt. by Traun k...
 
CCNA- Router on stick, VLAN and Trunking
CCNA- Router on stick, VLAN and TrunkingCCNA- Router on stick, VLAN and Trunking
CCNA- Router on stick, VLAN and Trunking
 
Ccna 4 final lab switchi
Ccna 4 final lab switchiCcna 4 final lab switchi
Ccna 4 final lab switchi
 
VIRTUAL LANS
VIRTUAL LANSVIRTUAL LANS
VIRTUAL LANS
 
Day 5 VIRTUAL LANS
Day 5 VIRTUAL LANSDay 5 VIRTUAL LANS
Day 5 VIRTUAL LANS
 
Zxdsl 9210 guide
Zxdsl 9210 guideZxdsl 9210 guide
Zxdsl 9210 guide
 
Virtual LAN and Vlan Trunking Protocol.pptx
Virtual LAN and Vlan Trunking Protocol.pptxVirtual LAN and Vlan Trunking Protocol.pptx
Virtual LAN and Vlan Trunking Protocol.pptx
 
3 2
3 23 2
3 2
 
CCN3Switching_lab_5_5_2
CCN3Switching_lab_5_5_2CCN3Switching_lab_5_5_2
CCN3Switching_lab_5_5_2
 
ccna project on topic company infrastructure
ccna project on topic company infrastructureccna project on topic company infrastructure
ccna project on topic company infrastructure
 
How to Configure QinQ?
How to Configure QinQ?How to Configure QinQ?
How to Configure QinQ?
 
Communication & switching networks lab manual
Communication & switching networks lab manualCommunication & switching networks lab manual
Communication & switching networks lab manual
 
Day 14.2 inter vlan
Day 14.2 inter vlanDay 14.2 inter vlan
Day 14.2 inter vlan
 
Ccna 9
Ccna  9Ccna  9
Ccna 9
 
Enterprise Network Manager: the Router-On-A-stick
Enterprise Network Manager: the Router-On-A-stickEnterprise Network Manager: the Router-On-A-stick
Enterprise Network Manager: the Router-On-A-stick
 
Lab6.4.1
Lab6.4.1Lab6.4.1
Lab6.4.1
 
(2) documents e books_cisco_networking_books_training_materials_cnap_-_ont_v5...
(2) documents e books_cisco_networking_books_training_materials_cnap_-_ont_v5...(2) documents e books_cisco_networking_books_training_materials_cnap_-_ont_v5...
(2) documents e books_cisco_networking_books_training_materials_cnap_-_ont_v5...
 
Network Design on cisco packet tracer 6.0
Network Design on cisco packet tracer 6.0Network Design on cisco packet tracer 6.0
Network Design on cisco packet tracer 6.0
 

Mehr von Davinder Chauhan (7)

old age
old ageold age
old age
 
Sports nutrition
Sports nutrition Sports nutrition
Sports nutrition
 
Nat 03
Nat 03Nat 03
Nat 03
 
Nat report103
Nat report103Nat report103
Nat report103
 
Nat report
Nat reportNat report
Nat report
 
Nat report 1
Nat report 1Nat report 1
Nat report 1
 
Nat 07
Nat 07Nat 07
Nat 07
 

Kürzlich hochgeladen

What's New in Teams Calling, Meetings and Devices March 2024
What's New in Teams Calling, Meetings and Devices March 2024What's New in Teams Calling, Meetings and Devices March 2024
What's New in Teams Calling, Meetings and Devices March 2024Stephanie Beckett
 
Powerpoint exploring the locations used in television show Time Clash
Powerpoint exploring the locations used in television show Time ClashPowerpoint exploring the locations used in television show Time Clash
Powerpoint exploring the locations used in television show Time Clashcharlottematthew16
 
New from BookNet Canada for 2024: BNC CataList - Tech Forum 2024
New from BookNet Canada for 2024: BNC CataList - Tech Forum 2024New from BookNet Canada for 2024: BNC CataList - Tech Forum 2024
New from BookNet Canada for 2024: BNC CataList - Tech Forum 2024BookNet Canada
 
Human Factors of XR: Using Human Factors to Design XR Systems
Human Factors of XR: Using Human Factors to Design XR SystemsHuman Factors of XR: Using Human Factors to Design XR Systems
Human Factors of XR: Using Human Factors to Design XR SystemsMark Billinghurst
 
Anypoint Exchange: It’s Not Just a Repo!
Anypoint Exchange: It’s Not Just a Repo!Anypoint Exchange: It’s Not Just a Repo!
Anypoint Exchange: It’s Not Just a Repo!Manik S Magar
 
Developer Data Modeling Mistakes: From Postgres to NoSQL
Developer Data Modeling Mistakes: From Postgres to NoSQLDeveloper Data Modeling Mistakes: From Postgres to NoSQL
Developer Data Modeling Mistakes: From Postgres to NoSQLScyllaDB
 
CloudStudio User manual (basic edition):
CloudStudio User manual (basic edition):CloudStudio User manual (basic edition):
CloudStudio User manual (basic edition):comworks
 
Hyperautomation and AI/ML: A Strategy for Digital Transformation Success.pdf
Hyperautomation and AI/ML: A Strategy for Digital Transformation Success.pdfHyperautomation and AI/ML: A Strategy for Digital Transformation Success.pdf
Hyperautomation and AI/ML: A Strategy for Digital Transformation Success.pdfPrecisely
 
How AI, OpenAI, and ChatGPT impact business and software.
How AI, OpenAI, and ChatGPT impact business and software.How AI, OpenAI, and ChatGPT impact business and software.
How AI, OpenAI, and ChatGPT impact business and software.Curtis Poe
 
"Debugging python applications inside k8s environment", Andrii Soldatenko
"Debugging python applications inside k8s environment", Andrii Soldatenko"Debugging python applications inside k8s environment", Andrii Soldatenko
"Debugging python applications inside k8s environment", Andrii SoldatenkoFwdays
 
DevoxxFR 2024 Reproducible Builds with Apache Maven
DevoxxFR 2024 Reproducible Builds with Apache MavenDevoxxFR 2024 Reproducible Builds with Apache Maven
DevoxxFR 2024 Reproducible Builds with Apache MavenHervé Boutemy
 
From Family Reminiscence to Scholarly Archive .
From Family Reminiscence to Scholarly Archive .From Family Reminiscence to Scholarly Archive .
From Family Reminiscence to Scholarly Archive .Alan Dix
 
Streamlining Python Development: A Guide to a Modern Project Setup
Streamlining Python Development: A Guide to a Modern Project SetupStreamlining Python Development: A Guide to a Modern Project Setup
Streamlining Python Development: A Guide to a Modern Project SetupFlorian Wilhelm
 
SIP trunking in Janus @ Kamailio World 2024
SIP trunking in Janus @ Kamailio World 2024SIP trunking in Janus @ Kamailio World 2024
SIP trunking in Janus @ Kamailio World 2024Lorenzo Miniero
 
Ensuring Technical Readiness For Copilot in Microsoft 365
Ensuring Technical Readiness For Copilot in Microsoft 365Ensuring Technical Readiness For Copilot in Microsoft 365
Ensuring Technical Readiness For Copilot in Microsoft 3652toLead Limited
 
Take control of your SAP testing with UiPath Test Suite
Take control of your SAP testing with UiPath Test SuiteTake control of your SAP testing with UiPath Test Suite
Take control of your SAP testing with UiPath Test SuiteDianaGray10
 
Vertex AI Gemini Prompt Engineering Tips
Vertex AI Gemini Prompt Engineering TipsVertex AI Gemini Prompt Engineering Tips
Vertex AI Gemini Prompt Engineering TipsMiki Katsuragi
 
Dev Dives: Streamline document processing with UiPath Studio Web
Dev Dives: Streamline document processing with UiPath Studio WebDev Dives: Streamline document processing with UiPath Studio Web
Dev Dives: Streamline document processing with UiPath Studio WebUiPathCommunity
 

Kürzlich hochgeladen (20)

What's New in Teams Calling, Meetings and Devices March 2024
What's New in Teams Calling, Meetings and Devices March 2024What's New in Teams Calling, Meetings and Devices March 2024
What's New in Teams Calling, Meetings and Devices March 2024
 
Powerpoint exploring the locations used in television show Time Clash
Powerpoint exploring the locations used in television show Time ClashPowerpoint exploring the locations used in television show Time Clash
Powerpoint exploring the locations used in television show Time Clash
 
New from BookNet Canada for 2024: BNC CataList - Tech Forum 2024
New from BookNet Canada for 2024: BNC CataList - Tech Forum 2024New from BookNet Canada for 2024: BNC CataList - Tech Forum 2024
New from BookNet Canada for 2024: BNC CataList - Tech Forum 2024
 
Human Factors of XR: Using Human Factors to Design XR Systems
Human Factors of XR: Using Human Factors to Design XR SystemsHuman Factors of XR: Using Human Factors to Design XR Systems
Human Factors of XR: Using Human Factors to Design XR Systems
 
Anypoint Exchange: It’s Not Just a Repo!
Anypoint Exchange: It’s Not Just a Repo!Anypoint Exchange: It’s Not Just a Repo!
Anypoint Exchange: It’s Not Just a Repo!
 
Developer Data Modeling Mistakes: From Postgres to NoSQL
Developer Data Modeling Mistakes: From Postgres to NoSQLDeveloper Data Modeling Mistakes: From Postgres to NoSQL
Developer Data Modeling Mistakes: From Postgres to NoSQL
 
CloudStudio User manual (basic edition):
CloudStudio User manual (basic edition):CloudStudio User manual (basic edition):
CloudStudio User manual (basic edition):
 
Hyperautomation and AI/ML: A Strategy for Digital Transformation Success.pdf
Hyperautomation and AI/ML: A Strategy for Digital Transformation Success.pdfHyperautomation and AI/ML: A Strategy for Digital Transformation Success.pdf
Hyperautomation and AI/ML: A Strategy for Digital Transformation Success.pdf
 
E-Vehicle_Hacking_by_Parul Sharma_null_owasp.pptx
E-Vehicle_Hacking_by_Parul Sharma_null_owasp.pptxE-Vehicle_Hacking_by_Parul Sharma_null_owasp.pptx
E-Vehicle_Hacking_by_Parul Sharma_null_owasp.pptx
 
How AI, OpenAI, and ChatGPT impact business and software.
How AI, OpenAI, and ChatGPT impact business and software.How AI, OpenAI, and ChatGPT impact business and software.
How AI, OpenAI, and ChatGPT impact business and software.
 
"Debugging python applications inside k8s environment", Andrii Soldatenko
"Debugging python applications inside k8s environment", Andrii Soldatenko"Debugging python applications inside k8s environment", Andrii Soldatenko
"Debugging python applications inside k8s environment", Andrii Soldatenko
 
DMCC Future of Trade Web3 - Special Edition
DMCC Future of Trade Web3 - Special EditionDMCC Future of Trade Web3 - Special Edition
DMCC Future of Trade Web3 - Special Edition
 
DevoxxFR 2024 Reproducible Builds with Apache Maven
DevoxxFR 2024 Reproducible Builds with Apache MavenDevoxxFR 2024 Reproducible Builds with Apache Maven
DevoxxFR 2024 Reproducible Builds with Apache Maven
 
From Family Reminiscence to Scholarly Archive .
From Family Reminiscence to Scholarly Archive .From Family Reminiscence to Scholarly Archive .
From Family Reminiscence to Scholarly Archive .
 
Streamlining Python Development: A Guide to a Modern Project Setup
Streamlining Python Development: A Guide to a Modern Project SetupStreamlining Python Development: A Guide to a Modern Project Setup
Streamlining Python Development: A Guide to a Modern Project Setup
 
SIP trunking in Janus @ Kamailio World 2024
SIP trunking in Janus @ Kamailio World 2024SIP trunking in Janus @ Kamailio World 2024
SIP trunking in Janus @ Kamailio World 2024
 
Ensuring Technical Readiness For Copilot in Microsoft 365
Ensuring Technical Readiness For Copilot in Microsoft 365Ensuring Technical Readiness For Copilot in Microsoft 365
Ensuring Technical Readiness For Copilot in Microsoft 365
 
Take control of your SAP testing with UiPath Test Suite
Take control of your SAP testing with UiPath Test SuiteTake control of your SAP testing with UiPath Test Suite
Take control of your SAP testing with UiPath Test Suite
 
Vertex AI Gemini Prompt Engineering Tips
Vertex AI Gemini Prompt Engineering TipsVertex AI Gemini Prompt Engineering Tips
Vertex AI Gemini Prompt Engineering Tips
 
Dev Dives: Streamline document processing with UiPath Studio Web
Dev Dives: Streamline document processing with UiPath Studio WebDev Dives: Streamline document processing with UiPath Studio Web
Dev Dives: Streamline document processing with UiPath Studio Web
 

Nat report2

  • 1. SECURING PRIVATE ENVIORNMENT BY USING NAT PROJECT REPORT
  • 2.
  • 3. ACKNOWLDGEMENT The project is based on network addressing translation(nat). The beauty of configuring nat on routers is that it can help users access internet on private ip address which are otherwise excluded by internet service provider(isp). We have used inter VLAN technology to make work efficient between 3 different and independent organisations. The vlans have been divided into web servers and internet clients.
  • 4. DESCRIPTION We have three organisations. Org1, org2 and org3. Each organisation comprises a router, to route the data from and to isp. There are manageable switches in each organisation and we have created separate vlans for servers and internet clients. If we want the communication between the internet clients and servers then we configure inter vlan concept on the router. And if we want to block some internet clients cannot access our servers then we create acl for that particular user. These organisations are linked externally to an isp which provides live(public) ip addresses to each organisation, and isp also provides the internet connections to others.
  • 5. CONFIGURATION FOR ORG1 %SYS-5-CONFIG_I: Configured frROUTER ORG1 Router>en Router#config t Enter configuration commands, one per line. End with CNTL/Z. Router(config)#hostname ORG1 ORG1(config)#line console 0 ORG1(config-line)#password net ORG1(config-line)#login ORG1(config-line)#exit ORG1(config)#line vty 0 4 ORG1(config-line)#password net ORG1(config-line)#login ORG1(config-line)#exit
  • 6. ORG1(config)#enable password net ORG1(config)#enable secret net1 ORG1(config)#int f0/0 ORG1(config-if)#no sh %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up ORG1(config-if)#exit ORG1(config)#int f0/0.1 %LINK-5-CHANGED: Interface FastEthernet0/0.1, changed state to upRouter(config-subif)#encapsulation dot1q 2 ORG1(config-subif)#ip nat inside ORG1(config-subif)#ip address 10.0.0.1 255.0.0.0 ORG1(config-subif)#no sh ORG1(config-subif)#exit ORG1(config)#int f0/0.2 ORG1(config-subif)#encapsulation dot1q 3 ORG1(config-subif)#ip nat inside ORG1(config-subif)#ip address 192.168.10.1 255.255.255.240 ORG1(config-subif)#no sh ORG1(config-subif)#exit ORG1(config)#int s0/0/0 ORG1(config-if)#ip nat outside ORG1(config-if)#clock rate 64000 ORG1(config-if)#ip address 200.10.10.5 255.255.255.252 ORG1(config-if)#no sh %LINK-5-CHANGED: Interface Serial0/0/0, changed state to down ORG1(config-if)#exit ORG1(config)#ip route 0.0.0.0 0.0.0.0 serial 0/0/0 We have place our web server in the private area so that the internet client cannot directly access it. So, we have configured static nat and open port number 80(http) only. ORG1(config)#ip nat inside source static tcp 10.0.0.2 80 200.10.10.17 80 In our organisation our clients want to access internet so we will configure dynamic nat with overload for clients.
  • 7. ORG1(config)#access-list 20 permit any ORG1(config)#ip nat pool netmax 200.10.10.18 200.10.10.18 netmask 255.255.255.240 ORG1(config)#ip nat inside source list 20 pool netmax overload ORG1(config)#exit ORG1#wr Building configuration... [OK] ORG1# SWITCH
  • 8. Switch>en Switch#vlan database % Warning: It is recommended to configure VLAN from config mode, as VLAN database mode is being deprecated. Please consult user documentation for configuring VTP/VLAN in config mode. Switch(vlan)#vlan 2 name server VLAN 2 added: Name: server Switch(vlan)#vlan 3 name clients VLAN 3 added: Name: clients Switch(vlan)#exit APPLY completed. Exiting.... Switch#config t Enter configuration commands, one per line. End with CNTL/Z. Switch(config)#int f0/1 Switch(config-if)#switchport access vlan 2 Switch(config-if)#exit Switch(config)#int range f0/2 - 3 Switch(config-if-range)#switchport access vlan 3 Switch(config-if-range)#exit Switch(config)#int f0/24 Switch(config-if)#switchport mode trunk Switch(config-if)#exit Switch(config)#exit Switch#wr
  • 9. FOR ORG2 ROUTER Router>en Router#config t Enter configuration commands, one per line. End with CNTL/Z. Router(config)#hostname ORG2 ORG2(config)#line console 0 ORG2(config-line)#password net ORG2(config-line)#login ORG2(config-line)#exit ORG2(config)#line vty 0 4 ORG2(config-line)#password net ORG2(config-line)#login ORG2(config-line)#exit ORG2(config)#enable password net ORG2(config)#enable secret net1 ORG2(config)#int f0/0 ORG2(config-if)#no sh %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up ORG2(config-if)#exit ORG2(config)#int f0/0.1 %LINK-5-CHANGED: Interface FastEthernet0/0.1, changed state to upRouter(config-subif)#encapsulation dot1q 2 ORG2(config-subif)#ip nat inside ORG2(config-subif)#ip address 10.0.0.1 255.0.0.0 ORG2(config-subif)#no sh ORG2(config-subif)#exit ORG2(config)#int f0/0.2 ORG2(config-subif)#encapsulation dot1q 3 ORG2(config-subif)#ip nat inside ORG2(config-subif)#ip address 192.168.10.1 255.255.255.240 ORG2(config-subif)#no sh ORG2(config-subif)#exit
  • 10. ORG2(config)#int s0/0/0 ORG2(config-if)#ip nat outside ORG2(config-if)#clock rate 64000 ORG2(config-if)#ip address 200.10.10.9 255.255.255.252 ORG2(config-if)#no sh %LINK-5-CHANGED: Interface Serial0/0/0, changed state to down ORG2(config-if)#exit ORG2(config)#ip route 0.0.0.0 0.0.0.0 serial 0/0/0 ORG2(config)#ip nat inside source static 10.0.0.2 200.10.10.33 ORG2(config)#access-list 20 permit any ORG2(config)#ip nat pool netmax 200.10.10.34 200.10.10.36 netmask 255.255.255.240 ORG2(config)#ip nat inside source list 20 pool netmax ORG2(config)#exit %SYS-5-CONFIG_I: Configured from console by console ORG2#wr Building configuration... [OK] ORG2# SWITCH Switch>en Switch#vlan database % Warning: It is recommended to configure VLAN from config mode, as VLAN database mode is being deprecated. Please consult user documentation for configuring VTP/VLAN in config mode. Switch(vlan)#vlan 2 name server VLAN 2 added: Name: server Switch(vlan)#vlan 3 name clients VLAN 3 added: Name: clients Switch(vlan)#exit APPLY completed. Exiting....
  • 11. Switch#config t Enter configuration commands, one per line. End with CNTL/Z. Switch(config)#int f0/1 Switch(config-if)#switchport access vlan 2 Switch(config-if)#exit Switch(config)#int range f0/2 - 3 Switch(config-if-range)#switchport access vlan 3 Switch(config-if-range)#exit Switch(config)#int f0/24 Switch(config-if)#switchport mode trunk Switch(config-if)#exit Switch(config)#exit Switch#wr
  • 12. FOR ORG3 ROUTER Router>en Router#config t Enter configuration commands, one per line. End with CNTL/Z. Router(config)#hostname ORG3 ORG3(config)#line console 0 ORG3(config-line)#password net ORG3(config-line)#login ORG3(config-line)#exit ORG3(config)#line vty 0 4 ORG3(config-line)#password net ORG3(config-line)#login ORG3(config-line)#exit ORG3(config)#enable password net ORG3(config)#enable secret net1 ORG3(config)#int f0/0 ORG3(config-if)#no sh %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up ORG3(config-if)#exit ORG3(config)#int f0/0.1 %LINK-5-CHANGED: Interface FastEthernet0/0.1, changed state to upRouter(config-subif)#encapsulation dot1q 2 ORG3(config-subif)#ip nat inside ORG3(config-subif)#ip address 10.0.0.1 255.0.0.0 ORG3(config-subif)#no sh ORG3(config-subif)#exit ORG3(config)#int f0/0.2 ORG3(config-subif)#encapsulation dot1q 3 ORG3(config-subif)#ip nat inside ORG3(config-subif)#ip address 192.168.10.1 255.255.255.240 ORG3(config-subif)#no sh ORG3(config-subif)#exit
  • 13. ORG3(config)#int s0/0/0 ORG3(config-if)#ip nat outside ORG3(config-if)#clock rate 64000 ORG3(config-if)#ip address 200.10.10.13 255.255.255.252 ORG3(config-if)#no sh %LINK-5-CHANGED: Interface Serial0/0/0, changed state to down ORG3(config-if)#exit ORG3(config)#ip route 0.0.0.0 0.0.0.0 serial 0/0/0 ORG3(config)#ip nat inside source static 10.0.0.2 200.10.10.50 ORG3(config)#access-list 20 permit any ORG3(config)#ip nat pool netmax 200.10.10.51 200.10.10.51 netmask 255.255.255.240 ORG3(config)#ip nat inside source list 20 pool netmax overload ORG3(config)#exit %SYS-5-CONFIG_I: Configured from console by console ORG3#wr Building configuration... [OK] ORG3# SWITCH Switch>en Switch#vlan database % Warning: It is recommended to configure VLAN from config mode, as VLAN database mode is being deprecated. Please consult user documentation for configuring VTP/VLAN in config mode. Switch(vlan)#vlan 2 name server VLAN 2 added: Name: server Switch(vlan)#vlan 3 name clients VLAN 3 added: Name: clients Switch(vlan)#exit APPLY completed. Exiting.... Switch#config t Enter configuration commands, one per line. End with CNTL/Z.
  • 14. Switch(config)#int f0/1 Switch(config-if)#switchport access vlan 2 Switch(config-if)#exit Switch(config)#int range f0/2 - 3 Switch(config-if-range)#switchport access vlan 3 Switch(config-if-range)#exit Switch(config)#int f0/24 Switch(config-if)#switchport mode trunk Switch(config-if)#exit Switch(config)#exit Switch#wr
  • 15. REFERENCES • Wikipedia • Google • www.edu.ac.in • NETMAX TECHNOLOGIES • CISCO